Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Router worked for awhile and now network is bad

22 Nov 2014   #1
Ramza

Windows 7 x64
 
 
New Router worked for awhile and now network is bad

We bought a Dlinks A/C Router and it was working very well for about 2 weeks and now the network keeps disconnecting and reconnecting. My laptop and one other computer are on the network and the other computer has had no problems. My laptop is an HP laptop, I have an Qualcomm Atheros AR9285 802.11b/g/n WiFi Adapter and have rolled it back and updated it with no effect. I have scanned for everything as well as disc cleaned and defragmented. I have tried changing channels on the router but no difference. The problem in my opinion has to be on the laptop because no other device is having this problem, please help me fix it.


My System SpecsSystem Spec
.
22 Nov 2014   #2
remm

Win 7 Ultimate 64-bit
 
 

Are both computers connected via Wifi, or is the other computer that is staying connected using Ethernet?

EDIT: And have you tried connecting the HP using Ethernet just to see if bypassing the wifi fixes the problem? This would narrow down the cause, making the internal wifi card in the latptop suspect. (But first I would look at the config settings on the wifi card repeatedly. )
My System SpecsSystem Spec
22 Nov 2014   #3
remm

Win 7 Ultimate 64-bit
 
 

Things I would check (and re-check) especially since you've been rolling the driver back and forth... be sure the wifi card is not set to cut power when idle or when using battery. This is under the Power Management tab after clicking the Configure button for the adapter.

Other setting that sometimes can cause signal drop is if the box to "connect even when he network is not broadcasting its name (SSID)" is unchecked. So be sure that's ticked. If you go to Networks and Sharing -> Manage Wireless Networks, then right-click on your Wifi Network -> Properties and you'll see the setting.
My System SpecsSystem Spec
.

23 Nov 2014   #4
Ramza

Windows 7 x64
 
 

I did everything you said and it made no difference, it still disconnects and reconnects. Both computers are wifi

Also I tried to do a speed test and 1/3 times the test times out
My System SpecsSystem Spec
23 Nov 2014   #5
PeaB4YouGo

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

If we all had unlimited wallets, I'd suggest you find a USB WiFi adapter to test with. Maybe someone you know has one?
My System SpecsSystem Spec
23 Nov 2014   #6
Shimshom

Windows 7 Ultimate x64
 
 

Are there any other wireless devices nearby such as a cordless phone as they can interfere with wifi
My System SpecsSystem Spec
23 Nov 2014   #7
remm

Win 7 Ultimate 64-bit
 
 

You said you tried changing wifi channels... you might dbl-check if you are on the best channel by using InSSIDer, a free wifi network scanner. It will show you all wifi networks in the area and suggest the best channel.

Assuming you have not added a cordless phone in the last 2 weeks or any other wireless device that might be interfering, and it worked fine for 2 weeks and now is being flakey, and the channel isn't a problem....

You can get a USB wifi adapter cheap (e.g. Edimax or TP-Link, both for about $8 on Amazon and maybe less on eBay). They are micro adapters so they don't stick out. They are a good solution if you don't feel comfortable opening the machine. Or if you think the problem is temporary -- some kind of glitch that will eventually work itself out. But if you want to replace the wifi card inside the machine, that's a cleaner solution.

My wifi adapter for my Acer laptop cost like $11 off eBay. They aren't expensive if purchased used, pulled from another machine of the same model. Just choose an eBay vendor with a high rating who guarantees they have tested the part.

However you did not say if you tried connecting the laptop with Ethernet to make sure the connection still doesn't drop out. If Ethernet works fine, then it has to be the wifi card in the laptop since the other computer is also connected via wifi and not having a problem (which would tend to eliminate the router). But it doesn't necessarily mean the card went bad.... it could be something funky going on with your ports. (Have you tested all other ports on the machine? e.g. PC Card, USB, flash card ports?)

But before I ordered a new wifi card I'd Google the exact model of the HP laptop (not necessarily the wifi card model, but the laptop model)... along with 'intermittent wifi' or similar.... sometimes laptops have eccentric problems with their particular hardware configurations that others have already worked out.

EDIT: Since the router is new to you.... you say the other computer has no problems with the wifi... is it using the same protocol? For example, is the router broadcasting in g only, n only, or g and n; and are both the computers using g -- or both using n? Or is the computer that is staying connected using a different protocol?
My System SpecsSystem Spec
24 Nov 2014   #8
Ramza

Windows 7 x64
 
 

ok
  • i cant do an ethernet check for reasons (one of which is no ethernet cable)
  • the other computer is using the same things i am as far as network and signal type
  • i tried plugging in an old usb adapter i had and after it was all updated the network bars were less and then connection still dropped in and out (it was a linksys brand usb adapter)
  • i have no cordless phones or any wired phones in my room or near it
i want to try everything i can before i just reset my laptop to "out of the box" where its a clean slate because im at wits end here
My System SpecsSystem Spec
27 Nov 2014   #9
remm

Win 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by Ramza View Post
ok
  • i cant do an ethernet check for reasons (one of which is no ethernet cable)
  • the other computer is using the same things i am as far as network and signal type
  • i tried plugging in an old usb adapter i had and after it was all updated the network bars were less and then connection still dropped in and out (it was a linksys brand usb adapter)
  • i have no cordless phones or any wired phones in my room or near it
i want to try everything i can before i just reset my laptop to "out of the box" where its a clean slate because im at wits end here
If the wifi card is bad, or if it is another problem, reinstalling Windows won't help anyway. That's not generally how to fix this problem.

You say you tried an 'old USB adapter' and got some signal strength, then fewer bars and a lost signal, which sounds similar to what's happening with the internal card. But you also say it worked fine the first 2 weeks... have you moved further from the router? It sounds like the router isn't close enough to you, or strong enough to reach wherever you are using your computer.

Have you tried sitting right next to the router and testing the wifi? If you are sitting right on it and still getting a broken signal and weak bars, then that would eliminate the possibility you are too far away from it.
My System SpecsSystem Spec
28 Nov 2014   #10
Ramza

Windows 7 x64
 
 

i get no problems sitting next to the router and no my location hasnt changed since i got it.

Also it seems that when I get disconnected the bars on the lower right hand of my screen dont go away, like it doesnt show that im being disconnected but i notice cause websites fail to load and when im in chats it says i get disconnected.
My System SpecsSystem Spec
Reply

 New Router worked for awhile and now network is bad




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Yesterday all network connections worked, today - nothing!
I don't get this. One day network connections work, the next they're gone! There must be a solution. I work in Mac 10.7.2 (Lion) as well as Windows 7. It took a little bit but I have shared folders between both computers using a wired network. On the Mac side, everything works but the Windows 7...
Network & Sharing
Can't connect to wireless router! Hasn't worked for days!
Not sure if I'm in the right forum but a couple days ago, my one year old Dell Studio 1558 laptop running windows 7 64bit couldn't connect to my Linksys Router. I think the router model is WRT54G or something like that. But i never had problems before connecting to wifi. It is not the router's...
Network & Sharing
Network 3 pc's and a NAS with a router???
Can anybody please give me some simple advice as to what I would need to set up the following. 1x PC (Mine, and i'd like to the be the admin Win 7 Ultimate X64) with internet access via the router and connected to a NAS 2x PC's Win 7 32bit with internet access via the router and connected to...
Network & Sharing
It's been awhile...
Hi all, i'm back. :) I've been busy with work & stuffs lately. So yeah. Hope all of you are doing great atm. Will try to be active in here like i used too last time. No promises though. With both work & family are my top priority now. Catch up will all of you later. See ya... ;)
Chillout Room
network bridge worked fine, until i switched to XP
i recently had windows 7 ultimate installed and after i had it for a while decded that wanted to switch back to windows xp. while i was using windows 7, i had a network bridge setup so that i could connect to xbox live (had my xbox connedted to my desktop with wifi). it worked flawlessly, but...
Network & Sharing
Seeing another router on my network
We only have one router, a dlink di-614 and are on a wpa2 encryption . But on the netwok page under "network infrastructure" I see another router "wireless N router tl-wr741n" , beside our dlink. should i be concerned?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App