Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet function for applications, but nw says "connected"

13 Dec 2014   #1
gregglee

Windows 7 Home Premium X64 SP1
 
 
No internet function for applications, but nw says "connected"

I wasn't sure what subforum would fit. Browser and email are involved, but broader than that. Probably not hardware, but at this point who knows?

This is long description. Bear with me.

Configuration: Hardware. Two computers connected to router which is connected to Dishnet satellite modem. No local network or homegroup set up. Both machines running Windows 7 sp1 with all updates. The computer I am typing on works fine with full internet functionality. From it I can log onto the router and the modem. Neither indicates a problem. Router shows both computers connected.

On the other computer, which is my wife's computer:

Windows control panel/network&sharing shows network connected with internet access. From cmd prompt I can ping, pathping or traceroute to WAN sites, e.g CNN, amazon, xkcd. Ipconfig shows nothing obviously wrong.

Firefox opens but immediately gives server not found screen for any url, including the router and modem dns addresses. Internet explorer will not successfully open at all. IE window appears but then says not responding, then closes after a minute or so with no further message. Avast (free version) shows warning that one shield is turned off, but does not respond when I select the turn on button. If I open Avast user interface it indicates no internet connection. The Avast warning is odd in that all three shields (file, mail, web) indicate as running. So what is the one that needs to be turned on?

Just before this started, I downloaded a large windows update (appx 25 items for Windows and Office), avast program update to new 2015 version, several adobe updates, flash, java. For some I used the Avast software update utility and some used application updater. All seemed to work. Still had internet function at that point.

Then I tried to find and uninstall the mdnsresponder version of Bonjour (I know what it is) because avast had popped up warning about it (rootkit I think) for past couple days, starting before I ran all the updates. Each time checked "delete (recommended)" from avast warning choices.

I found that the bonjour service (with cryptic numerical name) was already disabled, which I did a couple years ago. Any uninstaller was hidden, so I tried some manual uninstalling. My fooling with it was close to the time that internet connection failed, but I didn't notice exactly when, because the indicator in the taskbar showed, and still shows, connected. I also opened the Avast firewall setup page but didn't do anything, because it appears to be available only in the not-free version.

Eventually I tried to look something up on internet and found the problem.

Turning windows firewall and avast shields off does not fix the problem. Comparing settings between the two computers shows nothing obvious. The good one doesn't even have bonjour or dnsresponder.exe on it.

I have done all I can think of over several hours, except attempt using a restore point, because the last one was before the windows update. With so many changes, I am skeptical that it would succeed in restoring everything. None of the changes made after the windows update appear in affected programs list. Only the windows update items. One of those other changes would be the source of the problem. I'm nervous about making it worse with a failed restore.

Before I make an image of the current state, then try restore point I was hoping this half on half off internet connection would sound familiar to someone, who could aim me in the right direction.


My System SpecsSystem Spec
.
13 Dec 2014   #2
gregglee

Windows 7 Home Premium X64 SP1
 
 

One more clue. Windows update will communicate and download through the internet connection.

However as described above, nothing else I have tried will. Firefox and Avast both say no connection, and IE fails before it gets that far.
My System SpecsSystem Spec
Reply

 No internet function for applications, but nw says "connected"




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Internet working fine, but windows says "Not connected"
Hi, I seem to have a little problem for some time now, I didn't care much about it at the beginning but now it got somewhat sever. So, at some point both my wireless and cable network started showing a not connected icon even though they were connected and Internet worked all fine. So of course I...
Network & Sharing
Connected, but stuck "identifying" with no internet access
Hi there! My compaq laptop has mysteriously change settings or something (read: one of my children probably screwed with something). I have a wireless router and modem (iPad, phones, etc. are all connecting just fine). It tells me I am currently connected to my wireless network connection, but then...
Network & Sharing
"Connected" without Internet Access
I'm using a TP-Link 8810 modem with a switch, with 3 computers attached. Everything was going fine until 2 days ago, when the Windows 7 (64 bit) Dell notebook stopped connecting while the others were connected. In other words, there is a conflict somewhere that I can't find. The router is...
Network & Sharing
Laptop losses internet access, but says "connected" to wireless router
I bought a Cisco Valet M10 wireless router a few days ago and I have been having issues where my laptop says that it is connected to network and it shows maximum strength signal, but underneath the network name it says "No internet access". I have already contacted Cisco several times and also HP,...
Network & Sharing
Lost Internet Connectivity; Connected to "Unidentified Network"
I had Win7 32-bit running on a Dell PC. About one week ago, I noticed Internet connectivity was gone and that there was "limited connectivity" as I was now connected to an "unidentified network". The other systems on the network are still connected and working perfect; the problem is isolated to...
Network & Sharing
The message: " No internet access" The fact: connected
I use Windows 7 RC at work. I connect to the internet over company LAN with static IP and manualy inserted DNS. My internet connection is OK, everything works, but there is a yellow triangle in the connection icon in tray. If I put the cursor over it, I can read: "Network No internet access" I...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App