Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 100mbs speed limit on a Gigabit network to a iSCSI SAN.

23 Dec 2014   #1
bobyell

windows 7 Ultimate 64bit
 
 
100mbs speed limit on a Gigabit network to a iSCSI SAN.

Hi Guys,

I haven't been on this forum until now.

I have a Equallogic PS400 SAN, connected to a Powerconnect 6248 gigbit switch. Everything runs FINE on 2k8 server, Windows 2012r2 and VMware ESXi 5.1.

I created a iSCSI target for my wifes new pc which is based on a Gigbabyte MB, Gigabyte-970a-ud3, with a AMD FX-6100 hexacore CPU 4.2 Ghz , 16gGB DDR3 ram. Boot disks are a pair of SSD 240GB drives striped for even more speed.

Local storage is 4 2TB WD sata3( 6gbs) disks in a stripe for speed. I added a PCIe expansion card for a extra pair of 2TB disks (software striped) also SataIII (6gbs sec)
The network is a quad port Intel vt-100 server class nic. I have NO latency or retransmits on the network, Flow control is on and set up per Equallogic best practices.

There is 2.7 TB of movie ISO's on the 2TB stripe i want to move off to an iSCSI 6TB volume on my san.

Got it?



Here is the kicker , I can easlily move the data from the 2TB stripe to the 8TB stripe using robocopy, teracopy , etc. and it hauls butt and i get 120MB/ sec internal to internal SATA.
Theorectically (and in practice as i have a 2k8 server and 2012 server) i should be able to get 125MBs/ sec on my iSCSI san. I can never get anything more than 12.5MBs / Sec to the iSCSI target, the network transfer maxes out at 100mbs period. No matter what I do , the max network transfer of copying files is 100mbs and 12.5MBs from the windows 7 box. All of my other systems easily get the 100MBs /sec . I read that the issue is a QOS issue with Windows 7 (all of them) I'm running Windows 7 Ultimate 64 bit. I can run IOmeter on the nics to the iscsi target and easily get the 250mbs I would expect. Whenever I try to copy data from either internal stripe to the iSCSI target , it Max's out @ 100mbs and 12.5MBs .

From looking into it more it sounds like a QOS issue with Windows 7 network speed limit. I setup a QOS policy to allow iSCSI port 3260 to have a limit of 600gbs. Still no change , 100mbs / 12.5MBs..

Any ideas?

Thanks in advance

Bob


My System SpecsSystem Spec
.
24 Dec 2014   #2
bobyell

windows 7 Ultimate 64bit
 
 

Can one of the mods move this to the performance thread. Its not a network or sharing issue.Its a performance QOS issue.
My System SpecsSystem Spec
21 Jan 2016   #3
ywuw2486

7 ultimate 64-bit
 
 

Bobyell,
I'm having this same issue, I've ghosted a windows 7 64-bit install from a drive to an ISCSI lun. Works perfectly except that actual disk access never goes above 100mbit/s on Gigabit link. Were you able to find any solution?
My System SpecsSystem Spec
.

Reply

 100mbs speed limit on a Gigabit network to a iSCSI SAN.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Gigabit port speed
Hi all, I have a 100/25 Mbps fiber optic connection with a Technicolor TG784n v3 router and I'm having problems with the speed on the Gigabit port. When I turn the computer off or restart it the speed drops to 50 Mbps. If I connect the PC to one of the other 100 Mbps ports the speed returns to...
Network & Sharing
Gigabit LAN Connection Speed Problem
Most times, after my PC has booted, the Local Area Connection Status dialogue box shows a connection speed of only 100Mbps instead of the 1Gbps that it is designed to run at. My PC does occasionally connect at 1Gbps on a cold boot, usually after Iíve run a registry optimisation programme. This...
Network & Sharing
Gigabit Network Speed Question
I have a desktop workstation with an intel xeon 2.53ghz and 4gb of ddr3 ram, it has a broadcom netxtreme 57xx gigabit controller, and i have an Iomega home media drive, also a gigabit switch. I have my computer connected to the switch and the NAS to the switch as well, all using CAT6 cable....
Network & Sharing
gigabit connection but can only get 400Mb on speed test
ello folks a friend of mine now has a gigabit connection but can only get 400Mb download when tested via speedtest.net. while the engineer was installing everything he noted speeds of 700Mb on the laptop used for the setup. could any of you suggest how he would go about getting better speeds?...
Network & Sharing
Home gigabit LAN speed problem
Hi guys, I have 3 Win7 PC's in a network connected with some D-Link gigabit router and all PC's have gigabit ethernet cards. They all have IP addresses entered and subnet masks. The speed before was great, around 50MB/s. Now one of the PC's has a slower speed. It's now only around 10MB/s when...
Network & Sharing
Gigabit nic stuck at 100mbps in Gigabit network.
Cannot get gigabit performance out of Nics in Win 7.. Locked 100 mbps. My motherboard is an Evga 590 Sli Am2 motherboard, with dual gigabit nics. Having established that there is really no benefit to using both nics at the same time in another post, I am now posting because it seems I am only...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App