Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet browsers not opening or responding

09 Jan 2015   #1
lDarkSnow

Windows 7 Ultimate x64
 
 
Internet browsers not opening or responding

Hey there. Recently on my dads computer, there have been some problems trying to open any internet browser. The only one that responds with anything is Mozilla, which flags an error, saying ''Couldn't load XPCOM". The others are completely unresponsive, not opening or giving errors of any sort.

I've tried several things - it won't let me re/uninstall anything (like the browsers, simply seeming as if I didn't even click it), tried running as admin, and the computer was even restored to a time before the error occurred, to no avail.

The last thing updated was Skype, if that helps. The update and the first time the error started appearing happened to be on the same day (Monday), so I thought that might have something to do with it. Additionally, I can still access Skype and Steam, so the internet seems to be fine. No other computers in the household have the problem.

Any insight on, or fix for the problem would be much appreciated. Thanks in advance, and if you need any additional information, go for it.


My System SpecsSystem Spec
.
09 Jan 2015   #2
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

What happens if you enter Safe mode and try to open them?

Safe Mode
My System SpecsSystem Spec
09 Jan 2015   #3
lDarkSnow

Windows 7 Ultimate x64
 
 

Tried it twice, again to no avail.
My System SpecsSystem Spec
.

31 Jan 2015   #4
lDarkSnow

Windows 7 Ultimate x64
 
 

Bump? It's been weeks, and still no fix.
My System SpecsSystem Spec
31 Jan 2015   #5
PeaB4YouGo

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Here's something I stole from Mozilla support:

I didn't even try uninstalling/reinstalling Firefox, because seemed like it didn't work for you. But here's what DID work: I first logged into a different user account from the one I usually use (but still an administrator account). I revved up Internet Explorer (held my nose), went to the Mozilla site, downloaded Firefox (as if I didn't already have it), installed it, and kazam! Everything worked. Then (and I don't know if this was important or not), before I closed Firefox in that user account, I switched users, went to the account I usually use (and wouldn't load Firefox before), started Firefox, which went fine. Mozilla Support Thread

Go for it.
My System SpecsSystem Spec
31 Jan 2015   #6
lDarkSnow

Windows 7 Ultimate x64
 
 

Unfortuantely, that didn't quite work out. IE still wouldn't load up - and a funny thing - firefox was still installed on the new one. (Though I couldn't uninstall it from that location.) Is there any way to make a completely fresh user, devoid of all files/programs from the original one, for further testing in this regard?

Thanks.
My System SpecsSystem Spec
Reply

 Internet browsers not opening or responding




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Issues With Opening Internet Explorer 9/10 and Maxthon Web Browsers??
Hello. I am having an issue with Windows 7's Internet Explorer 9 (or version 10 too -- I tried what I am going to say here too without any difference to version 9) and Maxthon web browser. Simply, when I click on many hyperlinks of most websites' webpages or even clicking on any on of...
Browsers & Mail
All browsers are not opening
Hi all, I'm new on this forum so please be patient. Working with a Toshiba Satellite L650 laptop with Windows 7 Home Premium 64bit. All of my browsers have suddenly stopped working (IE, Firefox and Chrome). I click on the icon, the "loading" mouse pointer shows up and then nothing happens....
Browsers & Mail
web browsers are not opening
Guys need help, non of my browsers are even opening. Whenever i click on IE or mozila browser icon, no response is there. I need to fill an online exam form .so it is very imp. Kindlysuggest any way out. Iam posting this using my phone
Browsers & Mail
Internet browsers (IE & Chrome) close immediately after opening ???
Hi, Since three days both internet browsers installed on my PC won't start (IE and Chrome). Or rather close immediately after I start them. (I am entering this thread from my office PC) I didn't install any programs in between when they worked and stopped working (did copy files from a...
Browsers & Mail
Internet Explorer8 Not responding after opening first page of website
Hi All I just scanned my computer with anti virus and activated microsoft forefront client security. Since then internet explorer not functioning. I have IE8 installed. When default setting is blank pager, IE opens. Then if click on any website it opens front page and hangs up. Eg: yahoomail...
Browsers & Mail
Internet Browsers "Not Responding"
Ever since I installed the W7 OS (64 bit) about 2 weeks ago I've been having problems while browsing the internet. If I try to watch a video, log in to my school's library site, or sometimes just chat with people via Facebook, I'm almost guaranteed to get the "Not Responding" message, at which...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App