Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't connect to internet after installation.

30 Jan 2015   #1
Terpsichore

Linux Ubuntu 64-bit
 
 
Can't connect to internet after installation.

New install on a new 1Tb hard drive straight out of the wrapping. Win 7 Home Premium 64-bit, OEM DVD bought from Amazon. The internet icon has a red cross on it, meaning no connection, and several re-boots hasn't cured it. But there is nothing wrong with my connection. I have a second hard drive which if I boot from it I connect instantly. How can I resolve this?


My System SpecsSystem Spec
.
30 Jan 2015   #2
doctore

Windows 7 Pro
 
 

are any questionmarks showing in Device Manager?
My System SpecsSystem Spec
30 Jan 2015   #3
Berkey

Microsoft Windows 7 Professional 64-bit SP1
 
 

Quote   Quote: Originally Posted by Terpsichore View Post
New install on a new 1Tb hard drive straight out of the wrapping. Win 7 Home Premium 64-bit, OEM DVD bought from Amazon. The internet icon has a red cross on it, meaning no connection, and several re-boots hasn't cured it. But there is nothing wrong with my connection. I have a second hard drive which if I boot from it I connect instantly. How can I resolve this?
Did you install the drivers using a driver disc from whatever brand of computer you have? If you did a clean install, but did not insert said disc (assuming you have one) you may have to go to the companies website and manually download (to a zip drive or what have you) and install the driver(s)

I bought my current laptop (just a dell shell with the Mobo, no hard drive or RAM) but it had no disc only the installation disc, so after I put it all together, I had to use my service tag number and grab the updated drivers from the site
My System SpecsSystem Spec
.

30 Jan 2015   #4
Terpsichore

Linux Ubuntu 64-bit
 
 

Quote   Quote: Originally Posted by Berkey View Post
Did you install the drivers using a driver disc from whatever brand of computer you have? If you did a clean install, but did not insert said disc (assuming you have one) you may have to go to the companies website and manually download (to a zip drive or what have you) and install the driver(s)
Ah, that did the trick. I'd forgotten I even had a disk. Had to search for it, but I'm up and running now. Thanks.
My System SpecsSystem Spec
30 Jan 2015   #5
Berkey

Microsoft Windows 7 Professional 64-bit SP1
 
 

Quote   Quote: Originally Posted by Terpsichore View Post
Quote   Quote: Originally Posted by Berkey View Post
Did you install the drivers using a driver disc from whatever brand of computer you have? If you did a clean install, but did not insert said disc (assuming you have one) you may have to go to the companies website and manually download (to a zip drive or what have you) and install the driver(s)
Ah, that did the trick. I'd forgotten I even had a disk. Had to search for it, but I'm up and running now. Thanks.
no problem, glad to help
My System SpecsSystem Spec
Reply

 Can't connect to internet after installation.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB Internet dongle is taking a long time to connect to Internet
1. Is this a wired or wireless connection issue? Wireless via USB modem/dongle 2. Who is your Internet Service Provider (ISP)? Tata Docomo 3. What type of Broadband connection are you using? don't know 4. What is the exact Make and Model of your Modem, Router or Modem/Router Combo -...
Network & Sharing
Can't connect to internet "Windows was unable to connect to this netwo
Hello guys, I have just finished my very first computer build and am rather happy with most things. Unfortunately I am having problems connecting to the internet. I have a temporary dongle in place and because it's my only option for about a month I kinda need it to work. When I first...
Network & Sharing
CAN connect to internet, CAN'T connect to router
I'm trying to connect to either of two routers I have. With either one I can connect to internet (obviously... I'm typing this). I can NOT connect to the router itself to update the firmware or change the settings. The URL to connect to each: Netgear WGR614v6, http://192.168.1.1 or...
Network & Sharing
I cannot connect to my ROUTER but i can connect to internet.
1. Question: Help please, so i don't know what the problem is but i want to portforward my port and i've tryed hunders of gateways cmd ---> ipconfig i know that but it just says ''Page could not be found'' So do you have any suggestions how can i fix this? I'm using D-Link DWA-125 Wireless N 150...
Network & Sharing
not able 2 connect to internet through broadband connect
i have bsnl broadband connection.whenever i tried to connect it through my win 7 it gives me error 651 with pppoe.. I am on a wired connection through a modem,..modem is workng well with win xp..but not with win 7.
Network & Sharing
No apps connect to MY internet, but connect fine on my neighbours net?
I am trying to use limewire, couterstrike, bitcomet etc, but nothing apart from firefox/I.E. and windows live messenger can connect to MY internet. everything workd perfectly on my neighbours internet, when accessed from my own laptop. Please help me. Thanks.
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App