Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WiFi stopped working randomly on custom PC

10 Mar 2015   #1
dannyjerome0

Windows 7 Home Premium 64bit
 
 
WiFi stopped working randomly on custom PC

Problem started a few weeks ago. Not sure exactly if anything changed on my PC in terms of software. I know there have been no hardware changes. I am having horrible WiFi capabilities on my PC. Every other device in my household works perfectly fine. My PC is custom-built, running Windows 7 64-bit Home Premium. The BIOS and drivers are all updated. I was using a TP-Link USB WiFi adapter, which seemingly out of nowhere started running slowly. Then, the Internet would disconnect randomly and intermittently, or slow to almost a crawl. Since then, I ordered 2 more WiFi adapters (Panda and Linksys). All 3 adapters seem to work just fine on my laptop. All of them do the same thing on my PC. Oddly, the Linksys adapter worked beautifully for a couple minutes right after the installation. However, it eventually went back to horribly slow download speeds and/or intermittent connection. Nevertheless, I know the problem is not with the adapters, since they work fine on other machines. I have tried swapping out my keyboard, mouse, etc. with all of the available USB ports to no avail. The keyboard and mouse work fine in all of the USB ports, but the adapters don't work no matter what ports I use. Recently, I ran CCleaner, cleaned up the system and registry, did a fresh install of the WiFi adapter, and still it sucks (again, though, the adapter worked GREAT for a minute or two, then the connection pooped out). HELP??? Never seen this problem in all my years of building PC's.


My System SpecsSystem Spec
.
10 Mar 2015   #2
doctore

Windows 7 Pro
 
 

#1 - How is your antivirus situation?

+ Would you post a screenshot of the Wireless Network Connection Status (double click on your network adapter)?
My System SpecsSystem Spec
10 Mar 2015   #3
dannyjerome0

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by doctore View Post
#1 - How is your antivirus situation?

+ Would you post a screenshot of the Wireless Network Connection Status (double click on your network adapter)?
I'm using Avast Free Antivirus 2015. I have run a full system scan and everything is good.

My System SpecsSystem Spec
.

12 Mar 2015   #4
dannyjerome0

Windows 7 Home Premium 64bit
 
 

I just did a fresh install of Windows 7, and the same problem exists. I'm wondering if it's a power supply issue. I checked my voltages in BIOS and they are all perfect, so I don't think that's it. Motherboard issue?
My System SpecsSystem Spec
12 Mar 2015   #5
doctore

Windows 7 Pro
 
 

Would you post a screenshot of the Wireless Network Connection Status (double click on your network adapter)?
My System SpecsSystem Spec
12 Mar 2015   #6
dannyjerome0

Windows 7 Home Premium 64bit
 
 

My System SpecsSystem Spec
12 Mar 2015   #7
doctore

Windows 7 Pro
 
 

Well, your speed is 65Mbps, which is about right for a wireless connection.

Download a trial of Kaspersky Total Security or Eset and run another antivirus scan.
My System SpecsSystem Spec
12 Mar 2015   #8
dannyjerome0

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by doctore View Post
Well, your speed is 65Mbps, which is about right for a wireless connection.

Download a trial of Kaspersky Total Security or Eset and run another antivirus scan.

I just did a brand new install of Windows with a formatted hard drive. First thing I did was install the network adapter and still no connection. Also, I have installed Malwarebytes and Avira just in case and both are clean scans.
My System SpecsSystem Spec
12 Mar 2015   #9
dannyjerome0

Windows 7 Home Premium 64bit
 
 

I'm wondering if there's a definitive way to test the USB controller and/or power supply. I know the voltages in BIOS are perfect, and my USB keyboard and mouse work fine.
My System SpecsSystem Spec
12 Mar 2015   #10
doctore

Windows 7 Pro
 
 

Quote   Quote: Originally Posted by dannyjerome0 View Post
Quote   Quote: Originally Posted by doctore View Post
Well, your speed is 65Mbps, which is about right for a wireless connection.

Download a trial of Kaspersky Total Security or Eset and run another antivirus scan.

I just did a brand new install of Windows with a formatted hard drive. First thing I did was install the network adapter and still no connection. Also, I have installed Malwarebytes and Avira just in case and both are clean scans.
You don't have connection to the Internet or to the network?
Can you run ipconfig /all at the Command Prompt and post the results?

P.S. Your USB and power supply are not the issue here.
My System SpecsSystem Spec
Reply

 WiFi stopped working randomly on custom PC




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Wireless has randomly stopped working
On Thursday I turned on my Xbox and found my xbox live wouldn't connect to the internet, thought it was strange so I checked my IPhone, same thing.I go and check my school laptop and it also would not connect to the wireless. However, my personal laptop which is connected to my router through the...
Network & Sharing
HDMI sound randomly stopped working
sorry for starting a new thread but i have searched through so many and still not found a fix for my issue I was watching a movie and sound worked perfectly fell asleep woke up the next morning and no sound through my tv connected via gainward gtx550ti HDMI port it still shows in playback...
Sound & Audio
SinMax WIFI USB Adapter stopped working suddenly
hello everyone so i have this USB adapter its a Sinmax dual antenna .... when i first got it worked fine and it was a great "plug n play" got great signal...also used it on moms laptop to get a better signle ( signal is great with dual) but now i took it home and all of a sudden it wont find any...
Network & Sharing
Wifi on all the devices in one room only randomly stopped working
I recently bought a new cisco e2000 router and had no problem connecting to it on all the devices in the house (about 10 of them) Just now, all the devices in my room (ipod, netbook, phone, and laptop) lost a connection to the router and no matter where I am in the house none of these 4 devices...
Network & Sharing
I screwed over the registry and wifi stopped working- help a newb out?
I was playing around with the registry deleting what I though to be useless stuff and being the silly man I am, I somehow disabled the wifi. I did not backup my registry and I have no system restores to return to because I disabled that service. I can connect to a router on windows 7 wifi in...
Network & Sharing
Custom themes stopped working
Hi, All my custom themes just stopped working! I had a problem with very slow loading of video thumbnails, so I found this solution: * open windows start menu * type cmd and wait for cmd.exe to appear listed under the title Programs: * right click on cmd.exe and choose "Run as...
Themes and Styles


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App