Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Not getting 300Mbs speeds Revisted

20 Mar 2015   #1
Magnus005

Windows 7 Home Premium x64
 
 
Not getting 300Mbs speeds Revisted

I see this is a common thread. About a year ago, I moved and and had to get a wireless NIC card for my PC as it is no longer feasible for it to be within cable reach of the modem/router setup, so I purchased a Rosewill Dual Band PCIE card (N600PCE), 802.11 (a, b, g, n). Ever since I installed it, it never liked my Cisco Linksys E2500, also Dual Band 300+300 Mb/sec. Fortunately, after the previous ISP provider issued a DSL modem with built in WiFi, that went away. But we just changed providers and the cable modem has no WiFi, so I had to dig out the E2500 again and at first, it was working at 300Mb/sec, but then it started acting erratically, constantly dropping connection to the network. FINALLY, I uninstalled and reinstalled the original drivers that came with the card and used the LAN wizard that came with it, but I'm not seeing better than 144Mb/sec. Any thoughts or suggestions?
BTW, the router is a version 1 and was flash updated during my setup.


My System SpecsSystem Spec
.
20 Mar 2015   #2
Magnus005

Windows 7 Home Premium x64
 
 

Well, the issue is sort of fixed, I managed to download the latest driver for that model and am fluctuating between 243.x and 300. I'm still curious as to why. I'll mark this as solved after some responses.
My System SpecsSystem Spec
20 Mar 2015   #3
Sub Styler

Windows 7 Ultimate x64
 
 

There's so much it could be;

1. Rosewill may have an updated driver on their website
2. The E2500 may have new firmware available
3. Depending to the quantity of neighbouring wifi networks you may be on a congested channel, in (192.168.1.1 assuming this the E2500) try operating on channel 1, channel 7, channel 14 and seeing if there are significant changes.
4. Try setting the router to G+N mixed mode instead of B/G mode.
5. Try to distance your router away from other electrical equipment (a few feet will normally be fine).
6. Ensure the antennae on both wifi card and router are connected securely and free from dust/corrosion. (do not over-tighten!)
7. Use an antennae on an extension at your PC end to help avoid interference from the PC itself.
8. In windows look at the advanced properties for your network adapter an turn off power saving options, check transmit power is all the way up and nothing seems out of place.
9. In the router setting check the same things.
10. What is your signal strength on the wifi? if anything other than excellent then the speed will drop.
Check the ping to 192.168.1.1 (or whatever the router address is) if greater than >8ms then you could be looking at firewall/winsock/MTU problems.


144Mb/sec is a relatively good wifi speed, is your internet connection faster than that? If not I wouldn't worry about it, there is no benefit unless you are transferring files over a home network?
My System SpecsSystem Spec
.

20 Mar 2015   #4
Sub Styler

Windows 7 Ultimate x64
 
 

ah you replied before I finished, good news, glad it helped.
My System SpecsSystem Spec
21 Mar 2015   #5
theveterans

Windows 7 Professional x64 SP1
 
 

300 Mbps connection doesn't mean it'll get 300 Mbps internet due to overhead protocol. You need at least 30-50% of connection bandwidth for the overhead thus the effective bandwidth is only about 150-180 Mbps.
My System SpecsSystem Spec
Reply

 Not getting 300Mbs speeds Revisted




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Slow Download Speeds on Desktop, Fast download Speeds on Laptop
I am having issues with my desktop. I am getting download speeds using speedtest.net of about 3mbps. On my laptop however I am getting speeds of 20-25mbps. I have run a virus scan and malware scan and both came out as clean. What else could be causing my computer to suffer such slow download...
Network & Sharing
Slow download speeds, Fast upload speeds. Other devices are fine.
My computer has extremely slow download speeds, upload speeds are fine. Ping is always at ~10-20ms. (to Google) The problem has nothing to do with, my ISP, my router, my type of connection. I know this for a fact. http://www.speedtest.net/result/3745496488.png I've tried multiple network...
Network & Sharing
fan speeds
i have a sony laptop nw220f t4300 procesor. tried out speedfan and right now the temps are under 45 but they have gotten up to 65 and stayed for a good while and cant figure why. the air is really warm/hot blowing out and and the fan just seems to stay on low. it used to switch for low to high at...
Hardware & Devices
i5 750 and Ram speeds
I want to do a relatively small overclock. In my bios i have c states, turbo boost and speedstep disabled. Dont see a cE1 setting anywhere. My base clock speed is 160 at 20 multiplier so 3.2ghz. But my 1066mhz ddr3 ram is at 1281mhz at an 8 multiplier. Is it safe for my memory to be at that...
PC Custom Builds and Overclocking
Different Ram speeds
Hello there, I recently purchased a Micron DDR2 2g ram and it's max speed is 400Mhz, I also have 2 Kreton DDR2 1g rams and both their max speed is 333Mhz, I do know that the new Micron ram will operate with the speed of the Kreton, but I was wondering, would it effect gaming or any other system...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App