Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Edimax EW-7612PIn Wireless PCI-Express Adapter disconnects randomly.

22 Jun 2015   #21
BlindPixel

Windows 7 Home Premium x64
 
 

I haven't tried the Linux Mint MATE Live CD yet. I have had my second Router (Belkin Router) connected to the Netgear one with a Ethernet Cable. It worked for several days but then the Belkin router disappeared off the Wireless Network Connections list and I started automatically connecting to the Netgear router.

The odd thing about this is I went into the properties of both connection names. With the Netgear router, I unchecked the 'Connect automatically when this network is in range' and 'Connect even if the network is not broadcasting its name (SSID)'. Then I checked these two options on the Belkin router. After an undefined amount of time, these settings go back to default where the Netgear was the router I connect to automatically whereas the Belkin didn't have this feature.

Sometime after doing this several times, the Belkin just stopped showing up on my computer as an available connection. Other people can see the router but for some reason I can't.


My System SpecsSystem Spec
.
23 Jun 2015   #22
paul1149

Linux Lite 2.8 x64 (full-featured, fast, rock-solid)
 
 

My guess is one of these:
  • the adapter is somehow getting uninstalled. This is the only reason I can come up with for losing network settings.
  • malware
  • something wrong under the hood in Windows

The next steps would be:
  • try a different adapter
  • scan for malware (MBAM is excellent)
  • fix Windows or run Linux to see if the problem is there

If you want to try to repair windows, you can use a prog like Complete Internet Repair.
My System SpecsSystem Spec
24 Jun 2015   #23
BlindPixel

Windows 7 Home Premium x64
 
 

Okay, after I ran MBAM (I am assuming it is Malwarebytes Anti-Malware program) something different started happening. When I am connected to the internet, I get the following status bar icons:


The white bar icon is the normal Windows internet status icon. The icon with the green bars is my Edimax internet adapter icon. Before I ran MBAM when the connection went down, both icons would give an indication the internet is down. Now when the internet goes down, the Edimax is still connected to the router yet I have no internet for my computer.

The only other adapter I can try is the on board internet connection. However, I need to be directly connected to the router for that to work. Right now we don't have the room for me to do this so until we get enough room I can't test this solution out.
My System SpecsSystem Spec
.

24 Jun 2015   #24
GokAy

Windows 7 Ultimate x64 SP1
 
 

Yes, MBAM is Malwarebytes.

Can you try uninstalling Edimax software? Windows built-in is good enough. Then remove the connection from the wireless networks list and re-connect. Make sure IP/DNS are automatic.
My System SpecsSystem Spec
24 Jun 2015   #25
paul1149

Linux Lite 2.8 x64 (full-featured, fast, rock-solid)
 
 

  1. Did MBAM find anything?
  2. Second, your problem may be as simple as running two network handlers on the same adapter. See if you can turn off the Edimax firmware in its GUI, or uninstall it from Control Panel / Programs. But first make sure you have a local copy of the Edimax driver in case it get uninstalled, so you can reconnect.
    Windows' built-in zero-configuration network handler is very good and takes minimum resources. Go with it alone.
My System SpecsSystem Spec
24 Jun 2015   #26
BlindPixel

Windows 7 Home Premium x64
 
 

I am not sure why I didn't add this to the post but here it is. MBAM found 48 Potentially Unwanted Programs (PUP) as either files or folders. The Vendor for them is PUP.Optional.CrossRider.A for all of them.

Also I do not have two wireless adapters, I think that is what you guys are assuming with the two signal bars. The only wireless adapter that I have is the Edimax one. When the Edimax adapter is disabled, the Windows signal bar will show no internet connection. It has been this way since I first installed the Edimax wireless adapter, not sure if it is the same way with everything else.

In total I have two Network Connections to use. The first is the Local Area Connection, which uses the Network Cable plugin on the tower. This is not connected whereas the second connection is the Wireless Network Connection which is connected through the Edimax adapter.

I am going to see if I can turn off Edimax firmware or uninstall it from Programs and see if I still have internet. I am pretty sure it will just cut me off from internet but who knows.
My System SpecsSystem Spec
24 Jun 2015   #27
GokAy

Windows 7 Ultimate x64 SP1
 
 

We know you have 1 wireless adapter. Uninstall the edimax software so windows manage the connection. If the drivers get uninstalled in the process you will have to reinstall only the drivers.
My System SpecsSystem Spec
24 Jun 2015   #28
BlindPixel

Windows 7 Home Premium x64
 
 

Okay, I went and uninstalled the Edimax Software and as predicted the internet cut off. The driver software I had gotten off the website itself didn't help at all. Apparently even though it says it is the driver for the adapter, there is no driver information in the download.

In order for me to actually download the driver, I had to put the CD into the machine and extract the driver through Device Manager in order for the utility to not be downloaded. As of right now, I am connected to the internet and do not have the Edimax Signal Bar and there is no Edimax program in Programs and Features. I will post a quick reply if the internet acts up again.
My System SpecsSystem Spec
24 Jun 2015   #29
paul1149

Linux Lite 2.8 x64 (full-featured, fast, rock-solid)
 
 

I should have mentioned another way might have been to prevent the edimax utility from autostarting at MSCONFIG. But you got it anyway. I've been down this road with edimax, and it can get tricky. Good hardware though. The alternative is to turn off Windows zero-config service.
My System SpecsSystem Spec
24 Jun 2015   #30
BlindPixel

Windows 7 Home Premium x64
 
 

Uninstalling the Edimax Utility while keeping the drivers didn't work. There are times the internet disconnects and the Netgear router disappears. Also the Belkin router hasn't appeared since the Netgear disconnected. Everyone else can see both all the time whereas I am disconnecting randomly.

Also, the other two computers that keep the connection have the wireless adapters already built into their computers. The Edimax adapter didn't come with the computer.
My System SpecsSystem Spec
Reply

 Edimax EW-7612PIn Wireless PCI-Express Adapter disconnects randomly.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Diagnose internet disconnects with broadcom 802.11g network adapter ?
Hello, I have experienced conditions where the internet completely disconnects, and the wireless network is no longer shown on the list to connect to, all wireless networks "disappear" from the list. I have tried many actions to try to fix the problem, reseting the network adapter, enabling and...
Network & Sharing
Laptop and Xbox 360 disconnects randomly from wireless and ethernet
I have a HP G62-371DX Notebook that I have been using to access the internet. Lately I have been experiencing random disconnects that will last from maybe 30 seconds to 2 minutes. They will happen maybe every hour or two and are becoming really annoying. At first I was using the laptops wifi...
Network & Sharing
Wifi Randomly Disconnects
I recently bought a Lenovo V570 and a Dell Inspiron N5110 from Best Buy but I am having an issue with both of them. Both have Intel i5 processors so it has to be something to do with it. My Wifi randomly disconnects and sometimes it automatically reconnects and sometimes it doesn't connect back. I...
Network & Sharing
Edimax EW-7128G Wireless PCI Adapter
I just upgraded to Windows 7 (32-bit) and have installed the drivers for my Edimax EW-7128G Wireless PCI Adapter. It is recognising my wireless router but wont conncet to the internet. All my other wireless devices, including a laptop running Vista, are able to connect to the internet via the...
Drivers
Edimax Wireless Card EW-7718IN installation problems
I bought an Edimax WiFi card (EW-7728IN) which supports Win 7 to replace an earlier WiFi card unsupported by Win 7. In the initial installation I left Windows to find the necessary driver, which it did and reported a successful installation. However, no wireless signals were picked up and when I...
Drivers
Need drivers for Edimax EW-7318Ug wireless usb adap.
Windows 7 doesn't recognise this device,are there any drivers that work with Windows 7 for this device..
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App