Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Portforwarding not working

14 Jun 2015   #11
kathy025

Windows 7 Professional SP1 x64 (OEM)
 
 

Hello GokAy,

You mean like this?



I used the current IPv4 address from ipconfig for the Local IP.

Unfortunately...



(I tried forwarding port 80 but it also failed.)

When I access my web app using my Local IP, it works:
192.168.254.101:8080/myWebApp

When I try to access using my External IP, it times out:
180.191.103.188:8080/myWebApp


My System SpecsSystem Spec
.
14 Jun 2015   #12
GokAy

Windows 7 Ultimate x64 SP1
 
 

You changed too much
Go to port forwarding and change the internal ports(private) to 8080. Keep public ones as 8081.

192.168.254.101:8080/myWebApp - this is correct if you are inside the network

180.191.103.188:8081/myWebApp - when you are connecting from Internet, notice 8081
My System SpecsSystem Spec
14 Jun 2015   #13
kathy025

Windows 7 Professional SP1 x64 (OEM)
 
 

Hi GokAy,

Here's the current rule:



I tried accessing using 180.191.103.188:8081/myWebApp but it timed out as well.
My System SpecsSystem Spec
.

14 Jun 2015   #14
GokAy

Windows 7 Ultimate x64 SP1
 
 

Ok, Did you ever try to connect to 192.168.254.101:8080/myWebApp from your phone? Maybe it is a permission issue with Tomcat?
My System SpecsSystem Spec
14 Jun 2015   #15
kathy025

Windows 7 Professional SP1 x64 (OEM)
 
 

I used my tablet to connect to 192.168.254.101:8080/myWebApp and it works.
The external IP did not work though.

Are there settings you need to see that can help you diagnose?
My System SpecsSystem Spec
14 Jun 2015   #16
GokAy

Windows 7 Ultimate x64 SP1
 
 

This myWebApp is the actual app or some management screen? I read that tomcat by default restricts management from Internet or something like that

Anyway, not sure if this would help but can you also add outbound rules to allow 8080 for both protocols in Windows Firewall?
My System SpecsSystem Spec
14 Jun 2015   #17
GokAy

Windows 7 Ultimate x64 SP1
 
 

Well, I downloaded and setup Tomcat on a virtual Win7 Home Premium x64. After opening the ports 8080 TCP/UDP in Windows Firewall and creating the port forwarding on router, I can connect from outside.

Here are the steps:
- Extracted tomcat to C:/tomcat
- created JAVA_HOME variable with C:\Program Files\Java\jre1.8.0_45
- ran startup.bat
- Created UDP/TCP port 8080 rules to allow
- Create port forwarding to virtual OS IP, external 8081, internal 8080
- tested with Firebind Reflector Demo1
- also connected to ZenMate VPN through Firefox, success too
My System SpecsSystem Spec
18 Jun 2015   #18
kathy025

Windows 7 Professional SP1 x64 (OEM)
 
 

Sorry I haven't been around, got busy with internship. I'm still baffled as to why it stopped working, it did before. Right now I reserved 192.168.254.101 to my laptop (connected to router via wifi) so even if it's dynamic IP, I will always have that address (effectively working like a static IP).

Is there any diagnostics I can run (cmd line or some tool) that can help us tell what's going wrong?
My System SpecsSystem Spec
18 Jun 2015   #19
GokAy

Windows 7 Ultimate x64 SP1
 
 

All I can think of at the moment is where id the tomcat folder? Perhaps it is a permission issue.
My System SpecsSystem Spec
19 Jun 2015   #20
kathy025

Windows 7 Professional SP1 x64 (OEM)
 
 

Hello GokAy

Quote   Quote: Originally Posted by GokAy View Post
This myWebApp is the actual app or some management screen? I read that tomcat by default restricts management from Internet or something like that
myWebApp is the actual app itself.

Quote   Quote: Originally Posted by GokAy View Post
All I can think of at the moment is where id the tomcat folder? Perhaps it is a permission issue.
Code:
D:\xampp\tomcat
Here are my most current settings:

1) Set Dynamic IP with reservation.



2) Checked ipconfig.

Code:
Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::7db6:2f63:90fe:38b4%12
   IPv4 Address. . . . . . . . . . . : 192.168.254.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::1%12
                                       192.168.254.254
3) Set port forwarding rule.



4) Set inbound/outbound rules for port 8080 in Windows 7 Firewall.







5) Tested port.



Those are the configurations I did. If you need other details to help diagnose, please let me know.
My System SpecsSystem Spec
Reply

 Portforwarding not working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Sound on Laptop and Desktop Randomly Stops Working and Working
So recently the sound on my desktop and my laptop has stopped working. For seemingly no reason. I really don't understand it. I first noticed it with my desktop. The sound just randomly stopped working. But not...entirely. It's really strange and complicated what's been happening, so bare with...
Sound & Audio
Laptop speakers working, but headphone jack not working only on Window
Hi, I have a dual boot of Fedora and Windows, and when I boot into Fedora, my headphones work fine. When I boot into Windows 7 64bit, my headphones don't work. My laptop speakers work fine however, and I tried re-installing drivers. I made sure that my headphones are the default playback...
Sound & Audio
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Portforwarding with the Sky D-Link router?
Hey guys, I can't seem to portforward on the new D-Link routers? I got my router this year, so it's one of the new black ones that stand up? It has all of the wifi info on the side of the router. Anyway, I'm trying to portforward, followed a couple of guides but when I go on 'canyouseeme' it...
Network & Sharing
Portforwarding build 7100
Im using 32 bit windows 7 build 7100. Ive portforwarded my router correctly as ive followed all of the steps on a guide that was specificly for my router. This can be found here YouTube - Port forwarding on the DG834G. The question is what do i do now to allow my firewall to let incoming and...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App