Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wireless yes, but no internet

11 Nov 2009   #41

7600.20510 x86

Use Wireshark to see what is going on with the connection. Capture for a while as you try to connect, then use .rar on the saved file. Upload it here after.

My System SpecsSystem Spec
12 Nov 2009   #42

Win 7 Home Premium 64bit

Sorry, was busy the whole day so far.

What I did now is to reset the system to factory standard.

I get the same as before - everything looks fine, but IE cant display a page.

When using the troubleshooter now I get the following message:

"The computer is trying to use a DNS server that is incorrect or does not exist".

Did a search on google and it seems that the dnshc.dll is responsible for DNS. Is this correct?
I looked up on my computer and the ddl-file is present, but I don't know if it is corrupted.

Brb later - have to do some more work.

cu Peter
My System SpecsSystem Spec
12 Nov 2009   #43

7600.20510 x86

As I was saying, either the router or computer is improperly configured for dns.

Best thing you can do is to set up a static ip address for the adapter under IPv4 settings. Use a free public dns server if needed.

Check the router again after if problems persist.

Triple check that there is no Bonjour service installed. If you'd like me to look, type system information in the start menu search box. Hit ctrl+s on the screen that opens. Use Winrar on the saved file and attach the .rar to a post.

In I.E>>> Tools | Internet Options | Connections Tab | Lan Settings

Remove all checked boxes and hit ok. Reboot and test.

Can you access this website by ip address?

type into a browser >>> and hit enter.

See what happens.
My System SpecsSystem Spec

12 Nov 2009   #44

Win 7 Home Premium 64bit


I atteched the sys-info file - hope that helps. As far as I saw via the Explorer there is no Bonjour folder in my system.

I typed in the address and I saw the forum. Then I typed it in and I got the info that the address is not valid.

Before I start with the static IP I wait what you find out - not that I change something that is not necessary.

cu Peter

Attached Files
File Type: rar sysinfo.rar (34.8 KB, 3 views)
My System SpecsSystem Spec
12 Nov 2009   #45

7600.20510 x86

I'd disable (or uninstall is better, but...) - use services.msc to disable

Updater Service

Google Software Updater

and this one too, depending on if you really want it or not:

Oberon Media Game Console Service

Reboot and test.

If that doesn't work, completely uninstall Norton. <<<< This is likely the cause.

Let us know how it goes and I may have further suggestions if needed along with how to set a static ip address for the adapter.

Also, the thread is getting a little long and I don't want to search through everything so sorry if I told you this already.

Check the hosts file. The only entry in it should be localhost - and that *must* be the first line if you placed others under it.
If anything else, some kind of malware edited it.
The location is C:\Windows\System32\drivers\etc\hosts

Open it with notepad.

Good luck.
My System SpecsSystem Spec
12 Nov 2009   #46

Win 7 Home Premium 64bit

Disabled all mentioned services -> reboot -> nothing changed. And I have the exclamation mark in the botton right corner (which changed to connected after serveral minutes)

Uninstalled Norton next -> reboot -> nothing changed.

But when I start IE and type in then I see the welcome page of the forum. But I cant log in, then I get the message that the page can't be displayed.

Yes, I posted the hosts file before. There is localhost inside and then underneath is a line with ::1
My System SpecsSystem Spec
12 Nov 2009   #47

7600.20510 x86

It's the router then it seems that is not forwarding dns properly.

Set it to use dns server = (Tested and works, by me personally.)

If that doesn't work, put the router back to how it was.

Then setup a static ip address for the adapter -

Go to Network and Sharing Center. Click local area connection. Click Properties. Double click Internet Protocol Version 4 (TCP/IPv4).

Set it as follows:

Ip address = same as router config page, usually or but change the last part to 150 -

for example, if router is make ip address
if router is make ip address

Subnet mask =

Default gateway = router's config page address same as before ( or

Preferred dns server =

Hit ok. Test. Disable then enabled the adapter. Test.
My System SpecsSystem Spec
12 Nov 2009   #48

Win 7 Home Premium 64bit

Do you think that the problem could be solved with a new router?
The Thomson Router is quite old.

Will try the suggested solutions now.
My System SpecsSystem Spec
12 Nov 2009   #49

7600.20510 x86

No it will be fixed once you change the dns on the router or set the ip address as static for the adapter as outlined. If you followed it correctly, you'll be back saying everything works. There's nothing wrong with the hardware.

If you don't know the router's config page address, tell us the exact model and I can find the info for you. Try typing in this if you aren't sure, to a browser >>>

Does that bring up the config page at all?
My System SpecsSystem Spec
12 Nov 2009   #50

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64

My System SpecsSystem Spec

 Wireless yes, but no internet

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Working with 2 wireless networks - Internet access and HDMI wireless
Hi, I have just got an EZCast home multimedia wireless sharing device. It works great from my acer laptop and from my android phone. HTC one! My problem is that it works as an access point so both my phone and my laptop need to connect as clients. when I do this I have no connection to the internet...
Network & Sharing
Internet connectivity problem, affects wired internet but not wireless
I am having Internet connectivity issues that only affect my computer and only affect it when I'm using a wired connection as opposed to a wireless connection. I would just use the wireless except that it's too weak here at my house especially in the room where I'm working and thus it's slow...
Network & Sharing
Wireless and internet are working but no internet access
Hi there ،، well the problem here that suddenly all my internet explolers ( firefox , IE9(x32) , google Chrome ) can't access to the internet . I checked the connection many times, i tried the system restore, scan for viruses and i couldn't find any help with this. The strange thing that...
Network & Sharing
wireless internet won't give me internet access, HELP!
A few days ago the public wireless internet i used worked fine and i had no problems with my computer. Now when i try to connect to it, it isn't allowing me access. It works just fine on my sisters laptop that is the same model and brand as mine.
Network & Sharing
Help! Internet wireless connection "connects" but no internet access
Hi all! I was installing a software on my other laptop (it had SQL software with it) and I ran into some trouble as I got error problems that the installation of the software had failed and now whatever I do, I can't access the web! Sure enough, my wireless connection connects successfully and it...
Network & Sharing
wireless internet connected but no internet access ?
hi, Am using dell inspiron laptop with windows 7 home premium 64 bit , i have a free wifi in our collage when i give connect it was getting connected but there is no internet access i had tried with trouble shoot it was giving problem regarding DNS pls tel me how to use wifi :)
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:36.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App