Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browser running slow or timing out, however internet is working fine.

30 Jul 2015   #31
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

It depends upon how you configured Avast and the components that you installed:

Avast's HTTPS Scanning interferes with Firefox and other programs - gHacks Tech News

However I don't believe that this is related to your problem as it occurs when using Linux.

I think you need a hardware expert. Moved house - something got dislodged or damaged during the move maybe?


My System SpecsSystem Spec
.
30 Jul 2015   #32
GokAy

Windows 7 Ultimate x64 SP1
 
 

Since this is happening on both OS's I believe it is not a Windows configuration issue. However, I can't be sure it is hardware either as LoL is working.

Did we try loading defaults in BIOS yet?
My System SpecsSystem Spec
31 Jul 2015   #33
Psych0viper

Windows 7 home premium 64-bit SP1
 
 

I don't think we have, because I have no clue how to do that.
My System SpecsSystem Spec
.

01 Aug 2015   #34
GokAy

Windows 7 Ultimate x64 SP1
 
 

Do you know how to open BIOS setup? It is written in the first screen you see when you start any PC. May be called "Setup" only, most likely a F-key or DEL.

Once inside, either in first screen or the exit menu. Once you load the defaults make sure to "Save the changes and Exit".
My System SpecsSystem Spec
Reply

 Browser running slow or timing out, however internet is working fine.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Running slow with network connection enabled, runs fine in Safe mode
I have a computer that would not see the hard drive a few days ago. Got a new hard drive and did a clean install of windows and restored the rest of the files with Carbonite. A few days later the computer would not boot into windows again. So this time i reformatted the new drive and stuck it into...
Performance & Maintenance
Browser Running Slow
Last week my internet browser (FireFox) started loading very sluggishly almost at dial up speed. I ran Norton and it found no problems so I then reset my browser and still had the same issue. I then did a speed test and it said my Ping was 18 but my download speed was 0.4kbps and upload was...
Browsers & Mail
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
very slow boot but running fine, new install
Hi, I am running a P5N-D motherboard ( bios 1401) with an intel core 2 quad Q9300, Rad HD3800 series and I have some problems since last week. It started with an error 0cx00000e9 someting About USB being disconnected. Since I couldn't figure out the problem I reinstalled windows 7 64bit. The...
Performance & Maintenance
Laptop NBA 2k11 running slow when it was fine a few days ago
First, my laptop is not my main computer for gaming, but I use it occasionally when my girlfriend needs my desktop and I want to play NBA 2K11. The game began running very sluggishly when playing (menus are fine), and the fps dropped from 40 fps to 15 fps. It was fine when I played on the 13th of...
Performance & Maintenance
Running fine but Slow Gameplay
Hi everyone,i have a problem with my gta san andreas,it's running fine and the graphics are good But the gameplay is SLOW! :( i tried to download the older one(vice city)it's better than san andreas but still slow,what to do,plz help! My Processor is 2.00GHz and RAM 1.00GB Thanx
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App