Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PCI-E internet card not working well, Slow speed / Connection loss

13 Aug 2015   #1
Roblox

Windows 7 Professional 64bit
 
 
PCI-E internet card not working well, Slow speed / Connection loss

I got a:

PCI-E Wireless 802.11n 150Mbps Network Interface Card

So It somewhat works but only a 2 MBPS download speed I know that my wireless network gives off 30 MBPS as my old external wireless USB was getting, but that is broke.

With that broke all I have left is the internal card with slow speed, Unable to render youtube in HD.

Windows shows the internal card has a strong connection of full bars but still slow speed.

Tried updating drivers for it through device manager but none available, So why is it so slow?

P.S. There is room for 2 antennas but having the 2 in makes no difference as It still works with 1, strange.


My System SpecsSystem Spec
.
21 Aug 2015   #2
Roblox

Windows 7 Professional 64bit
 
 

Still got the issue , Tried Uninstalling the device and detecting the device again , result = Still slow

Tried looking for new drivers = none found
My System SpecsSystem Spec
21 Aug 2015   #3
GokAy

Windows 7 Ultimate x64 SP1
 
 

Check the values in advanced tab of Wireless adapter in Device Manager.

Also what does it say as speed if you open Status of Wireless adapter (Network and Sharing - Change adapter settings - right click the wireless - status)

How about Network type - Home/Work/Public?
My System SpecsSystem Spec
.

22 Aug 2015   #4
Roblox

Windows 7 Professional 64bit
 
 

In Properties>advanced tab:
IEEE802.11h = Disable
Power Saving Mode = CAM (Constantly Awake Mode
Radio on/off = Enabled
SmartScan = Disable

Network & Sharing stats:
IPv4 Connectivity = Internet
IPv6 Connectivity = No network access
Media State = Enabled
Speed = bouncing up and down between 19.00 Mbps to 110 Mbps (My network never gives that much speed off) Usually 30 Mbps on working devices speed tests.

Network = Home
My System SpecsSystem Spec
22 Aug 2015   #5
GokAy

Windows 7 Ultimate x64 SP1
 
 

Check the values for your wireless section of the router too. Try a different channel for example.
My System SpecsSystem Spec
Reply

 PCI-E internet card not working well, Slow speed / Connection loss




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
recurring loss of internet wifi and ethernet speed
problem as above - every couple of weeks or so my internet slows to a snails pace, it usually lasts for 3 or 4 days then its back on full speed again, really cant figure this one out! Ive released ip and flushed dns! my ping is always around 10ms and my upload is always around 4mb which are...
Network & Sharing
Evening Internet Connection Loss -- Unable To Identify Source Of Loss?
I need your help!!! I got a real challenge for you! I am confused! I cannot locate the Internet connection loss source. Every night for the past 5 late evenings my Windows 7 Pro 64-bit has been losing my Internet connection on my desktop computer anywhere between 8 PM-12 AM (Last 3 nights: 11:05...
Network & Sharing
Internet speed loss, can't find solution
I'm having some serious issues with my internet speed. I am on Virgin Media 60mb with the ISP provided router. We have 4 computer connected via wires and several wireless devices. In the last month my computer has been suffering some serious internet issues. My regular connection on...
Network & Sharing
Fallback to second internet connection after internet access loss?
My computer has two network adapters connected to two different internet gateways. One is Ethernet and the other is WIFI. The Ethernet connection is first on the access order list (if you don't know what I'm talking about, see the image attached) and the WIFI is second. Today, the internet...
Network & Sharing
New laptop + slow internet connection speed ++
Hello guys, I bought a new laptop a few days back, but the internet has not been working as it should on it. I can barely connect to the internet, and the signal is really weird. If I sit in my couch with my laptop the internet is barely working, though if I move about 10inches it will start to...
Network & Sharing
Internet speed loss
Hey there guys. So here's my problem : I've been experiencing in the last 5-6 months a progressive loss of internet speed. I've called my ISP tech support and they told me to do a reset to the modem for about 10s. It worked lol. For about 1 or 2 days -.- Then it went to it's same position...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App