Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network connection hangs at PC start-up

10 Sep 2015   #21
GokAy

Windows 7 Ultimate x64 SP1
 
 

From what I have learned from experienced people here is that registry cleaning doesn't improve anything. It may introduce more problems. I sometimes advise to clean it though, no idea if it helped anyone. If you so wish, make sure you backup registry and also create a manual System Restore point in case something goes wrong.

Another one:
- Create a manual System Restore point (if you haven't already due to a prior step) - System Restore
- Run as admin - Download Complete Internet Repair - MajorGeeks
- Select options 1,2,3,4 and Reset Windows Firewall

If this fails too, I only got 2 more (at least for now):
- Either run as admin in Safe Mode with Networking - Tweaking.com - Windows Repair
- or a Repair Install - Repair Install


My System SpecsSystem Spec
.
11 Sep 2015   #22
Vladimir 1

Windows 7 Professional x64
 
 

Alright Im gonna try this, I hope it's safe and doesnt screw up anything more

EDIT::

Ok so I used the " Complete Internet Repair " program and it didnt help, it was same.

I booted my PC in safe mode with networking and the problem was gone, but I followed your instructions of the tweaking - windows repair program and now my PC is much worse than it was ..

Now my PC takes much longer than before to start ( longer in the welcome screen message ), once the welcome message is gone there's a black screen for like a minute or something and then the same network connection problem this time it's shorter for like a minute or something.

This is what I was afraid of, I didnt want to screw up anything but now it's pretty much screwed up, so Im gonna use the system restore point I created to fix the new problems ..
My System SpecsSystem Spec
11 Sep 2015   #23
GokAy

Windows 7 Ultimate x64 SP1
 
 

Sorry to hear that

If System Restore doesn't help, go for a Repair Install. It will default Windows Updates and device drivers but programs and user data files are unaffected. (Detailed in the tutorial).
My System SpecsSystem Spec
.

11 Sep 2015   #24
Vladimir 1

Windows 7 Professional x64
 
 

So do you think that some Windows updates could have caused my problem and not something to do with my ISP ?
Btw, note that my settings for Windows updates are turned off, never to check / download / install ( but I guess it still installs some very important updates by itself )
My System SpecsSystem Spec
11 Sep 2015   #25
GokAy

Windows 7 Ultimate x64 SP1
 
 

You should be installing Important updates and be up-to-date with them. It may very well fix your issue. Just avoid Windows 10 updates - http://www.sevenforums.com/general-d...ml#post3144970 (I believe is the latest list).

If it was your ISP, it should have been connecting to the router but have yellow exclamation mark on the network connection icon. Does your router have an option to keep-alive the connection? Though I haven't seen this in 10 years.
My System SpecsSystem Spec
11 Sep 2015   #26
Vladimir 1

Windows 7 Professional x64
 
 

I dont have router, I use a cable to the Ethernet port and that's how I stay connected to the internet.
My System SpecsSystem Spec
11 Sep 2015   #27
GokAy

Windows 7 Ultimate x64 SP1
 
 

Then yes it can definitely be the ISP, sorry for not realizing before, so your ISP just provide you with an Ethernet cable connection? Can you find any router from a friend/neighbor to connect to, maybe some old ADSL modem/router lying around? It will definitely show if it is your PC or connection. Maybe you can simply solve this by attaching a router in between.
My System SpecsSystem Spec
11 Sep 2015   #28
Vladimir 1

Windows 7 Professional x64
 
 

I'll also be looking forward to get a Wi-Fi router as soon as possible ..
Other than that I dont think I am going to do the Repair Install thingy because as I said my windows updates settings are OFF so it's definitely for sure this problem is not caused by updates since they were never downloaded / installed ..

Anyway ..

Thank you very much for all your solutions you've provided me, really appreciated and sorry for annoying you haha
My System SpecsSystem Spec
Reply

 Network connection hangs at PC start-up




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
'Bluetooth connection' is shown in my Network Connection suddnly.
Hi, I really had not this 'Bluetooth connection' before. But, I really don't know that pairing my Nokia Bluetooth with my HP Laptop Bluetooth would add this Bluetooth connection or NOT. I really guess this Bluetooth Connection was listed there when I connected my Lapotp Bluetooh with Nokia...
Network & Sharing
Local Area Connection missing from network adapters, no connection
I have a Windows 7 Home Premium computer that is not connected to the internet. I have checked the drivers and they are all installed correctly and operational. When I go into the adapter settings there is no Local Area Connection adapter. I have included some screen shots of what I am seeing if...
Network & Sharing
Help! Laptop w/Win 7 hangs at start up will not start in any mode!
F keys will not work either! I don't think I have a disc to restore from, what else can I do?
General Discussion
Wlan card hangs (identifying error) during connection to router.
Windows 7 home premium 32bit zonealarm basic firewall wlancard dell 1450 usb Info: the card never had a vista or windows 7 driver. A computer skilled took out a folder from the windows xp installer. Through device manager the folder is installed as driver, and the wlan card works. I...
Network & Sharing
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing
Connection hangs
Hi there. I have connection issues with Windows 7. Problem is that my connection runs fine for 5-10 minutes then afterwards while opening new tabs in mozilla it just hangs there and say unable to connect, then reconnects 30 seconds after. It's even worse with Internet explorer... and with...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App