Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WAN Miniport won't activate for hard-wired connection

20 Sep 2015   #1
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 
WAN Miniport won't activate for hard-wired connection

Since shortly after buying my Dell Inspiron laptop, I can get online with the wireless only. I cannot use the hard-wired ethernet connection. I can find the WAN Miniport under control panel/change adapter settings, but cannot get it to turn on. If I turn off the wireless, I cannot find a way to get online. This is W7 Home Premium.

Any ideas?


My System SpecsSystem Spec
.
20 Sep 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

Open Device Manager (devmgmt.msc) - expand Network Adapters - check whether Ethernet adapter is disabled or have any issues (yellow exclamation or similar)

Then Network and Sharing Center - Change Adapter Settings - see if "Local Area Connection" is there and enabled (right click).

Also when you have the cable plugged in, write in cmd:
Code:
ipconfig -all |clip
It will not display anything, but will copy the results to the clipboard. Paste here (CTRL+V).
My System SpecsSystem Spec
20 Sep 2015   #3
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 
network connections

On the device manager, there are two listed. Wireless Network Connection Dell Wireless 1397 WLAN and Microsoft Virtual WiFi Miniport Adapter. There is no yellow exclamation point.

The network connections screen shows 2 devices. First is Wireless Network Connection Dell Wireless 1397 WLAN Mini-Card with all green bars lighted.

Second is Wireless Connection 2 Not Connected Microsoft Virtual WiFi Miniport Adapter with all green bars lighted and a bold red X. When I right click on this, it shows enabled. Under Properties/Networking/Configure it shows "This device is working properly."
My System SpecsSystem Spec
.

20 Sep 2015   #4
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 
ipconfig

Windows IP Configuration
Host Name BLUE
prinaryu dns suffix __
Node type broadcast
IP routing enabled no
wins proxy enabled no

witeless lan adpater wireless network connedction
media state media disconnected
connedction specific dns suffix ____
description dell wireless 1397 WLAN Mini-Card
physical address 00-26-5E-7D-02-0B
DNCP enabled yes
autonciguration enabled yes
(WIRELESS)

Wireless LAN adapter wireless network connecdtion 2
media state media disconnected
connection specific DNS suffix ___
Description Microsoft Virtual WiFi Miniport Adapter
Physical Address 00-26-5E-7D-02-0B
DHCP Enabled yes
Autoconfiguraton Enabled Yes
My System SpecsSystem Spec
20 Sep 2015   #5
GokAy

Windows 7 Ultimate x64 SP1
 
 

You seem to be missing the Ethernet card. Never heard of such a thing, but can you check Fn key combos for Ethernet? It may also be disabled within BIOS (Setup menu when you first start the PC).
My System SpecsSystem Spec
20 Sep 2015   #6
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 
Bios

Running Setup/System Configuration/Integrated NIC shows
enabled=The internal LAN is enabled
My System SpecsSystem Spec
20 Sep 2015   #7
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 
Ethernet card

How would the ethernet card be shown in these various menus--I mean what should I be looking for that will identify the ethernet card?
My System SpecsSystem Spec
20 Sep 2015   #8
GokAy

Windows 7 Ultimate x64 SP1
 
 

Do you have any unknown device in Device Manager?

In Device Manager it should show as the Manufacturer and model, for example mine show as "Realtek PCIe GBE Family Controller".

But in Network Connections it is supposed to be (can be renamed) "Local Area Connection" however it should also have the card name visible. The left-most in screenshot..
WAN Miniport won't activate for hard-wired connection-network-connections.jpg


My System SpecsSystem Spec
20 Sep 2015   #9
Squidward

W7 Home Premium, W7 Professional, W8.1
 
 

Thanks so much for all your great help!

The network connections screen shows only these 2 devices--Wireless Network Connection Dell Wireless 1397 WLAN Mini-Card and Wireless Connection 2 Not Connected Microsoft Virtual WiFi Miniport Adapter.

I will look further for something like Realtek and controller.

It appears that this is not a W7 issue, but when I try to create a new broadband connection, I get Error 651: Your modem (or other connecting device) has reported an error. Researching this, I find a lot of references to it occurring commonly in W7, with no real clear single answer yet a lot of different approaches.

Gary
My System SpecsSystem Spec
20 Sep 2015   #10
GokAy

Windows 7 Ultimate x64 SP1
 
 

Well, you don't create an Ethernet connection like that. And your card may have a different name. I gave that as an example. There are many network interface card manufacturers and as many models of cards.

What is the exact make/model of your PC?
My System SpecsSystem Spec
Reply

 WAN Miniport won't activate for hard-wired connection




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Wired LAN Connection: "Unidentified network" No Internet Connection
Hi, I'm having a little bit of trouble connecting my computer to a wired internet connection. My wireless works, but some of the programs I am running require wired connections. My Physical connections are pretty weird, so I think I'll get that out of the way first. I have an AT&T wireless modem....
Network & Sharing
Wired LAN Connection: "Unidentified network", No Internet Connection
Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\Jesse>ipconfig /all Windows IP Configuration Host Name . . . . . . . . . . . . : JPC Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid
Network & Sharing
Wireless connection works, wired connection does not.
So last night, my wired connection was working. I did not install any new software or download anything. Tried getting on the internet today and nothing. My computer has an IP Address but I can't get onto the internet at all. I can't ping google. I can ping my IP address assigned, can't ping my...
Network & Sharing
server connection or is it my miniport?
last year,i was able to play games like S4 league,maplestory,TF2,etc...but idk i think it started in November,i went 2 my laptop,but i couldn't get to S4,like when i run as admin it get thats circle loading thing next to the mouse but only for a split sec. and then just stops loading the patch,so i...
Gaming
No Wired Connection to PC
I have AT&T U-Verse with a 2Wire (3801 HGV) router. I've had the service for about a month without any issues. As of now, I am able to connect to the internet using WiFi (via my Wii, iPhone, and Laptop), but when trying to make a WIRED connection (via ethernet cable from the 2wire router directly...
Network & Sharing
windows 7 keeps disconnecting my hard wired internet connection
I have all of my computers (4 of them) hard wired into the router. Then the other day my step-daughter needed to print something out from her computer that had a program on it that mine did not have and my computer is the only one with a printer (the kids 10 and she'll print out anything). So I ...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App