Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet with custom IP

06 Jan 2016   #21
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Okay folks, I need a little help understanding.

Why would one need or want a custom I.P. address to access the internet?


My System SpecsSystem Spec
.
06 Jan 2016   #22
UsernameIssues

W7 Pro SP1 64bit
 
 

Somacruz,
That does seem odd. 192.168.1.1 should be in that default gateway setting - but, whatever works.

Layback Bear,
Normally, you don't need a static IP address in your private network space. However, a static IP address might be needed if you are forwarding ports to a particular computer or you wish to place a computer in the DMZ.

For business networks, static IP addresses are useful to avoid delays (and errors) in fanning out newly* assigned IP addresses. In theory, such fan outs should happen within minutes. In reality, it might take hours before you can ask remote control software to connect to a computer using its computer name. It is best to just connect directly to its static IP address.

*e.g. a computer that has been off for a while, might get a new (dynamically assigned) IP address once it reconnect to the network.
My System SpecsSystem Spec
06 Jan 2016   #23
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Thank you for the information UsernameIssues.

My understanding of this thread is one home computer and access to the internet.
No server networking or the such.
I'm not familiar with such things being just a home user, no server, no networking except my computers accessing the internet which is done automatically in the settings.

I'm trying to understand why a user like me would want to do such a thing.

Somacruz is going through a lot of effort that I'm not understanding. Their must be a goal for all this effort.
My System SpecsSystem Spec
.

06 Jan 2016   #24
UsernameIssues

W7 Pro SP1 64bit
 
 

Layback Bear,
In the OP, Somacruz mentioned not wanting to revive an old thread. My guess is, this is the old thread:
Network starting slow after some programs

Perhaps Somacruz is still seeing apps that try to connect to the Internet before the networking stuff completes. Using a static IP address skips the time that it takes for the DHCP steps to complete - but I doubt that using a static IP address will help enough.

Somacruz,
If that is the issue, then there is a GPO setting that will delay* the presentation of the desktop (and those start up apps) until the networking stuff completes. Let me know if you want me to dig them up.

*the delay can take 20 or 30 seconds. I would rather see the desktop as soon as possible.

Alternately, scripts can be used to detect that the network is up - then start your apps :-)
My System SpecsSystem Spec
07 Jan 2016   #25
joedaman633

Windows 10 x64
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Okay folks, I need a little help understanding.

Why would one need or want a custom I.P. address to access the internet?
Depends which custom IP address you're referring to.
Some people believe that using an alternative DNS server (such as Google's free offering) is quicker than using the automatic settings which is usually the ISP's own DNS server.

Setting a static private IP is good if you're setting up port forwarding etc on your router.
My System SpecsSystem Spec
07 Jan 2016   #26
Somacruz

Windows 7 Ultimate x64
 
 

Well today it stopped working again... and I had to go back to automatic.

Edit: And now a few minutes later I set it to static AND NOW IT'S WORKING AGAIN... what is even going on?
My System SpecsSystem Spec
07 Jan 2016   #27
UsernameIssues

W7 Pro SP1 64bit
 
 

Maybe you should leave the computer on automatic and set your router to assign computers the desired DNS IP addresses. What is the make/model of your router?
My System SpecsSystem Spec
07 Jan 2016   #28
Somacruz

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Maybe you should leave the computer on automatic and set your router to assign computers the desired DNS IP addresses. What is the make/model of your router?
Well it's currently working but.. I got a Technicolor TG799vn v2
My System SpecsSystem Spec
07 Jan 2016   #29
UsernameIssues

W7 Pro SP1 64bit
 
 

Glancing thru the users manual, I did not see a way to set the DNS values. Some routers don't let you change those settings.

I'm not sure what else to suggest that you try.
My System SpecsSystem Spec
07 Jan 2016   #30
Somacruz

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Glancing thru the users manual, I did not see a way to set the DNS values. Some routers don't let you change those settings.

I'm not sure what else to suggest that you try.
Well, it seems to be working now. I'll leave this open until Sunday then I'll mark as resolved.

Thanks everyone that's been a help in this thread.
My System SpecsSystem Spec
Reply

 No internet with custom IP




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Westminster Custom Themed Win7 and Your Custom Themes
Hello! I'm a new User here and I'm gonna show you my custom themed Win7 that I Dubbed "Westminster". Feel Free to post about your custom themes tht you've made your own for any version of Windows! (It's only in the 7 section because mine is 7) To me it feels like It is A Windows 9 kinda thing....
Themes and Styles
[HELP] Internet Explorer 10 doesn't work with some custom shell32.dll
I've modified the icons in my shell32.dll using Resource Hacker and when I've applied it Internet Explorer fails to start. It gives an error which reads, "iexplore.exe - Entry Point Not Found" The procedure entry point shell32.SetCurrentProcessExplicitAppUserModeID could not be located in the...
Customization
New Custom Built Computer. BSOD involving using internet/network
I've been solving this for almost two months but still no good. I have a new custom built pc, below is my specs: VCard: R9285 RAM: HyperX Fury (4gb) PSU: Thermaltake Lite Power (600Watts) MOBO: Z97 Gaming 3 Processor: I5 4460 I also reformat my pc for so many times. My problem is that...
BSOD Help and Support
How do I remove custom theme, and custom icons?
Hello, I installed a custom theme and custom icons some months ago. I don't like it anymore, and would just like to go back to the good old windows 7. How do I do that? Cad
Themes and Styles
Easy Custom image + custom recovery OEM like system?
Ok.. I'm just throwing this out here...it's darn late hihi I have written a 'program' (script), which will automate a recovery system for windows 7, full with a working bootmanager, (custom) partitioning, ramdisks, custom environment (winre/pe), and backup imaging , all legal and licensed...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App