Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Problems (Sob)

25 Nov 2009   #1
13light

Windows 7
 
 
Internet Problems (Sob)

Alright, I am sure everyone is having this sort of problem, but i still dont have any answers.

I have just recently upgraded my XP to Windows 7.
On my XP, my internet ran fast but, when i installed windows 7, my download speed dramatically dropped. Ex: 1mb/s too 100kb/s.

Im pretty sure nothing else is the problem because i reinstalled windows 7, and the internet speed was back up but, when i installed windows 7 again, it went back down.

I am currently using a Linksys WUSB600N Adapter with a Linksys WRT160N for the router.

Does anyone have any clue how to fix this problem?

(P.S. I have upgraded the Driver for the Network Adapter)


My System SpecsSystem Spec
25 Nov 2009   #2
Gornot

Windows 7 Home Premium x64
 
 

Updated from Windows Update, installation CD or the manufacturer's website?
If you haven't done so yet, check the manufacturer's website for newest drivers.
My System SpecsSystem Spec
25 Nov 2009   #3
13light

Windows 7
 
 

Yes, i have done the Windows Update, and also i have already updated my network drivers.
My System SpecsSystem Spec
25 Nov 2009   #4
spawn

XP, Vista, Win7, Kubuntu
 
 

Try using a different web browser other than IE. Second linksys routers have a tedency to crap out. I have been using a dlink router I got for 10 bucks for 4 years. My parents had a linksys that fried out after about 2 years
My System SpecsSystem Spec
25 Nov 2009   #5
13light

Windows 7
 
 

Hmm thats what im starting to suspect... That linksys products might be the problem.
My System SpecsSystem Spec
25 Nov 2009   #6
patwhatsthat

Windows 7 Ultimate 64bit
 
 

Linksys admits issue with router here Re: WRT160N Problems - Wireless Routers - Linksys Community Forums a router firmware upgrade could be a possible solution look around here, need to know your versions number Linksys by Cisco - WRT160N Support hope this helps
My System SpecsSystem Spec
25 Nov 2009   #7
Raargh

Windows 7 Pro x64 (dual-booting XPSP3 and Win7)
 
 

@13light:

I went nuts for months with similar intermittent slowness problems until I replaced my older Linksys router with a brand-new Linksys 4-port 802.11abgn router. Got it at WalMart for $70.00. Prior to that I was going crazy , tormenting the RoadRunner tech support people. The new Linksys unit is fabulous, all problems went away.

Some good sites/things:

netmeter - I can't live without it:

Download NetMeter 1.1.4 Beta 4 / 1.1.3 - A handy network software that will monitor your bandwidth - Softpedia

http://www.speedtest.net

Ditto use FireFox, not IE!

Raargh
My System SpecsSystem Spec
26 Nov 2009   #8
13light

Windows 7
 
 

Yes, im a firefox user too. Hmmmm, well i guess it might be my router. But then, why did my internet run smoothly on XP.
My System SpecsSystem Spec
Reply

 Internet Problems (Sob)




Thread Tools





Similar help and support threads
Thread Forum
AT&T Internet Problems
I have AT&T DSL with filters on all my jacks and I’ve constantly had trouble with losing the connection off and on all day long. This has been going on for over 2 years but AT&T does not show any problems on their lines and a tech came out (August 2013) and didn’t find anything on the lines going...
Network & Sharing
Internet Problems
Hi we have a Linksys WAG160Nv2 and we are getting slow speeds :cry:(See below) First of all the router says its not designed for multiple PCs???? We have 2 phone 1 console and 3 pcs nearly always connected the the router, if the router has been on for a few days it will drop out. If...
Network & Sharing
Serious problems with internet.
hi, sorry if this is a dupe post but i really can not be bothered reading through 15k of threads. anyway, since i got win7 ultimate iv been having really bad internet problems. the problem isnt the internet, because i can connect to steam and websites perfectly. but when i try to connect to a...
Network & Sharing
Internet Problems!!
My internet worked fine until about 9 days ago when i installed Norton. Now, I can't get internet pages to load completely without having to refresh the page several times. This happens in Firefox and IE....Chrome won't load anything. I unistalled the Norton, emptied cookies, checked drivers for...
Browsers & Mail
Problems with Internet
Hello, I am currently having problems with my internet on only this PC, I really don't want to reformat because that takes forever. I have tried Fix7 or something. Tried scanning with KIS and uninstalled that to see if that was the problems I also reset the router to reconfiger is mostly...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App