Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgraded to 7, now no internet...


20 Dec 2009   #1

7600
 
 
Upgraded to 7, now no internet...

Ok well I'm dual booting 7 with XP now and just as it may be, 7 doesn't recognize my aftermarket PCI 10/100 Netgear Ethernet Adapter... My original one just stopped working, so I bought a new Netgear about 2-3 years ago and it has worked fine with XP/Vista but now I just installed Windows 7 and it only recognizes the VIA Rhine II Fast Ethernet Adapater that came with my computer, and not the NETGEAR FA311 Fast Ethernet Adapter that I've been using. I located the drivers for the Netgear but it only goes up to Windows ME compatibility it says, but I had it working fine with Vista so that doesn't quite make sense.... Since I'm dual booting isnt there a way I can just copy files from XP to 7 to make it recognize the Netgear adapter..?? Thanks..


My System SpecsSystem Spec
.

21 Dec 2009   #2

64-bit Windows 8.1 Pro
 
 

Have you tried installing the driver in XP compatibility mode?
My System SpecsSystem Spec
21 Dec 2009   #3

Windows 7 Ultimate x64
 
 

is there a way you can get your computer close enough to your router to hook it up via wired connection? if so, connect it by wire and when it is running, try to go to windows update and see if you can download a newer driver via windows update.
My System SpecsSystem Spec
.


21 Dec 2009   #4

 

The Netgear card FA311 is using a RTL8139D Chipset

verify this, then
get the driver from Realtek and all is well


http://www.realtek.com.tw/downloads/...&GetDown=false
My System SpecsSystem Spec
21 Dec 2009   #5

7600
 
 

The driver download includes a HELP.EXE that installs the driver from DOS and the highest it goes is ME/2000..?? But I dont understand how it came stock in my XP setup..?? And also it ran in vista fine... I'll search the chipset idea too, hopefully something gives here... Thanks, keep answers coming =)
My System SpecsSystem Spec
21 Dec 2009   #6

 

Just look what's printed on the chip - likely Realtek!

I am using here the Netgear GA311 adapter (realtek chip) and it works flawlessly with the Realtek driver, obviously!
My System SpecsSystem Spec
21 Dec 2009   #7

7600
 
 

Hmmm, well I downloaded the chipset and set it to XP compatibility mode, rebooted, and it still doesn't recognize the FA311... And just for ****s I rolled back the OEM Network driver and that didn't work either =(
My System SpecsSystem Spec
21 Dec 2009   #8

 

have you verified what's printed on the chip?

you do not need XP compatibility as there is a Windows 7 driver for this card/chip

once the driver is installed it shows as an Realtek adapter - not Netgear!
My System SpecsSystem Spec
21 Dec 2009   #9

7600
 
 

I even just moved the Netgear Adapters PCI slot to a diff available slot and still not recognizing it... And in Device Manager it only shows my OEM adapter under Network Cards, than in Other Devices it has "Ethernet Controller" and "Multimedia Audio Controller" both with exclamation points... I click them and hit update driver, no driver found it says... Well now I finally got it to recognize the driver by manually finding and installing it, and the light on the ethernet port lights up so I know it sees it, but I'm still getting no internet and it says "Local Area Connection" ip Configuration error or some b/s and the Network and Sharing center still show "No Network Access"...
My System SpecsSystem Spec
21 Dec 2009   #10

7600
 
 

Yeah there is a Netgear symbol and what looks like a Realtek symbol...
My System SpecsSystem Spec
Reply

 Upgraded to 7, now no internet...




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33