Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless ad-hoc not working after reconnect

23 Dec 2009   #1
him80us

win 7.600
 
 
Wireless ad-hoc not working after reconnect

hey all

i have a problem in win 7 on 2 different comp...on 2 dif wireless(an atheros laptop wireless and an atheros usb)

i can setup an ad hoc connection with internet no problem....works like a charm but...

if the server computer enters to sleep....after resume....the ad-hoc doesnt work anymore...only sais "identify.." and doesnt work anymore....

need to make another new ad-hoc connection to make it work

the ad-hoc connection is saved so i can use it another time....but once disconnected i can never reconnect to make it work...

i know the ad-hoc network its a temprary connection...but why bother to save it if it doesnt work afterwards

the command << netsh wlan connect name=Profile2 ssid=SSID2 interface="Wireless Network Connection"
>> works smooth but its in vain if the connection is not working after reconnect..

i said before its not working on s3....but not working on restart either....not even working if i disconnect the host PC and connect it again....cant really reconnect...

any ideas ?....

ps: the router is not a solution

thx


My System SpecsSystem Spec
.
23 Dec 2009   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

You should be using the wireless connection setup wizard in Windows 7 to set up those wireless connections. For Windows 7 computers I would also use Homegroup networking.

There are certain elements of sharing that probably won't work correctly if you use ad-hoc.

http://windows.microsoft.com/en-US/w...a-home-network

http://www.7tutorials.com/how-connect-wireless-networks

Homegroup - Create

The sleep mode wireless adaptor problem is widespread and will probably or hopefully get fixed with driver updates. Anthros may have one now if you look for it, new drivers are showing up daily on some sites. You might need to disable sleep until a newer driver shows up that fixes the problem.
My System SpecsSystem Spec
23 Dec 2009   #3
TaraSWinTeam

Windows 7
 
 

Regarding your server falling asleep and needing to start over again you should check the power settings on the computer: Sleep and hibernation: frequently asked questions.

Here is some basic information for setting up a wireless network for internet at home: Setting up a wireless network.

Cheers,
Tara
Windows Outreach Team
My System SpecsSystem Spec
.

24 Dec 2009   #4
him80us

win 7.600
 
 

u guys didnt fully understaind....

the sleep problem is one disconnect problem

the most important problem is....that if i disconnect the server comp from the ad-hoc network and reconnect it again...without restarting or anything.....the ad-hoc saved network i made wont work at all afterwards on the satellite computer

i can only create a new ad-hoc to make it work again

this is what i dont understaind....
My System SpecsSystem Spec
24 Dec 2009   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Temp solution is to disable sleep on the server until a better driver comes along.
My System SpecsSystem Spec
25 Dec 2009   #6
him80us

win 7.600
 
 

dont really care about the sleep for now....

more concerned about not being able to reconnect the network after i disconnect

i just hit disconnect....then a few seconds later i hit connect(to the ad-hoc i created) and the internet and network sharing its not working for the other machines...

in my server machine sais my wireless is broadcasting internet acces....but they dont have any internet or network


im very skeptic about new drivers for my hardware....i have the latest one ...and its from 2007...so if they didnt get anything better for almost 3 years....i dont think they will optimize a driver now....

cheers and merry x-mass
My System SpecsSystem Spec
05 Feb 2010   #7
martin5454

Win7
 
 

I have the same problem, if anyone knows any solutions please spread the word. Its really annoying issue
My System SpecsSystem Spec
05 Feb 2010   #8
aem

Windows 7 Ultimate 64Bit
 
 

I'm gonna try this disconnection of adhoc.

I create a wireless adhoc off my W7, which is now using LAN to access the internet. I'll have my eeepc connected to this adhoc network. I will then shutdown W7 and restart it. So then question is, can i still connect to my adhoc from my eeepc, right?
My System SpecsSystem Spec
05 Feb 2010   #9
aem

Windows 7 Ultimate 64Bit
 
 

Update: adhoc connected saved. Restarted W7 and adhoc disconnects. Had to manually reconnect it (by clicking on the "Connect" button). It connects and waiting for users...On my eeepc, the network is picked up and i connect. no problems.

So really the adhoc just need to be re-established after a restart of machine/shutdown etc.
My System SpecsSystem Spec
14 Feb 2010   #10
him80us

win 7.600
 
 

try this :

create a new shortcut
pot this on its adress :
netsh wlan connect name=WirelessProfileName ssid=AdhocSSID interface="Wireless Network Connection Name"

wireless profile name = ur wi-fi name
adhocSSID = ur ssid
wireless network connection name = ur wi-fi connection name as is shown in "network connections" in control panel

eg:
netsh wlan connect name=mywi-fi ssid=mywi-fi interface="Wireless Network Connection"


put this shortcut in startup....and it will work like a charm

tip: try to give to ur adhoc a name without spaces....if u put spaces in ur adhoc name put it in "..."

so far this is the only way i know to make ur adhoc start and connect at restart
My System SpecsSystem Spec
Reply

 Wireless ad-hoc not working after reconnect




Thread Tools




Similar help and support threads
Thread Forum
Working with 2 wireless networks - Internet access and HDMI wireless
Hi, I have just got an EZCast home multimedia wireless sharing device. It works great from my acer laptop and from my android phone. HTC one! My problem is that it works as an access point so both my phone and my laptop need to connect as clients. when I do this I have no connection to the internet...
Network & Sharing
intel 1030n does not reconnect to wireless network after hibernation
Windows 7 XPS laptop. Connects to the wireless network just fine. However, when I suspend or put the laptop into hibernation it never reconnects. I take the lpatop out of hibernation and it shows a red x through the network icon. I have to try and manually reconnect, and then I just get the...
Network & Sharing
Wireless internet won't reconnect when laptop lid opened
This topic was posted in Dec without a fix. I have 2 Toshiba Satellite laptops with a Realtek wireless adapter running Windows 7 64 bit. Just started having the problem about a month ago with both laptops. The adapter is disable when lid is closed. I want the computer to go to Sleep when not...
Network & Sharing
Wireless Connection can't reconnect after Hibernate state.
Hey guys, I just have been wondering this for the longest time. Ever since I've had Windows Vista (I now have Windows 7 Ultimate x86), the Wireless signal can never be re initialized after coming back from the hibernation state. I've tried playing around with the power settings for the network...
Network & Sharing
WLM 2009 auto reconnect after internet reconnect
Hello, I have recently upgraded from XP to W7 Home Premium and ever since I have installer WLM if my internet connection drops WLM shows the countdown timer for auto reconnect, this timer counts down to 00 then doesn't even try to reconnect, the timer just starts counting down again, I never had...
Software
Cannot reconnect to wireless network
Bought a new laptop with Windows 7 a few days ago and connected to my wireless home network without difficulty. Worked great for three days then suddenly disconnected from network today. Cannot reconnect despite rebooting new computer and host computer. Laptop sees the wireless network but won't...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App