Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unidentified Network - Doesn't have valid IP Config.

29 Dec 2009   #1
joewin7

Windows 7
 
 
Unidentified Network - Doesn't have valid IP Config.

Hi, ever since I installed Windows 7 on my computer, I've been having trouble connecting to the internet. I have a wired connection to a Belkin router. I have the latest firmware for the router.

When I start my computer, sometimes it will automatically connect to the internet, however most of the time it doesn't. I see a yellow exclamation point over the networking icon at the bottom, which says "Unidentified Network - No Internet Access".

The only way to solve the problem is by running troubleshooter -- numerous times. When the troubleshooter doesn't work, it says "Local Area Connection doesn't have a valid IP Configuration". I then have to repeatedly troubleshoot, or disable and enable my internet. The troubleshooter "Resets the local area connection adapter" - which works sometimes, but sometimes it doesn't.

Other times, it connects to the Belkin router, but says that there is "No Internet Access."

I have disabled the Bonjour service, which was a suggestion I saw in previous threads.

Please help me stop this annoyance of troubleshooting my connection every day!


My System SpecsSystem Spec
.
29 Dec 2009   #2
Jonathan_King

Windows 7 Professional x64
 
 

Hello Joe, Welcome!

Try updating you network adapter drivers. Go into Device Manager and right-click on your network adapter. If that does not work, go to the manufacturer's site and download them there.

Hope this helps,
~Jonathan
My System SpecsSystem Spec
29 Dec 2009   #3
PooMan UK

Windows 7 Ultimate 64bit
 
 

You could also try using a static IP address, just in case the router isn't dishing out the correct IP via DHCP
My System SpecsSystem Spec
.

29 Dec 2009   #4
joewin7

Windows 7
 
 

Thanks for the welcome. I have already updated my network adapter driver to the latest version. I have a Intel(R) 82562V-2 10/100 Network Connection.

Quote   Quote: Originally Posted by PooMan UK View Post
You could also try using a static IP address, just in case the router isn't dishing out the correct IP via DHCP
How do I do that?
My System SpecsSystem Spec
29 Dec 2009   #5
Jonathan_King

Windows 7 Professional x64
 
 

Where did you get the drivers? Regardless, try the other way. If you downloaded them from the manufacturer, try uninstalling them and using Windows Update, and vice versa.
My System SpecsSystem Spec
29 Dec 2009   #6
joewin7

Windows 7
 
 

I've tried both ways, actually. The first time I updated through device manager, then I went to the website and saw there was another update, so I updated through there.
My System SpecsSystem Spec
29 Dec 2009   #7
PooMan UK

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by joewin7 View Post

How do I do that?
I'll put together a "how to" shortly pal .... just gathering some images to make it easier.
My System SpecsSystem Spec
29 Dec 2009   #8
PooMan UK

Windows 7 Ultimate 64bit
 
 

Okidoki

Firstly Open "control panel" click on "network and sharing center"

Click on "local area connection (1)" then follow the image clicking through to (5)
Once at 5 enter your IP address .... this will depend on what address your network is running on (I'm hoping that you know this already) I've given an example. If you router is set to eg 192.168.0.1 then you will need to enter this into the "default gateway" and "preferred DNS (6)" (I've marked the last number with an "X" as this could differ) When you enter your IP address just change the last number to anything between say 10 - 20 eg. 192.168.0.10



Once you've done all this click OK then wait a few seconds and try again.


Attached Thumbnails
-static_ip.jpg  
My System SpecsSystem Spec
29 Dec 2009   #9
joewin7

Windows 7
 
 

I followed the steps but unfortunatley I still have the same problem
My System SpecsSystem Spec
29 Dec 2009   #10
PooMan UK

Windows 7 Ultimate 64bit
 
 

What model is the Belkin router, maybe its not Win 7 compatible ?

http://www.microsoft.com/windows/com...uters&v=Belkin
My System SpecsSystem Spec
Reply

 Unidentified Network - Doesn't have valid IP Config.




Thread Tools




Similar help and support threads
Thread Forum
Fresh Win7, no net, lcl area connect doesn't have valid ip config
Hoping I can get some help, this one is a head-scratcher. I have a PC that was having an unrelated problem and decided the simplest fix would be to reformat the HD then reinstall win 7. I've done this before without any problems; however, this time the PC will not connect to the home network...
Network & Sharing
Please help me to fix my problem in unidentified network and IP config
Please help... I was having a problem connecting to network... It always says "Unidentified Network and at the same time IP config doesnt exist... Help me anyone... Please see my IP config below...
Network & Sharing
Unidentified Network local area connection doesn't have valid ipconfig
There was lightning near my house today when it struck the power went out for a second and when it came back the Internet didn't work. And my network says Unidentified Network and when I troubleshoot it I get "local area connection" doesn't have a valid ip configuration. I'm not really sure what...
Network & Sharing
Wireless Network Connection Doesn't have a valid IP Config.
So I'm having a major problem with my laptop. Been fine connecting to the internet since day 1 and now after having my laptop for about 6 months, It decides to connect, but have "Limited Access", therefore, not allowing me ANY Access. I diagnosed the problem and it told me to shut router off, all...
Network & Sharing
Local area connection doesn't have a valid ip config error craziness
Hello all and ahead of time thanks for your help. I've searched google for around 10 hours for solutions and have tried to apply them. Ok first off my network card does say it's working properly when i go to device manager. This just suddenly happened when i woke up one day after turning off my...
Network & Sharing
Local Area Connection doesn't have a valid IP config
Hello, There have been already few threads open for this topic not only on this forum but on different ones around the world, however the problem is still not solved, thus I decided to open a new topic and solve this problem once and for all. Here is the problem: I cannot connect to my wired...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App