Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Very, very slow internet connection on Windows 7

30 Dec 2009   #1

Snow Leopard/Windows 7
 
 
Very, very slow internet connection on Windows 7

Hi, it's my 1st post on this forums. I've got huge problem with my internet connection on Windows 7.
I have 6Mb/s internet connection (always downloads 750-800 kbps - it is not my bandwich issue, cause on my iMac wirelessly everything runs great). I have Kasypersky Internet Security installed. I tried to turn off/on my router, Linksys WAG300N, Kaspersky, change ethernet cable, turn on/off my ethernet card in Windows 7. It is integrated ethernet card that is on Asus's P6T MoBo. Really I don't know what to do. I tried almost everything :/. Sometimes it's ok, but usually not. What I have to do? Reinstall whole Windows 7 or what? I'm stucked. Any tips?

ps. On speed tests it shows less than 1Mb/s and it downloads max. 100kb/s.

My System SpecsSystem Spec
.

30 Dec 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by marcin0903 View Post
Hi, it's my 1st post on this forums. I've got huge problem with my internet connection on Windows 7.
I have 6Mb/s internet connection (always downloads 750-800 kbps - it is not my bandwich issue, cause on my iMac wirelessly everything runs great). I have Kasypersky Internet Security installed. I tried to turn off/on my router, Linksys WAG300N, Kaspersky, change ethernet cable, turn on/off my ethernet card in Windows 7. It is integrated ethernet card that is on Asus's P6T MoBo. Really I don't know what to do. I tried almost everything :/. Sometimes it's ok, but usually not. What I have to do? Reinstall whole Windows 7 or what? I'm stucked. Any tips?

ps. On speed tests it shows less than 1Mb/s and it downloads max. 100kb/s.
I will bet you have win 7 setup using homegroup. Homegroup uses IPv6 and has been shown to have some problems with slow DL's on some systems.. There is an easy way to find out. Set up a new network using the workgroup instead of homegroup if you speed increases and it will you can then dis able the IPv6.


Good luck

Ken J+
My System SpecsSystem Spec
30 Dec 2009   #3

Snow Leopard/Windows 7
 
 

I don't know what do you mean by having win 7 setup using homegroup. OK, than what if I use IPv4? I should change IPv6 - and this IPv4 is an issue? But on my iMac I have IPv4 and everything is correct.
My System SpecsSystem Spec
.


04 Jan 2010   #4

Windows XP & Windows 7
 
 

I had a similiar problem due to Security software. It took away 20-30% of my bandwidth.

Here's a couple of things to do....

1. Make sure your network drivers and Router firmware are updated.
Check your Router settings

2. Go into SAFE mode (hold F8 at boot)and see if the issue still occurs. If not, it is probably an application that is being loaded at start in normal mode.

3. First things to look at are security software. Remove Kaspersky and any other security software althogether and see if you still get bandwidth issues. If yes, add them back in one by one to see which one impacts. If you just the one software, check the settings to see if is has some type of network or web shield. You don't really need a firewall other than your Routers.

4. Look at all running processes under Task Manager and END process one by one (the ones that you can) to see if any of them cause the problem.

5. Windows 7 manages TCP/IP settings automatically, so there is very little to tweak. It tends to be an application using bandwidth resource (uTorrent, Skype, Antivirus, Antispyware, or any network application that may be running in the background.) It maybe a matter of elimination.
My System SpecsSystem Spec
04 Jan 2010   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

The prior poster has covered most basis, but I have given you information provided by MS, that will tell you how to implement some of the suggestions given above.


How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
My System SpecsSystem Spec
04 Jan 2010   #6

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

If you connect directly to the modem does it change anything or make the connection faster?
My System SpecsSystem Spec
05 Jan 2010   #7

Windows XP & Windows 7
 
 

Which version do you have installed...64 or 32 bit?
64 bit versions are having real issues with drivers.
My System SpecsSystem Spec
Reply

 Very, very slow internet connection on Windows 7





Thread Tools



Similar help and support threads for2: Very, very slow internet connection on Windows 7
Thread Forum
Very slow internet connection Network & Sharing
Solved Windows 7 SP1 causes slow internet connection Network & Sharing
New Laptop Windows 7 64bit but internet connection very slow. Network & Sharing
Windows 7 SLOW Wireless Internet Connection Network & Sharing
Windows 7 internet connection is suddenly very slow Browsers & Mail
Internet Connection too Slow Network & Sharing
Slow Internet Connection with RC :/ Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:07 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33