Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need help - network connection - using Realtek RTL8157

19 Jan 2010   #1

Windows 7 Home Premium
Need help - network connection - using Realtek RTL8157

Hi all,

I just purchased a custom system from California and have been trying to get my internet set up. I'm running a wireless modem connected via ethernet. I have a Realtek RTL8157 PCIe controller.

The problem is that when I connect, the network found though windows networking says its an unidentified public network, and I can't connect at all.

Plugging it right in worked fine with my old winXP machine, as it should with any system with a good ethernet card.

Is it a windows 7 problem or is there something wrong with my ethernet controller? I have the latest drivers.


My System SpecsSystem Spec
19 Jan 2010   #2

Windows 7 Ult, Windows 8.1 Pro,

There are some new Windows 7 drivers released on 1/11/10 for the RTL8157L on the Realtek site that might be worth trying. > Realtek

As for the unidentified network problem, it's fairly common and not too hard to fix.
Try here.> Windows 7 Unidentified Network, Limited Access, No Internet Connection Problem Resolved

Another way to change the unidentified network is to: Press WinKey+R, type "secpol.msc" without quotes. Then click Network List Manager Policies on the left, and then you should be able to change the unidentified network from there by right clicking on "unidentified networks" then properties and change the settings.

Attached Thumbnails
Need help - network connection - using Realtek RTL8157-local-services-network-change.png  
My System SpecsSystem Spec
20 Jan 2010   #3

Windows 7 Home Premium

Thanks for the reply. I made a mistake last night, I actually have the Realtek RTL8167 (not the 8157); and as far as I can tell its built into the motherboard, so I'll try and update the drivers for the motherboard.

I also tried the trick with the Gateway IP, and it didn't work, but I'll remember the trick in the future.

Thanks for the advice, if you have any other ideas please let me know, cause I'm running out.
My System SpecsSystem Spec


 Need help - network connection - using Realtek RTL8157

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
'Bluetooth connection' is shown in my Network Connection suddnly.
Hi, I really had not this 'Bluetooth connection' before. But, I really don't know that pairing my Nokia Bluetooth with my HP Laptop Bluetooth would add this Bluetooth connection or NOT. I really guess this Bluetooth Connection was listed there when I connected my Lapotp Bluetooh with Nokia...
Network & Sharing
Local Area Connection missing from network adapters, no connection
I have a Windows 7 Home Premium computer that is not connected to the internet. I have checked the drivers and they are all installed correctly and operational. When I go into the adapter settings there is no Local Area Connection adapter. I have included some screen shots of what I am seeing if...
Network & Sharing
Problems with New Realtek Card RTL8139/810x and wifi connection
Recently my network connection hardwired to the motherboard went bad. Installed a Realtek RTL8139 network card and now cannot get internet on the PC and wireless at the same time. Router and modem checks out. The original hardwired connection (to the motherboard) has been disabled. Any...
Network & Sharing
Very Slow Internet Connection - Realtek NIC
I have two desktops set up in my place, and they both act very differently when it comes to my internet connection. They both have very similar hardware setups, which include overclocked i5 750 processors, 4 gigs of GSkill RAM, and Gigabyte P55 mobos. They're both ethernet-connected to a...
Network & Sharing
Realtek 8185 wireless connection problem in w7 x64
Hi people I have recently bought a new computer. It originally came with vista x64 and I have recently upgraded this to windows 7 x64. Both on windows vista and windows 7 I have been having wireless connection problems with my Realtek 8185 Extensible 802.11b/g Wireless Device On Vista...
Network & Sharing
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App