Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with atheros L1 ethernet adapter in Win7 x64

27 Jan 2010   #31
Kandersen

Windows 7
 
 

I have the MB P5k, and I´m having the exact same problem with the Atheros. I simply can´t understand, how this driver can be released as WHQL driver, and yet fail to work. This is a serious matter. I´m running Windows 7 on several computers here at home and running daily backup on a Windows Home Server. This client with the Atheros has not been able to finish a backup yet, simply due to this error.

Neither 2.4.7.27 or 2.4.7.29 works here. This is very bad for Asus, and even more for Atheros!

Greets
Kim


My System SpecsSystem Spec
.

06 Feb 2010   #32
techvslife

win 7 x64
 
 

It seems worst of all for you--I doubt asus or atheros care that much about old product compatibility with a new os.
some people report going back to a much older version of the driver works.

(I made sure I'd removed the previous driver completely before I installed the newest, and that one works for me. Don't forget to add mpowrie's fix earlier in this thread.)
My System SpecsSystem Spec
02 Mar 2010   #33
enjuls

Windows 7 Ulitmate 64 bit (6.1 build 7600)
 
 

I have been struggeling with this issue as well (main pc freezes when streaming dvd's to my mediacenter)
Just wanted to let you know that disabling the Task Offload feature does solve the streaming/freeze problem in yr own network BUT... with this option turned off yr nic cant handle multipe internet request anymore for some reason.
When i download articles from usenet and stream radio or play an online game i get major lag and the stream halts, even when downloading (not even at max bandwidth) internet pages load very slow.
With the Task Offload Option set to "on" i dont have this problem.

My only option left was to buy a new nic and so i did, now all problems are resolved.

Hope this helps.

Cheers !
My System SpecsSystem Spec
.


11 Sep 2010   #34
markkenton

Windows 7 Pro 64bit
 
 
Atheros L1 GigE NIC workaround Win7 64Bit

Hi Crew,
This works
First update driver from Atheros Communications

Go into Atheros NIC adapter properties. click 'configure' tab & disable all the task off-load settings.

After over 100GB file transfer using GigE & Jumbo frames, - No NIC crash, wopeee!!!

Suggests that the Atheros NIC just can't cope with too many tasks & crashes

All the best
My System SpecsSystem Spec
23 Sep 2010   #35
bond007001

win 7 64-bit
 
 
Alternative Solution

Found this tip on another site and trying it out now. Instead of disabling Task Offload (which reduces your speed), disable Flow Control instead. Good luck!
My System SpecsSystem Spec
26 Sep 2010   #36
markkenton

Windows 7 Pro 64bit
 
 

Bond's tip above works, ie, disable ALL Flow control Tabs - thanks (yes & it does give better performance than disabling task off-load)
My System SpecsSystem Spec
02 Dec 2010   #37
albatrozz

Win7 Ult x64, Server 2008 r2, XP Pro
 
 

Confirmed, disabling flow control worked, but ONLY with driver v2.7.4.29.

Tested with Windows Server 2008 R2 x64 using the Win 7 x64 driver FWIW.
My System SpecsSystem Spec
03 Dec 2010   #38
markkenton

Windows 7 Pro 64bit
 
 

Hi Team, Try this, it works with my PC Win7 64bit driver 2.4.7.29
Flow Control - Off
FlowControl - off
Interupt Moderation - off
Interupt Moderation - Disabled
IPv4 Checksum Offload - Tx&RX Enabled
Jumbo Frame - 7KB MTU
Large Send Offload IPv4 - Disabled
Large Send Offload v2 IPv4 - Enabled
Large Send Offload v2 IPv6 - Enabled
Max IRQ per Second - 30000
Max Frame size - 1514
Media Type - Auto
Network address - no present
No of Recieve Bubbers - 2048
No of Transmit Buffers - 1024
Power Saving - on
Receive Buffers - 512
Recieve side scaling - Enabled
Shut down wake up - off
sleep down to 10M - on
Speed & Duplex - Auto
Task offload - on
TCP Checksum offload (IPv4 & IPv6) - Tx & Rx Enabled
Transmit Buffers - 512
UDP Checksum offload (IPv4 & 6) - Tx & Rx Enabled
Wake up - none
My System SpecsSystem Spec
21 Dec 2010   #39
carcuscrae

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by markkenton View Post
Hi Team, Try this, it works with my PC Win7 64bit driver 2.4.7.29
Flow Control - Off
FlowControl - off
Interupt Moderation - off
Interupt Moderation - Disabled
IPv4 Checksum Offload - Tx&RX Enabled
Jumbo Frame - 7KB MTU
Large Send Offload IPv4 - Disabled
Large Send Offload v2 IPv4 - Enabled
Large Send Offload v2 IPv6 - Enabled
Max IRQ per Second - 30000
Max Frame size - 1514
Media Type - Auto
Network address - no present
No of Recieve Bubbers - 2048
No of Transmit Buffers - 1024
Power Saving - on
Receive Buffers - 512
Recieve side scaling - Enabled
Shut down wake up - off
sleep down to 10M - on
Speed & Duplex - Auto
Task offload - on
TCP Checksum offload (IPv4 & IPv6) - Tx & Rx Enabled
Transmit Buffers - 512
UDP Checksum offload (IPv4 & 6) - Tx & Rx Enabled
Wake up - none
How do you get all these settings? MY L1 which is on my Asus P5K motherboard doesn't have options like Jumbo Frames ,
Large Send Offload IPv4 - Disabled
Large Send Offload v2 IPv4 - Enabled
Large Send Offload v2 IPv6 - Enabled
etc

Can you advise please?
My System SpecsSystem Spec
21 Dec 2010   #40
Bucic

Windows 7 64-bit
 
 

It works for me with the following settings and driver version L1WinSetup_v2.4.7.29_WHQL.rar:
Flow Control ON
Task Offload OFF
My System SpecsSystem Spec
Reply

 Problems with atheros L1 ethernet adapter in Win7 x64




Thread Tools





Similar help and support threads
Thread Forum
Looking for a USB Ethernet adapter for Win7 64 bit
Just like the title says - I upgraded to Windows 7 pro 64-bit, and I can't find working drivers for my Trendnet TU-ET100C. Is anyone using a USB to Ethernet device under Win7 64 that works well, or has anyone found Trendnet drivers that work? Thanks in advance!
Hardware & Devices
Atheros Ethernet driver BSOD
Im having issues with my Atheros Ethernet driver, my computer intermittently crashes when using OpenVPN . I tried two Atheros drivers and got the same result, I will try one more driver. If that does not fix the issue I will most likely get a PCI Ethernet card. I just need a second opinion on the...
BSOD Help and Support
Atheros AR5007 802.11b/g WiFi Adapter
I'm using the Atheros AR5007 802.11b/g WiFi Adapter and the specs of this adapter say that I should get speeds up to 54 Mbps. I'm only getting to 16 Mbps even though the speed in the connection status says 54. I have used it with 2 different wifi routers (Linksys and Asus),with 2 different IPS and...
Network & Sharing
Atheros Ethernet Controller drivers won't/can't install
Hi all I am having wireless connection issues and hoping someone here can help me After resent issues I had with my Gateway laptop (ID59C) I reformated and reinstalled windows. All has gone well all drivers and windows updates have been completed When I tried to get my wireless internet...
Drivers
Atheros Wireless Adapter Slowing Down
Hello, I have an Atheros AR9258 Network Adapter on a Lenovo Z560 laptop. I recently noticed that my internet speed was very slow, so I went to Speedtest.net. I found out that I am only getting 1/4 of the speed I pay for. I uninstalled the device and its drivers. I then re-installed them (using a...
Network & Sharing
Atheros wired ethernet connection problem
Every time I connect my laptop with the Atheros wired ethernet adaptor at my work at my university (but it works home), I am forced to uninstall the driver from the device manager and then restarting windows 7 to get it to connect (it automatically installs the driver in this case). This happens...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App