Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Belkin N Wired/Wireless Hates My Win 7

24 Jan 2010   #11

Windows7 Ultimate 64bit


Does the LED in front of your router light up for the port that's connected to your PC? Say you plug PC to port 1, is the LED indicator for port 1 light up when you plug your PC? If it lit up, then the problem lies with your PC, not the router. Here's what you can do, go to one of your laptop/PC that's working, check the IP address, try a "Manual IP address", put an IP address that is close to other computers (say you see your laptop has, use for your PC). Match the other numbers as others computer's, everything other than IP address MUST BE THE SAME as other PC, that includes "subnet mask", "default gateway", "preferred dns server". Report back when you're done.


Edit: Don't use an IP address that's already used by other PCs, it will bark at you.
Edit2: If you use manual IP addressing, and it connects, then the problem lies with your Windows 7 installation, check in control panel => administrative tools => services => DHCP client, make sure it's running.

My System SpecsSystem Spec
24 Jan 2010   #12

Windows 7 Professional


I strung up a crossover cable. From ipconfig /all:

Windows IP Configuration
Host Name ...... :Home-PC
Primary DNC Suffix : <- Blank
IP Routing Enabled: No
WINS Proxy Enabled : No

Tunnel Adapter Local Area COneection* 9:
Media State : Media Disconnected
Connection specific DNS suffix: <- Blank
Description : Teredo Tunnelling Psudo Interface
Physical Address:00-00-00-00-00-00-00-00-E0
DHCP Enabled : No
Autoconfiguration Enabled : Yes


Now there are no ip addresses as this PC is not getting one from the router?

So presumably, I reverse the set up and take the ip addresses from the XP machine that's connected to the router? I'm doing that nowish.

Ah, it's kind of irrelevant isn't it as it's a crossed cable? Anyway, I changed both over to similar ip's like in the tutorial (good work btw) and I'm getting request time outs.
My System SpecsSystem Spec
24 Jan 2010   #13

Windows 7 Professional


Tried that after Aem's suggestion. Nothing happening. I changed the ip4 address in the local area connection (incidently an Intel 82566DC Gigabit) and saved the change. I went back to ipconfig /all and got the same response as I listed in post above. I see this tunnelling thing but no ip address that I recognise.

DHCP client is running.

Edit1: There's a light on the back of the router for each socket and it's lit up OK, plus the front "wired icon" is lit, so according to the user manual it's physically OK. Likewise there's a light at the back of the desktop when connected, but the "signal/activity" light is flashing constant pulses, not random activity style-pulse.
My System SpecsSystem Spec

24 Jan 2010   #14

Windows 7 Ultimate 64Bit

So at it stands we are still unsure if your have a port (physical) issue or not. You cannot direct connect to the router to the default ip. And when you tried to test setup cross-cable and test ping it fails to get results.

If your router cannot detect your PC adapter MAC address, cos the cable or port connector is not working I'm not sure how to proceed as it would amost be a show stopper for u.
My System SpecsSystem Spec
25 Jan 2010   #15

Windows 7 Professional

I'm convinced the cable's OK as the other PCs work fine with it. I'm starting to think of either something unknowble wrong with the hardware socket of something drivery - IDK.
My System SpecsSystem Spec
25 Jan 2010   #16

Windows 7 Professional

I had another idea of deleting the ethernet card driver and letting Win 7 reinstall it. That was done but still no connection with the ethernet cable.
My System SpecsSystem Spec

 Belkin N Wired/Wireless Hates My Win 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
4g hotsot belkin N600 network wired what else do I need to buy
ok my set up : 4g internet through android hot spot.. I'm connecting to it through the wireless adapter in the media pc..(lenovo Q158 with 8 gigs ram) PC is pluged via lan wire to belkin N600AVHD router, all the media periferals are plugged lan into belkin... all is setup as home...
Network & Sharing
Wired vs Wireless network, is wireless safe.
I generally don't have a need to network computers together. In fact if I do network in my home it will be for only one purpose and would prefer to have the network down 99.99% of the time. I can run the lines needed to connect these two computers but wireless would be easier to get going. I...
Network & Sharing
wireless won't see wired. wired sees wireless
network sequence. Verizon DSL Modem bridged to Cisco wrt57g router (which handles the wireless) and then a 8 port switch which all but the laptop is plugged into. wired machines can see and interact with laptop, laptop can see wired machines but can not log in to any across network. (network not...
Network & Sharing
Belkin wireless USB adapters
This may be of use to someone. After trying for a couple of hours and failing miserably in installing my 7050 adapter on my desktop which included downloading to my laptop all the applicable versions of the software then putting then on a flash drive to insert into the PC I let the device...
Hardware & Devices
Belkin wireless problem
I'm using windows 7 64 bit and its working fine except one problem. I have a belkin fd8055 usb wireless adapter. It acts just like it did in vista 64 bit sp2 when it boots from a cold boot. While booting, the little internet strenth bars on the bottom right side start menu has a little blue hour...
Hardware & Devices
Can't find Belkin wireless G USB
I just installed windows 7 RC on my computer. Everything loaded fine, but I am having trouble getting my belkin wireless G usb working. I run the driver and it installs fine, and when it prompts me to insert the usb. When I insert the usb nothing happens. I have tried other USB ports and...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:25.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App