Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow internet speeds on WIFI


25 Jan 2010   #1

Windows 7
 
 
Slow internet speeds on WIFI

Hi all.

ok, this is my first post so hello to all.
i have ther following.

TP link router pre N 150 mbps and a TP link WIFI dongle also 150mbps.
I have a Virgin 50 meg internet connection.

When i download using a newsgroup via ethernet i get around 53mbps constant. no drop outs and very reliable.

Same PC same servers using WIFI dongle and i get MAXIMUM 30mbps. the speed regularly falls down to below 5mbps and then speeds up again.

I recently re-installed windows 7 and on my previous install i had the same problem, i downloaded SG TCP IP optimiser and it worked i got 47 mbps, i tried it again though on this install and it didnt.

The dongle is the TP link WN727N, this has no drivers on TP links website as it says windows 7 will automatically install the driver for it.

Any suggestions on how i can fix this?


My System SpecsSystem Spec
.

25 Jan 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by steve1978 View Post
Hi all.

ok, this is my first post so hello to all.
i have ther following.

TP link router pre N 150 mbps and a TP link WIFI dongle also 150mbps.
I have a Virgin 50 meg internet connection.

When i download using a newsgroup via ethernet i get around 53mbps constant. no drop outs and very reliable.

Same PC same servers using WIFI dongle and i get MAXIMUM 30mbps. the speed regularly falls down to below 5mbps and then speeds up again.

I recently re-installed windows 7 and on my previous install i had the same problem, i downloaded SG TCP IP optimiser and it worked i got 47 mbps, i tried it again though on this install and it didnt.

The dongle is the TP link WN727N, this has no drivers on TP links website as it says windows 7 will automatically install the driver for it.

Any suggestions on how i can fix this?

Hi steve.

I would bet you are using "homegroup" as your network model. homegroup on some systems is flaky. You can test it for yourself by simply creating a new network connection using the workgroup model. If the problem is fixed you can then disable IPv6 and kill homegroup


Let us know if you need help

Ken
My System SpecsSystem Spec
25 Jan 2010   #3

Windows 7
 
 

Hi,

Thanks i saw this reponse to another email, i suppose that would make sense if last time i gave it a different group designation.

I will report back.
My System SpecsSystem Spec
.


Reply

 Slow internet speeds on WIFI




Thread Tools



Similar help and support threads for2: Slow internet speeds on WIFI
Thread Forum
differing internet speeds on home wifi Network & Sharing
verizon Fios: wifi and ethernet, 2 different internet speeds Network & Sharing
Solved Slow internet speeds HP Pavillion DV7 Network & Sharing
Fast internet, slow download speeds Network & Sharing
Public Wifi Very Slow Download Speeds, Images Take Forever to Load Network & Sharing
Slow internet speeds/downloads Network & Sharing
Slow internet speeds during gaming Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33