Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP Sharing not functional

28 Jan 2010   #1

Windows Seven Professional 64-Bit
 
 
WMP Sharing not functional

Unsure of exactly what is causing this issue, but here it is.

Only a few days ago I had full media sharing functionality, but now I am completely unable to do make any use of it. I was using WMP to share my media to my 360 and other computers in the home, but for some reason it stopped working completely. I have discovered that the "share my media" under the media streaming options in the network and sharing center is grayed out and I cannot select it, whereas before I remember specifically selecting this option. After searching for a while I have also discovered that this may be caused by the "WMP network sharing service" being disabled, however after considerable time spent searching I have determined that this service either no longer exists on my machine or was removed somehow.

Any help would be greatly appreciated, I cannot seem to locate any solution for this issue elsewhere.

My System SpecsSystem Spec
.

28 Jan 2010   #2

Windows 7 Ultimate x64
 
 

Make sure that this is ENABLED.....


Attached Images
   
My System SpecsSystem Spec
28 Jan 2010   #3

Windows Seven Professional 64-Bit
 
 

I thank you for the reply, but it appears that the service in question (Media player network sharing) is completely absent from my machine. I am unsure of how this could have occurred, but I am more interested in restoring it if possible.
My System SpecsSystem Spec
.


28 Jan 2010   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

In that case open the command prompt by typing cmd into the start/search, right click on the small dos icon above and select "run as admin" then type sfc/scannow at the blinking cursor then hit enter. Let the scan complete which will take some time. That should fix any file delation problems you might have had and hopefully get WMP sharing working again.

You might also want to check in msconfig and make sure the process is checked off and running. At the start/search window type "msconfig" then enter. Make sure the process is running like in the picture.


Attached Images
 
My System SpecsSystem Spec
28 Jan 2010   #5

Windows Seven Professional 64-Bit
 
 

yes I have checked MSconfig, but couldn't find the service.

I will try your suggested fix now, and thank you for the reply.
My System SpecsSystem Spec
28 Jan 2010   #6

Windows Seven Professional 64-Bit
 
 

I appear to be encountering an error when the "verification stage" reaches 58%

Code:
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>sfc/scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 58% complete.

Windows Resource Protection could not perform the requested operation.

C:\Windows\system32>sfc/scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 58% complete.

Windows Resource Protection could not perform the requested operation.

C:\Windows\system32>
I take it this is not supposed to occur?
My System SpecsSystem Spec
28 Jan 2010   #7

Windows 7 Ult, Windows 8.1 Pro,
 
 

Nope that's bad. About all I can think of is to perform either a repair install from the Windows CD or a system restore to an earlier point in time.

I would go with the system restore option first.

System Restore

Repair Install
My System SpecsSystem Spec
28 Jan 2010   #8

Windows Seven Professional 64-Bit
 
 

I am trying to avoid that if possible, but it looks as if I may have to make use of the startup repair regardless.

Thank you anyways for the assistance.
My System SpecsSystem Spec
28 Jan 2010   #9

Windows 7 Ult, Windows 8.1 Pro,
 
 

I would avoid it also but at this point the recovery options seem to be all thats left. Somehow your system files got messed up but I'm not sure how. Start up repair might fix the problem also but generally that one is used to fix problems with Windows starting.
My System SpecsSystem Spec
28 Jan 2010   #10

Windows Seven Professional 64-Bit
 
 

The only recovery images I have are from a couple of days back, which is after the problem seemed to appear. I'll browse around and try and determine the best method of recovering my core windows files, and see what I can find.
My System SpecsSystem Spec
Reply

 WMP Sharing not functional




Thread Tools



Similar help and support threads for2: WMP Sharing not functional
Thread Forum
Recycle Bin Image gone but functional General Discussion
Need to reformat HD without current functional os Installation & Setup
Onscreen keyboard not functional General Discussion
Solved HP Toolbox not fully functional? Software
Non functional IE9 and can't go to IE8 Browsers & Mail
Backup and Restore non-functional Backup and Restore
Win 7 fully functional if I install before Oct. 22nd? Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:07 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33