Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Homegroup joined but no access...


29 Jan 2010   #1

Windows 7 Professional x64
 
 
Homegroup joined but no access...

I'm having trouble with my a Homegroup. I turned off my Homegroup to compare transfer speeds between Homegroup and mapped drives. I reenabled it and now it doesn't work.

I have two PCs running Windows 7 Professional. I created a Homegroup on PC1 and PC2 reports a Homegroup is available to join on PC1. I can join the Homegroup. Homegroup reports "joined" in the Networking Centre and "Homegroup" appears in the lefthand navigation pane on open folders. However, clicking on Homegroup returns the message that no homegroup computers are available.

I have...
Verified that both PCs are in the Home network.
Verified that PC1 has directories shared in the Homegroup.
Verified that IPv6 is enabled on both PCs.
Disabled firewalls on both PCs.

Network appears OK as I can see PC1 from PC2 and access directories if I share them the old fashioned way.

I have tried leaving the Homegroup and rejoining with the same result.

Any ideas what might be stopping the Homegroup from working?

My System SpecsSystem Spec
.

29 Jan 2010   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Try setting the Library to share folders then share with "Everyone" the link below shows you how. If none of the Library's are shared you will get that message. You need to check this on both machines.
Share libraries with your homegroup


Attached Thumbnails
Homegroup joined but no access...-homegroup-sharing-library-s.png  
My System SpecsSystem Spec
29 Jan 2010   #3

Windows 7 Professional x64
 
 

Thanks but that didn't do anything. PC1 (MEDIAPC-PC) Doesn't show up under homegroup on PC2 (SEVEN) but can be see under network. Please see the image below.

BTW. I have shared folders and libraries on both computers but they don't see each other even though both are joined to the same homegroup..

My System SpecsSystem Spec
.


29 Jan 2010   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Check the Advanced Sharing settings and make sure it looks like the picture below.
There are two windows that look the same Home or Work and Public. It should say "current profile" at the top of the Home or Work window. You may also need to reboot both machines for any recent network changes to take effect.

Can you access the Homegroup from one of the machines?

Are you using any type of A/V software or a third party firewall?


Attached Thumbnails
Homegroup joined but no access...-home-work-homegroup-enable.png   Homegroup joined but no access...-public-sharing-enabled-all.png  
My System SpecsSystem Spec
29 Jan 2010   #5

Windows 7 Professional x64
 
 

Settings are identical to yours.

Both computers report they are joined to the Homegroup but neither can see the other. The both list homegroup in the navigation pane once the homegroup is enabled. Homegroup is hosted by MEDIAPC. Both have the default directories shared as well as a couple of others. I've verifided that Homegroup is listed in their shares each time I change anything.

I've tried recreating the homegroup and restarting between each change.

MEDIAPC has no A/V and windows FW. SEVEN has Kaspersky but it is disabled while trying to get this to work.

Bizzare thing is that this was working few days ago.
My System SpecsSystem Spec
29 Jan 2010   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

Make sure that IPv6 is enabled. In services make sure that all the three peer networking services are started.

Yes it is strange that it worked before and not now.

Somtimes it helps to create the Homegroup on a different machine and join from the other but it sounds like you tried that. You may need to uninstall Kapersky also.

Try the link below which is a Homegroup trouble shooting walkthrough. The parts about switching between Public and Homegroup sharing can fix certain problems.
http://technet.microsoft.com/en-us/l...16(WS.10).aspx

Homegroup check list>http://www.computerperformance.co.uk..._homegroup.htm

Also try this because it fixed this same problem for someone else.
I had a similar problem. My 64-bit desktop wired into the network and my 32-bit laptop wirelessly connected, stopped recognising one another on the homegroup. Recreating the homegroup and rebooting didn't help.

Then, when I clicked "See full map" in the Network and Sharing Center, I discovered that even though I had set up my network as a Home network and it was displayed as such in the Network and Sharing Center, for some reason Windows 7 didn't "see" that. It wouldn't display the network map because it said I was on a Public network.

So, I changed my network to a Work network, then back to a Home network, and the homegroup started working again. I had deleted the homegroup on the laptop prior to making these changes, so I simply rejoined and everything's now working again.

So make sure you aren't mistakingly on a Public network because Homegroups won't work from there.


Attached Thumbnails
Homegroup joined but no access...-services-peer-networking-enabled-set-automatic.png  
Attached Images
 
My System SpecsSystem Spec
29 Jan 2010   #7

Windows 7 Professional x64
 
 

IPv6 is enabled on both machines. Peer services are running on both.

Home network is set to trusted under KIS. Cant understand why it would decide to block it now? I'll try an uninstall.
My System SpecsSystem Spec
29 Jan 2010   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

I'm very suspecious of Kapersky really, nothing but problems with A/V's lately and the only way to fix is to uninstall them it seems. Best to install the A/v's after you get the network set up and working.

Try this trouble shooting guide. Pay particular attention to the registry change further down the page. http://helpdeskgeek.com/windows-7/wi...-to-homegroup/
My System SpecsSystem Spec
29 Jan 2010   #9

Windows 7 Professional x64
 
 

We can rule out Kaspersky.

Complete removal, restarted both computers, left and removed homegroup, recreated and rejoined and still the same issue. I can join but cant access from either PC.
My System SpecsSystem Spec
30 Jan 2010   #10

Windows 7 Professional x64
 
 

OK. I've fixed this

I uninstalled the NIC from device manager, deleted files from
C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking and restarted PC2 (SEVEN). Then rejoined Homegroup and it's working again.
My System SpecsSystem Spec
Reply

 Homegroup joined but no access...




Thread Tools



Similar help and support threads for2: Homegroup joined but no access...
Thread Forum
Modified Excel registry, joined user to domain, now no admin access Network & Sharing
Domain joined pc, does domain admin have access to my homegroup Network & Sharing
One Way HOmegroup Access Network & Sharing
Homegroup and Domain Joined PC Network & Sharing
Can I access a HomeGroup through VPN? Network & Sharing
Homegroup access only one way Network & Sharing
No access to homegroup Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33