Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WG311 V2 issues

05 Feb 2010   #1

windows 7
WG311 V2 issues

I have had this card working fine in my PC with Vista installed Windows 7 and the card is reconised by the system in the device manager. However when ever I try to connect to my network by clicking the "connections are avalible icon" in the bottom right of the screen and selecting my network and clicking connect I get a message reading "windows was unable to connect to ....." However I have another PC running windows 7 that conects to the same network with no problems
I never get a chance to enter any info like the network key

Any help would be much appresated


My System SpecsSystem Spec

05 Feb 2010   #2

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit

Welcome to Seven Forums!

Most of these problems tend to be driver related. A good rule of thumb is to make sure the drivers for your wireless adapter are current. Also make sure your wireless router has the latest firmware.

What make and model router are you using?
My System SpecsSystem Spec
05 Feb 2010   #3

windows 7

Netgear WG311 V2

ANd where would I get them from??
My System SpecsSystem Spec

05 Feb 2010   #4

Windows 7 Ult, Windows 8.1 Pro,

Yes this same WG311 PCI adaptor came up a few days ago and would not work correctly with Windows 7. I posted a link to the old Vista drivers but they didn't work any better. It was a slow limited connection as I recall and it was not fixed. That adaptor was never tested to work properly with Windows 7 according to the compatiblity list.

I'd say your best bet it to get one that is known to work with Windows 7 because that one doesn't seem to work correctly for anyone. Maybe you will have better luck but not too hopeful.

Link to drivers.

Here is a link to that post. NETGEAR connection
My System SpecsSystem Spec

 WG311 V2 issues

Thread Tools

Similar help and support threads
Thread Forum
Recording issues with recorders (fraps hypercam etc) sound issues
Hey guys, ive lately been making lets play and walkthroughs on youtube and im having a couple of problems. With my headset, in the background while recording thats like a static noise and i cant seem to make it go away, ive tried multiple recording programs like fraps and hypercam but its still...
Win 7 Upgrade-MANY issues!! Search, screen flashing, Outlook issues..
I have recently upgraded from XP to Win 7 and I have encountered so my problems I've lost count... However, I work from home and I need to get these issues worked out NOW... So, I am DESPERATE for answers... 1. Main problem: I have done a full system index 273,852 files and 2 days later...
General Discussion
Removable Disk Issues - Work through issues
Hello Forum, I have two removable disks. One is write protected (D) - I want to know if you can alter that property. I have just put them into my laptop and discovered the presence of New Folder - with a zip folder in it and another folder called Found. Want to know how that got created. ...
Hardware & Devices
Netgear WG311 v3 won't run!
As you know, I have 7 Ultimate. I was recently given a NetGear WG311 V3 54/mbs Pci card. Can't seem to find out why it won't work. So many things wrong in my Os atm, but this for now. I tried the Marvell driver. Nope! Absolutely nothing in my Devices and Printers. I installed the Smart Wizard....
Hardware & Devices
Dhcp issues and network connectivity issues since windows 7 x64 sp1
I reformatted my computer because after installing service pack 1 and other updates from Feb 14th my computer has been having issues getting a dhcp from my router. I have a windows 7 home premium 32 bit laptop that works just fine. I also have a ubuntu machine that pulls an address from this...
Network & Sharing
Windows 7 Ultimate 32bit issues with desktop freezing/ other issues
Hi all, Going to try and make this brief, "try" being the operative word here.. I have a Gateway PC running Windows 7 Ultimate 32 bit 4 gigs of ram but obviously not all useable (yet) Dual core processor Nvidia 9800GT graphics Card Corsair 650 watt PSU HT Omega Striker 7.1 Souncard..
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:37.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App