Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 7057 x64 Broadcom wireless issues

30 Mar 2009   #1

Windows 7 x64 Home Premium, Professional and Ultimate, Ubuntu x64
7057 x64 Broadcom wireless issues

After my kid went to some less-than-savory websites, my PC at home was infested with a slew of viruses.

I figured it was time to install 7057 since I had such good luck with 7000 on my netbook.

I installed and everything appeared to be fine, but then, using the Microsoft provided Broadcom 802.11g wireless driver (just as it is labeled in Vista Ultimate, which works PERFECTLY), things started to act flakey with my internet connection.

It's a Belkin branded Broadcom card, but I have never had issues with it. After switching back to Vista it's working perfectly again.

I ran Windows updates, then started to surf the web a little to find some drivers and in the middle of doing nothing out of the ordinary, internet connectivity simply dropped.

It showed me still connected, but only for local access - no internet.

I rebooted - couldn't even connect to the wireless now.

I did a cold boot - connects but local only.

No other PC in the house was having any issues.

I've tried it using DHCP and a static IP - both of which worked on all other machines as well. No joy.

The router I am using is the first generation Belkin Pre-N, which for the past year has needed the occasional reboot, but didn't really have any serious issues.It is several years old.

As I said - no other machines had any problems. They are all running Vista Ultimate (a mix of x32 and x64), along with my netbook running x32 build 7000.

So, can I suspect that there is an issue with the Broadcom driver? Or maybe that the Router is too old to handle something that this new build is trying to do? Is anyone else having similar issues?

I'm going to be getting a new router, simply due to an electronics refresh that I am doing throughout the house, but, I don't want to have to futz with the desktop machine anymore on Win7 if I am going to continue having these issues.

Thanks in advance!

My System SpecsSystem Spec
05 Apr 2009   #2

Windows 7 x64 Home Premium, Professional and Ultimate, Ubuntu x64

After replacing the router with a new, modern 802.11n router, this problem is gone.
My System SpecsSystem Spec

 7057 x64 Broadcom wireless issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Acer 5750 (Broadcom wireless) dropping
Hello all, I've had this problem on and off for almost a year. My Acer 5750 laptop will randomly drop the connection to my router/modem. Often I will be browsing on Firefox or another browser when suddenly the page requested will crawl along and a "page cannot be displayed" will occur. Often...
Network & Sharing
Broadcom Bluetooth and Intel wireless 6205 conflict !!
Hi all I am using a Lenovo X1, 129126U for over a month now I am having problems connecting the a4tech bt310 bluetooth mouse to the machine, previously it used to be fine but then suddenly the bluetooth components dissappeared after several attempts and uninstalling and reinstalling drivers I...
Network & Sharing
Lenovo Broadcom wireless problems.
Hi there, Not sure if I've got the right forum so sorry if I've put it in the wrong place, but here goes: I'm running a brand new Lenovo B570 with Windows 7 Home Premium x64 and a Broadcom 802.11n wireless network adaptor. Earlier today I was managing to connect to the internet wirelessly,...
Hardware & Devices
7057 MCE issues...
since upgrading from 7048 to 7057 my MCE doesn't seem to retain information...when switching from one channel to another(mostly from regular to HD, have dual tuner) just locks up and I have to either re-boot and/or re-boot and redo tv signal setups OR remove and reinstall my cable capture...
Media Center
Interface issues in 7057
I just upgraded to 7057 and now seek bar in Media Player Classic is messed up. Reinstalling MPC and video drivers (I have nvidia geforce 7600GT) doesn't help. Only when I disable desktop composition it works normal. What...
General Discussion
Build 7057 MTU issues
i have been playing with windows 7 since i installed and found upload speed just terrible down load is good computer to computer is good but upload to net is max of 11 kbs i have an oem Ralink wireless card and its the same network for all i did a few tests and was told that MTU discovery was off...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:33.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App