Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No proper visibility on network

07 Feb 2010   #1
Algoz66

W7 64bit
 
 
No proper visibility on network

I have Belkin N1 vision and connected to it by ethernet a W7 (64bit) PC, and also connected by ethernet an XP (SP3) machine. I also have wireless connections for a W7 (64bit) laptop and an XP (SP3) laptop.
Problem has been from day 1:
W7 desktop (ethernet) only sees all other devices on network as media devices.
I have ensured the following:
All machines belong to same named workgroup.
W7 machine is set to work network (as opposed to homegroup)
File sharing is enabled on all machines.
No firewall software running on any of the machines.
Have tried disabling AV software - no help.

The W7 desktop is not visible at all on the network to any other machines. However, all 3 other machines DO see each other.

What is strange is that if I reboot the router then everything is fine - the W7 desktop sees the other devices as computers. However, when the W7 desktop has rebooted - back to square one, and it only sees media devices. Pinging works fine - machines see each other ok.

I'm now officially stumped. Anyone else had this?


My System SpecsSystem Spec
07 Feb 2010   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Have you tried to update the firmware on your Belkin router yet?

There is also a good chance that your anti virus or firewall is causing the problem, sometimes uninstalling them is the only way to fix it. Try uninstalling the A/V software on the Win 7 machine and see if it helps.
My System SpecsSystem Spec
07 Feb 2010   #3
Algoz66

W7 64bit
 
 

Quote   Quote: Originally Posted by chev65 View Post
Have you tried to update the firmware on your Belkin router yet?
I looked for updated firmware, but there is only BETA released - no approved firmware yet.
My System SpecsSystem Spec
08 Feb 2010   #4
Algoz66

W7 64bit
 
 

Well Chev65 - I uninstalled and reinstalled my AV, and now everything is fine! Thank you SO much for your help. This has been driving me mad for weeks now. I can't believe Bullguard make such crappy AV that could do this to my network.
My System SpecsSystem Spec
08 Feb 2010   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Yes I've seen these types of problems many times and there is usually an A/V involved somehow.

It's best to set up sharing and make sure it's all working then install the A/V to see if anything changes.
Often times when you reinstall the A/V it will pick up the network and allow for sharing automatically like Bullguard seems to have done which is good.

I'm glad you got have it working again Algoz66, I'll mark this as solved.
My System SpecsSystem Spec
Reply

 No proper visibility on network




Thread Tools





Similar help and support threads
Thread Forum
Cannot get computer to join proper home network
I recently had to re-install Win 7 Home Premium on my desktop computer. In the setup, it apparently chose to join "Network," which is not the name of the network it was on prior to the reinstall. My laptop is on that other network, which for this discussion I'll call "Something 4". I know I can...
Network & Sharing
restrict the visibility of certain folders
Hi Shawn, thanks for the quick and prompt reply. I have several user accounts and I want to restrict the visibility of certain folders to certain user accounts. How do I do that ? And I have only Home Basic. I don't want to other users to see certain folders that exist in my HDD.
General Discussion
Change tray icon visibility defaults
Hola, any chance to change how new/unknown applications' icons should be handled by notification area, if I have always show all icons and notifications on main panel turned OFF. Despite that explorer time from time crashes, user settings are forgotten and I always have to setup all applications...
Customization
A wireless mystery: No connection despite visibility
Can anyone help? I have a Belkin Wireless G USB Adapter (don't laugh!) connected to my desktop (running Windows 7). Until recently, it worked fine. However, it suddenly stopped working, apparently it can't see my router despite it being only 7 meters away. Strangely, it can see the neighbour's...
Network & Sharing
NAS Visibility Lost after XP mode/switch user
My home network runs a D-link 655 router with an XP box, Windows 7 Professional (HP 180t) box, HP MediaVault 2020 NAS, and a Synology 410 NAS physically attached. I am able to view all these components on my Windows 7 box in 'explorer - Network' on boot. If I open an XP mode window or switch...
Network & Sharing
Network visibility - and Windows Firewall
Hi all I've got an Asus P5W DH Deluxe mobo, which has dual Gigabit ethernet and 802.11g wireless onboard. I'm using the wireless for my Internet connection - which works fine. However, I also have a crossover cable plugged in to one of the ethernet cards, which I'm trying to connect to my...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App