Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Why my 100 mbits broadband slows down?

01 Apr 2009   #1

Windows 7
Why my 100 mbits broadband slows down?


Im very new in this forum, so let we get started. I have windows 7 7068 version, 32 bits. my coumpter is fujitsu siemens scaleo p, with 3 gb ram and double core, not quad core up til 5000+ amd turion. my videocard is an nvidia 8600gs (pretty lame card but it works). I had before windows vista when I get it couple years ago but it sucked, so I turn to xp. It worked, but it had so alot of problems. then I saw windows 7. I try it and I love it! Some error, but not so much.

Now comes a real problem: I have an modem who look like an router, but my isp said it is not a router, is only bridge modem with router fuctions. Then I have an Netgear WGR614v9 what is pretty low tech router. My problem is that everytime I put it on and I tcp tested on it, it slows down from orginal speed 100-92 mbits to 40 mitbs. I thought it was the wireless setting but it wasn't. then I thought it was with the nat firewall, but not. So Im lost with ideas. If u have any idea what this causing this problem and if u had the same problem, let me know then.

My System SpecsSystem Spec
31 May 2009   #2

xp vista win7

I run xp vista and win7. as of late win7 internet using any number of browser is slow. I switch to vista and speed is fine so I conclude win7 has an issue with internet connection.
My System SpecsSystem Spec
31 May 2009   #3

Mac OS X/Ubuntu/Windows 7

I too, am having a similar issue. My internet works fine when I am running Ubuntu (on the same computer as Win7) but right when I switch to Win7 my internet slows significantly. Sometimes it doesn't even load pages. I'm not sure what to try, I've tried optimizing my connection but that does nothing. I'm with garyP on this one, it may just be an issue with drivers or Win7 itself as of now.
My System SpecsSystem Spec

31 May 2009   #4

Windows 7 x64 RTM Retail

My speeds have actually improved about 10% since I played around with the TCP parameters

Open up a command box. Type in
'netsh int tcp show global' to see how yours are set.

My setting are:

TCP Global Parameters
Receive-Side Scaling State : enabled
Chimney Offload State : enabled
NetDMA State : enabled
Direct Cache Acess (DCA) : enabled
Receive Window Auto-Tuning Level : normal
Add-On Congestion Control Provider : ctcp
ECN Capability : enabled
RFC 1323 Timestamps : disabled
My System SpecsSystem Spec

 Why my 100 mbits broadband slows down?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Teracopy slows down?
Hi i am copying a file from a disc to my HD. I noticed that my teracopy become slower as i become frequently copying files from disc to my HD. Now i am copying a file and this is how slow it transfers. Is it really like this? Intel i5 2500k 1TB Windows 7 Home Premium ...
Java Add-on slows down IE8
I've discovered that disabling the "Java Plug-In 2 SSV Helper" Add-on makes my home page load in 1 second instead of 8. The CPU and memory usage are both considerably lower as well. Might be worth a look to see if you have it. Name: Java(tm) Plug-In 2 SSV Helper...
Browsers & Mail
CHKDSK Slows To A Crawl
Am running chkdsk on my C: drive (scheduled on boot) and it runs OK at about 3000 sectors per second then slows to a crawl - I left it running for 8 hours and it got to about 50% of the last step (4 of 5) but by that time was slo slow it would have taken hours more to finish. Any ideas ?
Performance & Maintenance
IDE Slows Windows 7 boot
Hi everyone. I installed Windows 7 Pro over a week ago now, changing from XP pro. From the first time i had installed and tried to run windows 7 it has taken over 10 minuites to load windows, it just seems to hang on the windows 7 logo. I started to notice more problems when trying to watch...
Hardware & Devices
Windows 7 Slows Down after Inactivity
Hello! I have installed the Windows 7 RTM and have a pretty annoying problem. Once I start up my computer, Windows 7 runs extremely well: everything works very fast and smoothly. However, if leave my computer on for a while (30 minutes or more), without doing anything, everything becomes pretty...
Performance & Maintenance
explorer.exe slows down
Hi there, I'm running x64 7264 (sorry if my specs say otherwise) right now, and I'm noticing that explorer.exe will slow down to unusable after a couple of days. If i kill the process and restart it, everything ends up working just fine, but until I do that, the taskbar is unusable, and there...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:22.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App