Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Thinkpad T60 ethernet connection not detected

18 Feb 2010   #1
creso

Windows 7
 
 
Thinkpad T60 ethernet connection not detected

Hello, recently I installed windows 7 on my Lenovo T60. First I thought the install went flawlessly because I was able to access the internet but later I realized that I was accessing the internet through wireless and my ethernet port was not detected. I installed the intel chipset driver but I can't install any ethernet drivers because the ethernet card is flat out not detected at all. I've searched all over Google and haven't found anything like this so I'm completely stumped.

Also theres only one driver in device manager that's unknown but I'm pretty sure its some sort of storage driver, its called Intel(R) ICH7M/U LPC Interface Controller - 27B9.

Any help would be greatly appreciated.


My System SpecsSystem Spec
.

18 Feb 2010   #2
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

First thing is to see if Lenovo supports W7 on the T60. If they do, the drivers should be available from Lenovo.

Did you run the W7 Upgrade advisor before you installed? It would have told you about any driver issues,

If not, things get more interesting. You may need use Vista drivers if no native W7 drivers are available from Lenovo.

http://www-307.ibm.com/pc/support/si...cid=MIGR-74108

Lenovo Support & downloads - List of Windows 7 Upgrade Capable Systems

http://www-307.ibm.com/pc/support/si...ocid=WIN7-TIPS
My System SpecsSystem Spec
18 Feb 2010   #3
aem

Windows 7 Ultimate 64Bit
 
 

I have the exact make and model of your T60. Have you tried letting W7 auto update the driver? Mine just connects to the internet and update the drivers automatically.
My System SpecsSystem Spec
.


18 Feb 2010   #4
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

Quote   Quote: Originally Posted by aem View Post
I have the exact make and model of your T60. Have you tried letting W7 auto update the driver? Mine just connects to the internet and update the drivers automatically.
Your appearance is most fortuitous.
My System SpecsSystem Spec
20 Feb 2010   #5
creso

Windows 7
 
 

Thanks for all the replies, the problem is that the device is not detected at all which means any drivers that I install don't detect the ethernet device either. In the bios the mac address of the ethernet was listed as not applicable so right now I'm thinking maybe the device went bad.
My System SpecsSystem Spec
20 Feb 2010   #6
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by creso View Post
Thanks for all the replies, the problem is that the device is not detected at all which means any drivers that I install don't detect the ethernet device either. In the bios the mac address of the ethernet was listed as not applicable so right now I'm thinking maybe the device went bad.
Can you post a screen shot device manager?

http://www.sevenforums.com/tutorials...en-forums.html
My System SpecsSystem Spec
08 Mar 2010   #7
creso

Windows 7
 
 

Sorry for the late reply, here's the screenshot. The unknown device is: Intel(R) ICH7M/U LPC Interface Controller - 27B9.


Attached Thumbnails
-devicemgr.png  
My System SpecsSystem Spec
12 Mar 2010   #8
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
12 Mar 2010   #9
bummpr

Windows 7 x86 and x64 - RTM
 
 

Have you "enabled" the device in the Network and Sharing Center?
My System SpecsSystem Spec
15 Feb 2011   #10
skmfisher

Windows 7 Pro 64-bit
 
 
Update BIOS First

I had this exact same issue when updating the Thinkpad T60 (2623-D6U) to Windows 7, 32-bit. I had to update the BIOS utility first (Lenovo Support - BIOS update utility - ThinkPad T60, T60p) then reboot, then go to the "unknown device" and simply run the Update Driver and this time it found and updated it. Turns out it was a Security Device -> Trusted Platform Module 1.2
My System SpecsSystem Spec
Reply

 Thinkpad T60 ethernet connection not detected




Thread Tools





Similar help and support threads
Thread Forum
Ethernet Lan Cable not detected
Ethernet Lan Cable not detected on my computer . last week it was working and now its not idk why . my friend told me to reset the bios setting so i removed the cmos and reseted the settings still not working and i also installed the latest driver for my 82579V Gigabit Network . Help pls i cant...
Network & Sharing
Ethernet Connection is Not being detected in Windows 7
I have faced a problem just a few hours ago for the first time that my Ethernet Connection is not being detected. I have a Lenovo essentials b570-e laptop, with a core i5 processor and 2 GB Ram. I have never before experianced this problem. I have already tried via another cable, connecting...
Network & Sharing
Ethernet cable not detected!!
Hey everyone, Since I'm on a campus, I'd like to download shit with a real nice speed, but the only problem is, when I connect my ehternet cable, it won't connect or something. If I go to the adapter settings, it says that the wireless network connection is fine, but the local area connection...
Network & Sharing
Ethernet cable not detected
One of my Windows 7 computer has been getting an error for 24 hours that the ethernet cable is not detected and it can not connect to the internet. Other Windows 7 computers on the same router/internet connection work fine. I have already tried the following all of which were not successful....
Network & Sharing
Ethernet not detected
Hello all! I know there have been some threads about this issue before, but I couldnt find a solution to my problem there: Until today I had Windows XP running on my new system, which consists of: Mainboard: Asus M4A87TD Athlon X2 Ram and other hardware. The network adapter is a onboard...
Network & Sharing
HELP! ethernet cable not being detected
Hi, I am using windows 7. i have upgraded from vista recently. My internet connection has been cutting out infrequently over the past month, but now it has cut out completely. windows is detecting the problem as a either a faulty ethernet cable or as a cable not being connected. I have tried; ...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App