Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Internet

01 Mar 2010   #1
MonthOLDpickle

64 W7 Pro
 
 
Slow Internet

I had the W7 Beta while at work up til last week. I was connected to a domain/server that uses it self as DCHP/DNS.

Now I install W7 64 bit Pro and use the same IP set up in the config..I connect perfectly. Than my internet is slower than it was in beta. Sometimes I get the page doesn't load, hit refresh it loads slowly but sometimes not the format - hit refresh again and it works.

Do I need to install an Ethernet driver from my laptop dell site or what?


My System SpecsSystem Spec
.
01 Mar 2010   #2
Jonathan_King

Windows 7 Professional x64
 
 

Welcome!

If Dell provides the driver, go ahead and install it.

If not, you can go to Device Manager, find your network adapter, and select Update driver software.
My System SpecsSystem Spec
01 Mar 2010   #3
MonthOLDpickle

64 W7 Pro
 
 

Yes I just tried that and there is no driver on dell website. Maybe its a setting somewhere.
My System SpecsSystem Spec
.

01 Mar 2010   #4
Jonathan_King

Windows 7 Professional x64
 
 

Go to Control Panel>Device Manager, right-click on your network adapter, and select "Update Driver Software".
My System SpecsSystem Spec
01 Mar 2010   #5
MonthOLDpickle

64 W7 Pro
 
 

I think I fixed it by changing the default IP the server addresses me. So far everything loads uber fast.

I did do the update but windows told me the current one was okay.
My System SpecsSystem Spec
01 Mar 2010   #6
Jonathan_King

Windows 7 Professional x64
 
 

Sounds like you figured it out. Thanks for posting!
My System SpecsSystem Spec
01 Mar 2010   #7
MonthOLDpickle

64 W7 Pro
 
 

Yea it was a random guess and try - worked out!

You helped me too lol...some how posting here helped.
My System SpecsSystem Spec
01 Mar 2010   #8
Jonathan_King

Windows 7 Professional x64
 
 

It's just our secret way of helping users without directly suggesting something.

Glad you figured it out. Be sure to let us know if you have any other problems.
My System SpecsSystem Spec
Reply

 Slow Internet




Thread Tools





Similar help and support threads
Thread Forum
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
Constantly slow and disconnecting from internet (no internet access)
Ok this has been happening for a few weeks now with the connection either being slow or just displaying a yellow triangle saying limited access and no internet access. Getting pretty desperate and running out of ideas now so need to ask here. Basically we switched ISPs after about a month of no...
Network & Sharing
slow internet log on
been having this problem for past few days. seems to take forever for me to get on internet. web pages don't want to load up took about 3 minutes for me to get this site to load up. My isp is aol and don't know why except been using it for years. aol welcome screen don't like to load up as with...
Network & Sharing
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
My internet is so slow
I think I have written about this a while ago, but cannot find it. My internet is so slow. I have Windows 7. That little round circle keeps going around and around. I ran malwarebytes and had over 700 problems and fixed them and now it seems slower. I went to msconfig and only checked 2...
Network & Sharing
Slow with Internet
I've recently installed 7 on my System and is working fine. Speed is OK. But the problem is with Internet. I've observed that as the connected time increases, my System gets slow. I have to reboot the System to get the normal speed. Is there a fix for this? I'm using AVG Free Edition.
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App