Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: TEW-423PI Not working

03 Mar 2010   #1
AlwaysAFK

Windows 7
 
 
TEW-423PI Not working

Today I made a little pit-stop by Fry's and picked up a TEW-423PI G wireless adapter for my desktop (I know it's not a good one, but it was 14 bucks and I'm broke). Followed the instructions: install drivers, install device etc. I'm getting nothing. Simply shows an "x" over the wireless connection symbol. When I try to run the diagnostic it reads "There might be a problem with the driver for the Wireless Network Connection 3 adapter." Device Manager is showing that both the driver and the device are working properly, but I'm not getting any sort of connection out of it.

I read through the forums, downloaded the windows 7 drivers, tried to use the older drivers etc. but to no avail, nothing's working. Any tips?

EDIT: The troubleshooter says "Windows couldn't automatically bind the IP protocol stack to the network adapter."


My System SpecsSystem Spec
.
03 Mar 2010   #2
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

Looks like you got one that may not be W7 compatible. Trendnet doesn't have W7 drivers and it's not on the Windows 7 Compatibility List.

You can try and completely remove the all the drivers. If you have a restore point from before you first installed, go back to it.

You said you had W7 drivers but I've not been able to find any. Are you sure they're W7 drivers and not Vista?
My System SpecsSystem Spec
04 Mar 2010   #3
AlwaysAFK

Windows 7
 
 

I downloaded the updated drivers from TRENDnet | Downloads | Wireless | TEW-423PI (Version C1.xR)which includes a windows 7 version installation, however the program failed as well. I went in and manually added the driver from the device manager, but it's still having the issue. Other forums have had people claim to have gotten it to work, however I can't quite find the solution.
My System SpecsSystem Spec
.

04 Mar 2010   #4
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

I see where they have W7 support in the driver. That's good.

Your best bet is to *completely* remove any and all drivers related to the adapter as best you can. I have the feeling you have a mixed bag of driver files in there.

If you have a restore point you can go back to, try it. You need to get to the point where you can do a *clean* install of the drivers.
My System SpecsSystem Spec
Reply

 TEW-423PI Not working




Thread Tools




Similar help and support threads
Thread Forum
Sound on Laptop and Desktop Randomly Stops Working and Working
So recently the sound on my desktop and my laptop has stopped working. For seemingly no reason. I really don't understand it. I first noticed it with my desktop. The sound just randomly stopped working. But not...entirely. It's really strange and complicated what's been happening, so bare with...
Sound & Audio
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
TrendNet TEW-423pi Windows 7 Driver Troubles
Hello all, I recently bought a new setup, and the network card of choice was the TEW-423pi C1.1R card from TrendNet. The first time I set it up with my PC, the driver installed wonderfully and I had no problems. But until recently, Windows 7 64bit must have updated the driver or something,...
Drivers
HDMI Sound randomly not working - test in settings gets it working?
I have started having an issue over the past week (config/drivers/etc not changed in months) where sound will randomly not be output by HDMI. System config/specs... Win7 SP1 all patches, nearly a stock install... only running WMC and XBMC. Only 3rd part stuff installed are SpeedFan an ATI...
Sound & Audio
Trendnet TEW-423PI Card
Has anyone had sucess getting this card to work with 7 ? Microsoft says it's compatible with download from Trendnet, I can't even get that to work, any suggestions please ?
Network & Sharing
Tew-423pi
Hi everyone, i have a Trendnet Wireless G card, TEW-423PI C1.0R Realtek chipset RTL8185L Has anyone had experience with this working in Win 7 x64?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App