Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Technet Plus Subscription


10 Apr 2009   #1

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 
Technet Plus Subscription

Is anyone here already a member? The reason I ask is that I was trying to join Technet Plus (I have a 20% discount coupon) and when I sign into my Windows Live ID the page goes into error mode saying that this page can't connect with WL or words to that effect.
I already have a "Guest" account with Technet linked, so I know the ID works with the site.
Anyone know if Windows Live is having issues at the moment?

My System SpecsSystem Spec
.

10 Apr 2009   #2

 

Technet plus is logging in fine here.
My System SpecsSystem Spec
10 Apr 2009   #3

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

I got as far as the "Buy" button. Click that and up comes the usual Windows Live sign-in box. It's then that it goes weird.
I reported a bug.

I suppose I could try resetting IE8 and starting over. It does the same in Firefox however, which makes me think that there's some sort of bug.

Maybe someone on high is telling me not to waste my money.
My System SpecsSystem Spec
.


10 Apr 2009   #4

 

I've known technet act like that and it usually sorts itself out after a few hours, it could be a regional thing.
My System SpecsSystem Spec
10 Apr 2009   #5

Windows 7 x86 Build 7077
 
 

Windows live did have an error earlier.

Live services hit with outage system wide

Update: All systems are back up and running Many users have been locked out of their accounts as problems with users inbox's seem to be inaccessible by any means. The problem appears to be system wide, as Microsoft reports on Twitter, stating "@MesaPink The issue will be resolved shortly sorry... Read on »
My System SpecsSystem Spec
10 Apr 2009   #6

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

..and here's me thinking it was my Al-Qaeda ID that was the problem....tee hee.
My System SpecsSystem Spec
10 Apr 2009   #7

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Well it certainly isn't fixed here. This is what I get.....


Attached Images
 
My System SpecsSystem Spec
10 Apr 2009   #8
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

No problem getting there for me .... Are you going here?

http://technet.microsoft.com/en-us/s...s/default.aspx
My System SpecsSystem Spec
10 Apr 2009   #9

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Yes I've tried both US and Canada as a country, now it wont even go as far as the live ID sign-in. I wonder if it's something this end...very weird.

I'll keep trying.
My System SpecsSystem Spec
10 Apr 2009   #10

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

By the way, did either of you go through the motions of buying or renewing a membership? It seems to be at that point, just before payment that it breaks down. I've tried now in Windows 7, Vista and XP, all with the same result.
My System SpecsSystem Spec
Reply

 Technet Plus Subscription




Thread Tools



Similar help and support threads for2: Technet Plus Subscription
Thread Forum
Solved Technet subscription Chillout Room
28% off TechNet Subscription Chillout Room
Help with Technet subscription General Discussion
Technet Subscription General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:05 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33