Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ICS crashing everytime

28 Mar 2010   #1

ICS crashing everytime


First of all, here's my setup:
I have a router, what is working perfectly, it shares the internet for 4 pc. One of thoose is my pc. My pc got 2 lan card, one which is integrated to the motherboard, and one 3-4~ years old realtek card. Im getting the inet via the integrated card, and I want to share it via the realtek card, so I can use inet on my laptop. It works fine for a completly random time. After from 5 to 120 minutes(both case happened), ICS crashes on my pc(in 99% of the cases, it crashes without a message, so I cant give it, the 2 times something popped up I was codeing, and both time entered it immediately, without even have time to read it...), so the sharing immediately stops. At this point I have to go to the Network and Sharing center, press on my card's properties which got the inet connection, stop the sharing, restart the sharing, and woala, everything works again... for a while... Getting a wifi router isnt really an option, since sometimes I have to share inet to a laptop without any wireless connection. Most of the times I need inet on both computer, and I cant access the other 3(already taken) slots at the router, because its quite far away from me, and I dont wanna bother anyone with this. Not to mention, I really want to fix this, if I can, it just bothers me too much. Any idea on what can I do? Or how can I trace the origin of the problem? Any help is appreciated!


edit: if i dont do anything after a crash, after a random time it gets "revived", so sharing starts again. Of course, ICS crashes after this as well.

My System SpecsSystem Spec
29 Mar 2010   #2


Anybody, any idea on what should I do? Or how can I get a detailed description of the error?
My System SpecsSystem Spec
30 Mar 2010   #3


I will bump it one more time, maybe this time someone will have an idea
My System SpecsSystem Spec

30 Mar 2010   #4

Windows 7

What do the event logs show at the time of the crash?
My System SpecsSystem Spec
30 Mar 2010   #5


Im not quitely sure about if this is the exact message from the point ICS crashing, but im in a hurry now, and I found only this entry connecting to ICS.

The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Internet Connection Sharing (ICS) service, but this action failed with the following error:
An instance of the service is already running.

- System

- Provider

[ Name] Service Control Manager

[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}

[ EventSourceName] Service Control Manager

- EventID 7032

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8080000000000000

- TimeCreated

[ SystemTime] 2010-03-28T22:07:41.401067500Z

EventRecordID 9518


- Execution

[ ProcessID] 532

[ ThreadID] 2456

Channel System

Computer deva

- EventData

param1 1

param2 Restart the service

param3 Internet Connection Sharing (ICS)

param4 %%1056

Hope this is the one I should looked for, and this helps. Thx for the help, hope we can solve it somehow
My System SpecsSystem Spec
03 Apr 2010   #6


It seems Ive managed to solve it. What I did was disabling IPv6, because whenever ICS crashed, there was an error message that IPv6 cant allocate memory or something like this, and at Services I made the 2 services that was constantly crashing to restart in ANY case. Now sharing is working for like 2~ hours without crash(Im monitoring with torrent), and even if it crashed(what I doubt), it is restarting immediately.
My System SpecsSystem Spec
03 Apr 2010   #7

Windows 7 Ult, Windows 8.1 Pro,

Your router probably isn't handling the IPv6 packets like it's supposed too, or it was made before IPv6 became standard on all routers. You won't be able to use Homegroups either if that is the case. In any event, if you want the problem to go away most likely a new router will fix it.
My System SpecsSystem Spec
03 Apr 2010   #8


Well the problem was the IPv6 thingie indeed. Any router isnt involved with this kind of share, because I tried to share via 2nd network card, which is a bit, like 3 years old. I guess it cant handle IPv6, thats why it was crashing. The problem is fixed in the end, ty for the replies.
My System SpecsSystem Spec

 ICS crashing everytime

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Bsod everytime
I can't find any solution, so i post here the .zip of my files!
BSOD Help and Support
BSOD 1E, 0D, different everytime
Hey, I have a laptop that i been working on for a while and after time it will randomly blue screen on us. The error code are different most of the time. The laptop has been reinstalled twice, but yet the blue screen come up, Some time it is while it doing windows updates, or just...
BSOD Help and Support
CPU Hike to 100% Everytime.
I am having Dell Vostro 1015. I am having 4GB RAM and 32-bit windows 7 installed on my laptop. My CPU hike to 100% though I don't use anything. I have just installed 2GB RAM 15 days ago and new HDD, So is it the reason for this? I am attaching my task manager's all services snapshot. Kindly help me...
Performance & Maintenance
Windows Explorer crashing, adobe plug in crashing.
Im running windows 7 ultimate 64 ... I dont know totally system specs. It's a custom rig that I purchased about 6 months ago. I dont think the specs matter anyway because I don't believe this is a hadware problem, but a windows problem. Ok, So about a month ago I was unlucky enough to pick up...
General Discussion
Muted everytime
I use MSN to talk to my friends. Everytime we connect, the microphone on my laptop are muted. i have to go to cp to unmute it. What is the error? how to fix it?
Sound & Audio
BSOD almost everytime
Sometimes its PAGE_FAULT_IN_NONPAGED_ERROR , not really sure how often. Sent to Asus service centre, which defragmented the disk (and I believe) reinstalled the OS, but this did not eradicate the problem. I think the problem lies with the hardware. Anyone can help? Is Windows 7 . . . - x86...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App