Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Poor Internet Speeds

16 Apr 2010   #1

windows 7 Ulitmate
Poor Internet Speeds

Hi Guys, I have Windows 7 Ultimate and a Dell Inspirion computer and 2 locations to work from. In my first location I have a cable modem and wireless router that I get 9.2Mb download speeds. When I move the laptop to my second location with an ADSL modem and linksys wireless router I get .5Mb download speeds.

Not to be too wordy - I thought I had an ISP issue so they upgraded my modem and their rep hooked his laptop to that modem directly and got 8.2Mb download speeds... .I was happy! Until I hooked my router back up and only saw .5Mb download. I contacted the router folks they did a firmware upgrade and recduced the MTU down to 1300 same issue - they said defective router.

Bought a new DLR 665 XtremeN router and same issue (using that now in my other location and still see over 9Mb download speeds there). Replaced cable between router and modem - same. Hooked my machine up directly to the new modem and had a few issues with RAPPPOE but got past those and once connected still only see .5Mb download speeds.

I am now at a loss. I grabbed some network traces with WireShark and they show lots of retrans packets ... I just recently read that this may be because that is how WireShark displays the data... don't know where else to turn. If anyone has any ideas I would certainly love to hear from you!

My System SpecsSystem Spec
16 Apr 2010   #2

W7, Xp Pro

When I move the laptop to my second location with an ADSL modem and linksys wireless router I get .5Mb download speeds.
Hi, is the ADSL through copper phone connection
My System SpecsSystem Spec
16 Apr 2010   #3
not so gray matter

W7 Ult. x64 | OS X

My best suggestion would be to order a new modem. If you are getting low speeds when connected just to the modem then there's either a problem with your computer or the modem. An easy way to test this would be to connect to a different internet source w/ your computer and see if you get better speeds. If you do, it's a problem with your modem. If not, then there's something wrong with your computer.

In that case:
Uninstall your ethernet drivers
Download the latest versions
Install them.
Test again.

You can also try taking a gander at they have many tools that will help you diagnose what's wrong w/ your connection.
My System SpecsSystem Spec

16 Apr 2010   #4

windows 7 Ulitmate

Hi Guys, thanks for the reply I will check out the site now. I will also visit a neighbour tomorrow to see how my machine performs with his modem / router configuration.
My System SpecsSystem Spec
22 Apr 2010   #5

windows 7 Ulitmate
Solved! It was an ISP issue

Hi Guys. Wanted to post a quick note to let you know that I did take the laptop to a neighbour who was using same ADSL and ISP. I brought my modem and laptop and tested there ...all was fine 9+ mb download. Thought my problem was phone cabling so called up ISP (phone and ISP are same) discussed all I had done and then he said hold on... Came back and said I just made a change I will call you back in 20 Mins.... about 45 mins later all was working at 10.15Mb throughput now.

I want to thank the folks that replied to me as those steps helped me to isolate the issue.
My System SpecsSystem Spec

 Poor Internet Speeds

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Long Ping time poor internet performance
I just upgraded from Vista 64bit to Windows 7 Ultimate 64 and I am suddenly experiencing periodic poor internet performance on both Mozilla and IE 8. Pages fail to load or they start to load and then just die. No other machines on my home network (running Win XP) on the same router and cable...
Network & Sharing
Very poor Internet connection/speed
I recently got a new Wireless card LB-Link BL-LW04-A2. I'm able to connect to my wifi and I get 4 bar connection yet my download speed is 1mb. If I put my laptop in exactly the same place that gets about 20-30 mb download speed. I have spoke to my ISP and they have said it's not a fault at...
Network & Sharing
sudden choppy video, poor Ethernet speeds, hard drive clatters a lot
All video is now stop motion, dropped frames. Gigabyte ethernet went from 67 to 33 mb/s hard drive just wont stop. I ran cc cleaner, windows update, reinstalled nvidia driver, malware bytes found several bad things. JRT.exe found nothing. Multiple reboots, rescans nothing working to fix....
General Discussion
Poor Internet connection over WiFi
Hi everyone, I'm having this problem with the WiFi (which I set up in 2011) at my grandfather's. I googled quite a bit for this problem and never found a solution. I've had the issues for quite some time, but as I usually only stayed there for a couple of days the last couple of times anyway, I...
Network & Sharing
Poor Internet speed Acer 5570 laptop
My wife's Acer Laptop is experiencing very slow Internet speeds with both Wired and Wireless connection. It is setup through a TP-link WR1043ND router to a Docsis3 router to a cable connection. I have tried wireless and wired using the supplied Nic's and have trie a USB Gigabit wired router and...
Network & Sharing
Internet Explorer 9 (IE9) Poor Performance at Start Due to Add-ons
More - Internet Explorer 9 (IE9) Poor Performance at Start Due to Add-ons - Softpedia

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:31.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App