Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow network startup on all adapters


22 Apr 2010   #1

Windows 7 Professional 64bit
 
 
Slow network startup on all adapters

Whenever I boot up or disable/enable a network adapter it takes 1-3 minutes before I actually connect. After waiting, I'll see the little round circle spinning in the system tray and then i'm able to connect.

While waiting for my adapter to work I noticed under tcp/ip settings that my gateway field is blank. If I put it in and go back, it's still blank. When the adapter finally connects it then shows up in the gateway field.

Tried uninstalling AV, different drivers for LAN and wireless and reloading OS. Nothing seems to work. Any suggestions?


My System SpecsSystem Spec
.

22 Apr 2010   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Welcome to the forum justinrodney,

What is the model number and version number of the router you are using now?
My System SpecsSystem Spec
22 Apr 2010   #3

Windows 7 Professional 64bit
 
 

I use my laptop for work so I'm connected to several different things. Primarly I'm on wireless (Linksys WRT54GL) and Ethernet to several cisco routers. No matter what I'm connected to, the results are always the same.

Thanks
My System SpecsSystem Spec
.


23 Apr 2010   #4

Windows 7 Professional 64bit
 
 

Forticlient VPN software was the problem. After uninstalling and reinstalling I still had the issue. I then installed latest version of Forticlient and uninstalled both wireless and wired card. Rebooted and everything works great.
My System SpecsSystem Spec
23 Apr 2010   #5

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by justinrodney View Post
Forticlient VPN software was the problem. After uninstalling and reinstalling I still had the issue. I then installed latest version of Forticlient and uninstalled both wireless and wired card. Rebooted and everything works great.
Third party software once again, I'm glad the latest version works for you.
My System SpecsSystem Spec
15 Nov 2010   #6

windows 7
 
 

The following is what happened to me and my experience: (This is the REAL answer)

I know this problem is old....but yes it happened to me today....so NO its not fixed....

It is NOT network related to connections and or hardware....at all.....so you dont have to disable IP6....reinstall drivers for NIC....or reinstall windows either...

It is NOT only related to vista or 7...as this is happening to me on xp

It IS related to services to starting up..... .NET framework in particular!

IF this is happening to you...upon startup and waiting for network icon to showup....go to run type: services.msc and look for a services with "STARTING" versus "STARTED" for me it was the stupid framework....I uninstalled it and network now shows up as it should (less than one second)

*someone please copy this and distribute it all over the internet to help others....Thank you
My System SpecsSystem Spec
31 Dec 2010   #7

Windows 7 x64 Home Premium
 
 

Great work! Thanks

This is exactly where I found my problem.
For me it was: Windows Image Acquisition (WIA)

I changed its start up from Automatic to Automatic (Delayed Start)
and the problem was solved.
My System SpecsSystem Spec
01 Jan 2013   #8

windows 7
 
 
[solved] WIA aquisition disabling - HP drivers

Same thing for me, disabling WIA worked after trying everything before that (i am an advanced user since 1985, i mean it haha) on Windows 7 X64 SP1.

There is an HP Deskjet F2280 machine installed here, WIA issues might rise due to that? edit: YES, read below. I have been trying to get the scanner to just scan (known problem in HP drivers that was not addressed for a long time and when they addressed it, it was not working again!!!!)

HP printer/scanner drivers are the worst thing in this planet: not properly working, disk/resources consuming bloatware.

Thanks for the solution. I hope the scanner can scan without WIA enabled...

edit: it is again freaking HP, read the solution here if you are unlucky or dumb enough to have an HP printer/scanner product:

http://www.realgeek.com/forums/solve...od-260644.html


ps. this post is old but i posted to refresh it and make this solution more available to others that may be concerned.
My System SpecsSystem Spec
08 Apr 2014   #9

Win7x64
 
 
HP CUE DeviceDiscovery Service

Hi,

Still this issue is valid, 2014. For me it was "HP CUE DeviceDiscovery Service".
Immediately after that service went from "Starting" to "Started" network connected.

I set to delayed start and my problem went away!

Thanks for the solution! I too had tried all kinds of network settings to no avail...
My System SpecsSystem Spec
01 Sep 2014   #10

Windows 7 x64
 
 
Offsite Online Backup

My problem with delay began after many years of almost immediate connection. This thread helped me solve my problem. In my case the culprit was Offsite Online Backup which I changed to Automatic (delayed) and the problem disappeared. Thanks.
My System SpecsSystem Spec
Reply

 Slow network startup on all adapters




Thread Tools



Similar help and support threads for2: Slow network startup on all adapters
Thread Forum
Network slow to initialize on startup, slow system Network & Sharing
Different network adapters Network & Sharing
Unidentified Network; No Network Access - Powerline Adapters Network & Sharing
How to fix slow startup according to network search Network & Sharing
Many Network Adapters Network & Sharing
Network Adapters gone after MS update Network & Sharing
Need network adapters Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33