Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: slow internet with RC

30 Apr 2009   #1

Windows 7
slow internet with RC

So here is my prob.

few days ago I downloaded RC from a tracker(md5 is OK) I installed it, activated with my serial number. The problem is the *VERY* slow internet. I have 2 laptops, on both I wireless internet, dynamic IPs. One has Windows 7 7000, the second I installed the RC and only the second has the problem with the slow internet and this was not before I installed RC. Everything else runs fine. I already checked with antivirus, registry cleaner so on but no better. Can You advice something? Maybe some internet diagnostic tools?

My System SpecsSystem Spec
30 Apr 2009   #2

Windows 7077

may be its downloading updates in background
My System SpecsSystem Spec
30 Apr 2009   #3

Windows 7 Home Premium x64 SP1

Quote   Quote: Originally Posted by gulshan View Post
may be its downloading updates in background
Nah. Windows Update is programmed to download at a speed that does not interfere with usual Internet downloading and browsing. Also, I'm not sure that W7 RC has updates up-to-date.

For myself, I think it's driver related. Try to install the drivers from the manufacturer's website (Vista's drivers) instead of Microsoft's drivers. It can solves many many things.
My System SpecsSystem Spec

26 Jun 2009   #4

Same problem

I´ve had the same problem...
The last weekend I installed the W7 and I did all necessary updates. But my Internet is extremelly slow...
I was used to do downloads with transfer rate of 100 kpbs and now my transfer rate gets 5 kpbs on average... reaching a maximum of 10 kpbs...

All my drivers are up-to-date...

Has anybody any idea about what´s happening?

My System SpecsSystem Spec

 slow internet with RC

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
Constantly slow and disconnecting from internet (no internet access)
Ok this has been happening for a few weeks now with the connection either being slow or just displaying a yellow triangle saying limited access and no internet access. Getting pretty desperate and running out of ideas now so need to ask here. Basically we switched ISPs after about a month of no...
Network & Sharing
slow internet log on
been having this problem for past few days. seems to take forever for me to get on internet. web pages don't want to load up took about 3 minutes for me to get this site to load up. My isp is aol and don't know why except been using it for years. aol welcome screen don't like to load up as with...
Network & Sharing
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
My internet is so slow
I think I have written about this a while ago, but cannot find it. My internet is so slow. I have Windows 7. That little round circle keeps going around and around. I ran malwarebytes and had over 700 problems and fixed them and now it seems slower. I went to msconfig and only checked 2...
Network & Sharing
Slow with Internet
I've recently installed 7 on my System and is working fine. Speed is OK. But the problem is with Internet. I've observed that as the connected time increases, my System gets slow. I have to reboot the System to get the normal speed. Is there a fix for this? I'm using AVG Free Edition.
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:47.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App