Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: D-Link DWA-552 Problems

04 May 2010   #1

Windows 7 Ultimate 64bit
 
 
D-Link DWA-552 Problems

I have a d-link x-treme router and internal pci card. It worked great for about a year and today it can't find any networks. I tried disabling all the other network adapters like the Ethernet and Bluetooth, but that didn't work this time like it did with vista. I have also tried having windows repair it and it couldn't. I disabled and enabled my adapter, no good. I know it's not the router because I'm using my iPod touch to type this message. My Mom isn't having any problems with her laptop connection either. I looked into it and have found that I'm not the only one who has been having problems, but so far, no one is sharing the solution. All I have heard is that is has something to do with the driver. However I haven't updated anything and it has been working fine for two months. Any help would be great. Thanks in advanced! -Kevin


My System SpecsSystem Spec
.

04 May 2010   #2

Windows 7 Ultimate 64-bit
 
 

When you say it cannot find any networks, does it physically say "No Networks Available" or is the message different?

Thanks
My System SpecsSystem Spec
04 May 2010   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

I found this procedure from another site. It should fix the problems you are seeing with your D-link DWA552 adaptor.

FIXED: Solution follows.

1. download newest drivers for windows 7 here: Latest Atheros WLAN drivers for Windows 7 and Vista (x86 & x64) - LaptopVideo2Go Forums

2. Go to the control panel and uninstall any dlink install.

3. Go to the control panel -> hardware and sound -> Device Manager and click on "network adapters" then find if any wireless adapter is installed; if so uninstall it. Now right click in the device manager window and select "scan for new hardware". A new device should be found by windows. If it is UNABLE to install a device, then you may proceed to reboot your pc, otherwise continue to uninstall AND check the delete driver also button and looking for new hardware until windows CANNOT install the found hardware.

4. After rebooting your pc, extract the new drivers to a folder, then go to device manager again and select the found network device. Right click it and selct update driver. Chose to install from pc, and select the folder with the driver in it and let it install.

5. After the install reboot your pc.

If it still does not connect properly do the following.

go to your router set up and select the following settings in the wireless connection settings.

- security:WPA-Personal
- encryption type: WPA or WPA2 automatic
- Wireless mode: b,g or n automatic (just n should be ok as well)
- frequency: 20/40hz automatic

- in your adapter's settings, enable wireless-n adhoc

This should fix the issue with intermittent drops, not being able to find the network etc. It seems that in Win 7 the new drivers do not work very well with wireless g on this card as testing showed the same issues when switching from n, or mixed to just g.
My System SpecsSystem Spec
.


04 May 2010   #4

Windows 7 Ultimate 64bit
 
 

Yes it said "no networks available" and it had a red x over the signal bar. However the driver provided from Chev65 worked for me. Thank you very much!
My System SpecsSystem Spec
04 May 2010   #5

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by kev0 View Post
Yes it said "no networks available" and it had a red x over the signal bar. However the driver provided from Chev65 worked for me. Thank you very much!
Well what do you know, something I posted here actually worked!

Thanks for reporting back in Kev0.
My System SpecsSystem Spec
05 May 2010   #6

Windows 7 Ultimate 64bit
 
 

No thank you chev65! I sent you a rep for your help!
My System SpecsSystem Spec
06 May 2010   #7

Windows 7 Professional 64-bit
 
 

Hey I just tried your suggestion chev65, unfortunately it didn't fix the problem for me.. To go into the details, I'm running this on windows 7 Professional 64bit, I tried using the latest driver (v9.0.0.173).

This has been bothering me for a long enough time! It won't connect at all, or even register any existing networks.

Hovering over the wireless connection symbol on the start menu I see "Not connected - No connections are available", all while I sit beside my desktop with my laptop happily connected to the web.

So Kev0, what was your situation was before this fixed it, and also what was the driver you chose?

Thanks in advance! Larry
My System SpecsSystem Spec
23 May 2010   #8

Windows 7 Ultimate 64bit
 
 

It worked for me until today .. Now I'm having the same problem and back to using
my itouch .. I'm gonna try to do this again and report back if
I figure it out.
My System SpecsSystem Spec
25 May 2010   #9

Windows 7 Ultimate 64bit
 
 

Windows must be updating this driver because I uninstalled it and reinstalled it using the provided driver above and it works once again. However it still does not work every time. I am now dual booting Windows 7 and Windows Vista because Vista never has this problem and a computer without internet is worthless. I might just have to buy a new card that is compatible with windows 7 64bit and my router. Any suggestions?

Oh and as for larryp. I chose the atheros_v9.0.0.173 driver and used the setup it provided. For warning, this is a reoccurring problem, so keep this driver handy, you will need it again.
My System SpecsSystem Spec
16 Nov 2010   #10

Windows 7 Premium 64 bit
 
 
D-link DWA-552 Adapter

I have been having the same issue in regards to the D-link DWA-522 adapter. I do not believe that updating to the latest driver in this case is the answer. I have been downloading the latest drivers as normal and then I landed up with my wireless adapter crashing. I would have to reboot to get it to work again as nothing else would work.

I have an older driver dated 11/05/2009 1.60 that works with Windows 7 os. I have applied this driver and I also hope will fix the problem. Time will tell. If anyone has the same problem and wants to try out this driver let me know and I will provide it to them.
My System SpecsSystem Spec
Reply

 D-Link DWA-552 Problems




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33