Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: No network or internet connection after upgrade

07 May 2010   #1

Win 7
 
 
No network or internet connection after upgrade

Hi, I have just installed windows 7 upgrade, since the install I have had no internet or network access. I have tried installing new drivers but still not working. The connection to the router is showing excellent, unidentified network & no internet access. I have also tried bypassing the router and going straight to the modem with the cable and get the same results.

My System SpecsSystem Spec
.

07 May 2010   #2

Windows 7 Home Premium 64-bit (6.1, Build 7601)
 
 

Have you reset the router?

Also you may want to post the details of the router and modem and such
My System SpecsSystem Spec
07 May 2010   #3

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by stuham33 View Post
Hi, I have just installed windows 7 upgrade, since the install I have had no internet or network access. I have tried installing new drivers but still not working. The connection to the router is showing excellent, unidentified network & no internet access. I have also tried bypassing the router and going straight to the modem with the cable and get the same results.

We could use some info about your network and PC.

Upgrade from?? vista? XP?

Encrypted or not?

Firewall anti virus? etc

Ken
My System SpecsSystem Spec
.


07 May 2010   #4

 
 

Quote   Quote: Originally Posted by stuham33 View Post
Hi, I have just installed windows 7 upgrade, since the install I have had no internet or network access. I have tried installing new drivers but still not working. The connection to the router is showing excellent, unidentified network & no internet access. I have also tried bypassing the router and going straight to the modem with the cable and get the same results.
Hello stuham33, and welcome to Windows Seven Forums!

There are several things that might be the cause of your issue. Things like Anti-virus, firewall, and browser pop-up blockers sometimes get in the way.

Do you have your "Network Location" set as "Home Network?"

Name:  change_network_location.png
Views: 11
Size:  78.2 KB

You also have some built-in diagnostics for networking that might help you find the problem:



Please let us know what you find out?

Cheers!
Robert


My System SpecsSystem Spec
07 May 2010   #5

Win 7
 
 

Sorry, yes I have reset the router. My computer is acer 5735 with atheros AR5B91 adapter, and the router is a linksys WRT160n V2.
My System SpecsSystem Spec
07 May 2010   #6

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

This upgrade problem comes up pretty often. For some reason when people upgrade to Windows 7 from Vista the winsock gets messed up and needs to be reset. To fix that problem follow the simple procedure below.

1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue.


2. Type netsh winsock reset at the command prompt, and then press ENTER.

Note If the command is typed incorrectly, you will receive an error message. Type the command again. When the command is completed successfully, a confirmation appears, followed by a new command prompt. Then, go to step 3.


3. Type exit, and then press ENTER. You should be prompted to reboot, if not you should reboot and test.

After resetting Winsock if you still have the unidentified network problem try the procedure in the link below which should take care of that problem. You should be able to get online again after performing these procedures.

Windows 7 Unidentified Network, Limited Access, No Internet Connection Problem Resolved
My System SpecsSystem Spec
07 May 2010   #7

Win 7
 
 

Sorry again, I upgraded from vista to win 7. I attempted to set the network to home but it says it is an unidentified network. I have disabled the firewall and uninstalled the anti virus.
My System SpecsSystem Spec
07 May 2010   #8

Win 7
 
 

Quote   Quote: Originally Posted by chev65 View Post
This upgrade problem comes up pretty often. For some reason when people upgrade to Windows 7 from Vista the winsock gets messed up and needs to be reset. To fix that problem follow the simple procedure below.

1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue.


2. Type netsh winsock reset at the command prompt, and then press ENTER.

Note If the command is typed incorrectly, you will receive an error message. Type the command again. When the command is completed successfully, a confirmation appears, followed by a new command prompt. Then, go to step 3.


3. Type exit, and then press ENTER. You should be prompted to reboot, if not you should reboot and test.

After resetting Winsock if you still have the unidentified network problem try the procedure in the link below which should take care of that problem. You should be able to get online again after performing these procedures.

Windows 7 Unidentified Network, Limited Access, No Internet Connection Problem Resolved
That worked Thanks. I have now connected to the network, and it shows I am connected to the internet but it won't let me show any web pages.
My System SpecsSystem Spec
07 May 2010   #9

 
 

Quote   Quote: Originally Posted by stuham33 View Post
That worked Thanks. I have now connected to the network, and it shows I am connected to the internet but it won't let me show any web pages.
Now try resetting your router and Internet modem again. Shutdown computer, router and modem, then start modem and let it fully boot up, then router and let it fully boot up, then computer and check Internet again.

You can still run your Network "Diagnostics", and check to see that your "Network Location" is now set to "Home Network".

Cheers!
Robert
My System SpecsSystem Spec
07 May 2010   #10

Win 7
 
 

Thanks for all the help again. I now can connect to my home network and it shows I am connected to the Internet. However when I try to open the browser both firefox and IE it won't connect, on firefox it says server not found and on IE it says it cannot display the page. I have reset the router, modem and rebooted.
My System SpecsSystem Spec
Reply

 No network or internet connection after upgrade





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:13 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33