Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MSI US54SE2(ralink rt73) & Windows 7 issue

12 May 2010   #1
troublecro

Win 7
 
 
MSI US54SE2(ralink rt73) & Windows 7 issue

Here's the situation. When I booted WIN7 I found that adapter installed and working fine. Today,I had my "re-assemble & clean" routine with hardware. I jacked-up all the backside connections back in and with them,my MSI US54SE II with Ralink TR73 chipset(RT2500). It reported that the driver was successfully installed BUT since then it won't find any network connections. I tried troubleshoot and it gave this,splendid screenshot

Click

Anybody with any kind of solution except re-installing system and never removing USB dongle form the USB port? I tried Ralink Vista drivers,no go. I even found in win update rt73 updated driver(what a coincidence uh?) but nothing. I must mention that on the XP system,all works like a charm.


My System SpecsSystem Spec
.
12 May 2010   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Have you tried going into Device Manager and rolling the driver back? After that try typing into a command prompt ipconfig /all to get the connection working again.
My System SpecsSystem Spec
12 May 2010   #3
troublecro

Win 7
 
 

sorry m8,that option is blanked...can't do!
My System SpecsSystem Spec
.

Reply

 MSI US54SE2(ralink rt73) & Windows 7 issue




Thread Tools




Similar help and support threads
Thread Forum
Ralink Wireless card
Hey Guys I have a problem with my Ralink wireless card. windows "says" its fine but it doesn't enable (on windows 7) It might be a driver problem i'm not sure... I have the latest driver for it too its a Ralink RT61 Turbo Wireless Card chipset is 2561/RT61 if you know of any drivers...
Hardware & Devices
Ralink?
This is my first time I'm on my hp laptop that was setup a long time ago so I can't remember the startup but it was really slow so I went to uninstall a lot of programs witch sped it up but I uninstalled one of the ralink things so after some struggle of not being connected to the internet I fixed...
Drivers
Ralink RT61 WiFi Lan card, windows 7 not receiving any wifi signals
Hello, I have recently bought a new pci wifi lan card (Ralink rt61 turbo) and have plugged in and installed drivers. Initially the drivers the company I bought it from told me to install didn't work, but after some googling found the correct drivers and downloaded from Ralinks website. However...
Hardware & Devices
RT73 USB Wireless LAN Card will not enable.
Have been trying to install a high gain USB wireless long range wireless network adapter to my laptop. Initially tried a Alfa AWUS036h, software installed ok, but it never detected any networks and in Network Connections it was showing disabled. Any attempt to enable started well, showed enabling...
Network & Sharing
Latest RT73 (RT2500) USB driver?
Im using windows 7 default, version 4.0.0.15 from Microsoft but I have some issues with my wifi (Edimax 7318usg). Have you got any new driver? Thanks!
Drivers
PCI Wireless Driver - Ralink
Hello there! :) I'm having an issue with installing the driver for my Ralink Turbo Wireless PCI Card. I'm dual booting Windows 7 Ultimate (64-bit) on a seperated partition from Windows XP Professional. The card appears in Device Manager as an unknown network device located on PCI slot 1,...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App