Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ethernet=No Internet But Wireless Works Fine

21 May 2010   #1
conduktar44

Windows 7 Ultimate 64bit
 
 
Ethernet=No Internet But Wireless Works Fine

I'm sure this has been asked 1000 times but I cannot seem to find my exact issue anywhere. Hopefully this helps myself and anyone who runs into this issue.

To start, I have Windows 7 Professional 64bit. Everything worked 100% fine with absolutly no issue and then.... I moved. Now we have Fios instead of Comcast.

Now to the issue. When I have the ethernet connected I cannot get internet access but I have full network access. I went out and purchased a new wirless card and wirless works just fine. I tested 2 different cables, recrimped both of them and nothing. I have activity on the PC and the Router so I am sure they are good.

I have tried everything I have read online, Updated Realtek Family PCI Ethernet drivers from MSIglobal. Disabled/Enabled. ipconfig /flushdns, /release and /renew. I went as far as Backing up and reformating the Hard Drive and before reinstalling the backup I tested it and nothing. Restored my backup file and yep.. nothing.

Its kind of frustrating. I'm not exactly and expert but i am in no way a novice either. This one has me stumped. Im thinking maybe it is a windows service that is not set to start correctly but I figured I would creat a post while I am at work and maybe have and answer to test before I hunt through the services tonight.

Any advice is greatly appreciated

Thanks


My System SpecsSystem Spec
21 May 2010   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

This sounds more like a router problem to me. Have you tried resetting your router then using the ipconfig /all command?
My System SpecsSystem Spec
21 May 2010   #3
mpcrsc562

Windows 7 Ultimate x64
 
 

You have Fios now, but had Comcast in the past? Did you get a new modem/router combo with Fios? What I would suggest to do is to make sure that the MAC address being shown in the router settings for the PC that is hard-wired is your PC's MAC address instedad of the router's MAC address. There should be a setting which would allow you to clone the MAC address for your PC to the router.

I suggest this first as I just had this problem two days ago after switching routers (but I don't use Fios). I couldn't connect although every setting was as it was in the previous router. After cloning my PC's MAC address into the new router, I was able to connect.
My System SpecsSystem Spec
Reply

 Ethernet=No Internet But Wireless Works Fine




Thread Tools



Similar help and support threads for2: Ethernet=No Internet But Wireless Works Fine
Thread Forum
Solved Laptop refuses to detect anything wireless, ethernet works fine Network & Sharing
Internet works fine but I can"t have wireless Network & Sharing
Solved Here is a new one wireless works fine will lan wont connect Network & Sharing
Unable to connect to modem/internet via lan but wireless works fine Network & Sharing
No internet access with ethernet, but wireless works Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:15.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App