Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Local area connection doesn't have a valid ip config error craziness

01 Jun 2010   #1

Windows 7 64bit
 
 
Local area connection doesn't have a valid ip config error craziness

Hello all and ahead of time thanks for your help. I've searched google for around 10 hours for solutions and have tried to apply them. Ok first off my network card does say it's working properly when i go to device manager. This just suddenly happened when i woke up one day after turning off my computer. It is always saying "identifying" when i look at the connection in the network settings.

I live in Korea and i am plugged directly into this wall socket in my apartment so i really don't have a router. Not sure what one would call that. Anyways, my IP address is starting with 169 and im not sure if it's suppose to start with that. I have everything set to "obtain an IP address automatically" but when i did an IPconfig it showed the 169 address. i heard it isn't suppose to be like that on various forums.
i am running windows 7 64bit and the things i have tried and have failed are:

disabling IPV6
tried to do a ipconfig /release but it failed after giving me the error "error occured while releasing interface LAN an address has not yet been associsated with the network endpoint.

have tried reenabling and disabling the network card about 50 times
tried uninstalling and reinstalling the drivers from the CD and also from just restarting windows 7.

i tried doing the "netsh int ip reset reset.log" in the CMD and this told me something along the lines Two things are OK and it said restart for it to take effect. I did restart but of course nothing worked.

I tried disabling the bonjour service in the services.msc that some people had tried on this site and other sites and that also didn't work.

If anyone can help me through this... i would greatly appreciate it. Having no internet at home just sucks, i have access at work only now and at internet cafes. Any suggestions would be greatly appreciated and thanks for your help in the meantime!

Thanks,
Justin


My System SpecsSystem Spec
.

01 Jun 2010   #2
aem

Windows 7 Ultimate 64Bit
 
 

If you plug into a wall socket, that means you are not in control of the network you are connecting to. The 169 number you see is a private IP address your machine gives itself when it cannot obtain no other IPs.

What can you tell us about the network connection from the wall socket? Have you tried another machine? Is there a way you can test the building network from next door apartment (ie asking people if they have any issues).
My System SpecsSystem Spec
01 Jun 2010   #3

Windows 7 64bit
 
 

i'll let you know later if it is just my computer or not. Thanks for the quick reply man. I am at a pc cafe now printing out every solution i can think see that i haven't already tried. My friend is bringing over his laptop tonight so i will see if it's just my computer or the connection itself.
My System SpecsSystem Spec
.


01 Jun 2010   #4
aem

Windows 7 Ultimate 64Bit
 
 

Usually a problem like this could have a simple fix if you take a systematic approach to try and find out where the problem lies. Hope your friend can connect, cos then the issue would be on your machine
My System SpecsSystem Spec
01 Jun 2010   #5

Windows 7 Ult, Windows 8.1 Pro,
 
 

First you should uninstall the Bonjour sevice and all files associated with it because all too often disabling the service isn't enough to fix the problem. You might want to uninstall which ever A/V software you have installed for the time being.

After you do that follow the link below to fix the IP valid problem.
You can also enable IPv6 because it never seems to be the source of these types of problems.

http://www.sevenforums.com/network-s...tml#post745376
My System SpecsSystem Spec
07 Mar 2011   #6

XP SP2
 
 

Hi guys!

I have had the same problem for a few days now, and have searched numerous forums and gone through hell and high water to fix it. nothing helped until I found the ultimate solution that will help everyone:

CALL YOUR ISP, TELL THEM WHAT HAPPENED AND THEY CAN CONFIGURE A NEW IP ADDRESS FOR YOUR CONNECTION. IT ONLY TAKES ABOUT HALF AN HOUR.

During this time you must keep your router/modem turned off, and after the ISP has fixed the problem (in my case it took half an hour) you must restart your machine with the router/modem on and connected. From then on it should be like nothing ever happened.

Just for the fun of it, here's a list of things I have tried without results:

release/renew ipconfig
restarting modem/router and computer about a zillion times
changing LAN card
creating a static IP
resetting winsock in command prompt
reinstalling Windows 7
reinstalling XP (I had a dual boot and I did both, losing all installations)
manually entering IP address
disabling/enabling local area connection
plugging and unplugging LAN cable
uninstalling and reinstalling LAN card driver
resetting modem/router using the reset button

And after all this, all it took was just a phone call.
This is because your ISP is THE ONLY authority when it comes to configuring your IP address. In this case, it can only be done from the outside. This is also the reason why Microsoft didn't announce any patches or fixes for this problem, because it is not their problem and responsibility.

Only one question remains, WHY is this happening? Noone has been able to answer this, and I have read tons of forum posts about it. Maybe even the guys that made Windows 7 don't know it.

I am going to copy this post on several other forums because I have seen the trouble that people are having with this problem.

If you find out why this is happening, please post it here.
My System SpecsSystem Spec
Reply

 Local area connection doesn't have a valid ip config error craziness




Thread Tools



Similar help and support threads for2: Local area connection doesn't have a valid ip config error craziness
Thread Forum
""Local Area Connection" Doesn't have a valid ip config " Network & Sharing
WHYY!!! local area connection doesn't have a valid Network & Sharing
""Local Area Connection" Doesn't have a valid ip config Network & Sharing
Local Area Connection doesn't have valid ip configuration Network & Sharing
Local Area Connection doesn't have a valid IP Network & Sharing
"Local Area Connection" doesn't have a valid IP config Network & Sharing
Local Area Connection doesn't have a valid IP config Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:39 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33