Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet speed drops, win 7

01 Jun 2010   #1
Mizzhell

Windows 7 ultimate x64
 
 
Internet speed drops, win 7

I'm now on vacation at my mum, internet connection: 10Mbit/10Mbit, for a couple of months and therefore I have my desktop computer with me. After a couple of minutes downloading at 1,1 MB/s the speed drops below 100 kB/s, and won't return to normal speed until I restart the computer and the same thing happens again. I didn't have this problem at my house, internet connection: 5Mbit/1Mbit, it occurred when I got here. I have also reinstalled windows 7, but no change.
I'm connected to a router, Linksys WRT54GL running DD-WRT v24-sp2, with a Siemens Gigaset usb stick 54. I have restarted, and cleared the router, but no change.
My brother's laptop running vista is fine, full download speed all the way, and on his desktop computer with win 7, full speed there also.

So my download speed drops to 10%, and upload to about 50& after some time.
Any suggestions??


My System SpecsSystem Spec
.

01 Jun 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Mizzhell View Post
I'm now on vacation at my mum, internet connection: 10Mbit/10Mbit, for a couple of months and therefore I have my desktop computer with me. After a couple of minutes downloading at 1,1 MB/s the speed drops below 100 kB/s, and won't return to normal speed until I restart the computer and the same thing happens again. I didn't have this problem at my house, internet connection: 5Mbit/1Mbit, it occurred when I got here. I have also reinstalled windows 7, but no change.
I'm connected to a router, Linksys WRT54GL running DD-WRT v24-sp2, with a Siemens Gigaset usb stick 54. I have restarted, and cleared the router, but no change.
My brother's laptop running vista is fine, full download speed all the way, and on his desktop computer with win 7, full speed there also.

So my download speed drops to 10%, and upload to about 50& after some time.
Any suggestions??

I will bet you are running "homegroup". It has connectivity issues on some mixed systems. You can verify it is the problem by setting up a new network connection using workgroup instead. If it fixes the problem you can disable IPv6 and kill homegroup.

Let us know if you need help with this

Ken
My System SpecsSystem Spec
01 Jun 2010   #3
Mizzhell

Windows 7 ultimate x64
 
 

If removing the homegroup are done by control panel > homegroup > leave homegroup, and disabling IPv6 is done by unchecking the IPv6-box in properties for the nic, then it's done, and it didn't work.

when watching perfmon, it looked like this right before and when the speed had dropped:
Right before

Just when it had dropped


Uploaded with ImageShack.us
My System SpecsSystem Spec
.


01 Jun 2010   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

In the past this problem has been one of three things.

Either your router settings need adjusting but it's difficult to say which settings are causing this or your A/V software or a third party networking software is causing the problem so uninstalling them and checking to see if anything changes might be worth while.

This can also be a problem with your network drivers.
My System SpecsSystem Spec
01 Jun 2010   #5
kucing13

 

don't know if it's related but you could have a look

Download speed cut in half
My System SpecsSystem Spec
01 Jun 2010   #6
Mizzhell

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by kucing13 View Post
don't know if it's related but you could have a look

Download speed cut in half
Seems like the same problem, but I don't have the Bandwidth controller-thing
My System SpecsSystem Spec
01 Jun 2010   #7
Mizzhell

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by chev65 View Post
In the past this problem has been one of three things.

Either your router settings need adjusting but it's difficult to say which settings are causing this or your A/V software or a third party networking software is causing the problem so uninstalling them and checking to see if anything changes might be worth while.

This can also be a problem with your network drivers.
Have uninstalled avira antivirus and the software which came with the usb stick, but no difference..
I'm using the same drivers as before, can't find others and it worked for 2 years on win 7, until I came here.
My System SpecsSystem Spec
01 Jun 2010   #8
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Mizzhell View Post
Quote   Quote: Originally Posted by chev65 View Post
In the past this problem has been one of three things.

Either your router settings need adjusting but it's difficult to say which settings are causing this or your A/V software or a third party networking software is causing the problem so uninstalling them and checking to see if anything changes might be worth while.

This can also be a problem with your network drivers.
Have uninstalled avira antivirus and the software which came with the usb stick, but no difference..
I'm using the same drivers as before, can't find others and it worked for 2 years on win 7, until I came here.
Windows 7 hasn't been out for two years.
Have you tried using different router settings or rebooting your machine after uninstalling A/V software?
My System SpecsSystem Spec
01 Jun 2010   #9
Mizzhell

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by Mizzhell View Post
Quote   Quote: Originally Posted by chev65 View Post
In the past this problem has been one of three things.

Either your router settings need adjusting but it's difficult to say which settings are causing this or your A/V software or a third party networking software is causing the problem so uninstalling them and checking to see if anything changes might be worth while.

This can also be a problem with your network drivers.
Have uninstalled avira antivirus and the software which came with the usb stick, but no difference..
I'm using the same drivers as before, can't find others and it worked for 2 years on win 7, until I came here.
Windows 7 hasn't been out for two years.
Have you tried using different router settings or rebooting your machine after uninstalling A/V software?
Sorry, lol @ me, 1 year, since some RC.
Have RS the computer, and cleared the router, no change
My System SpecsSystem Spec
01 Jun 2010   #10
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Seems like it may be a router problem in this case because changing to a different router seemed to create this problem for you. I wasn't reading that very clearly, sorry bout that.

You should try to install the latest firmware for that router, it will be different firmware depending on the router hardware version. Trying different types of router security settings or a different router channel may also help.
Linksys by Cisco - WRT54GL Support
My System SpecsSystem Spec
Reply

 Internet speed drops, win 7




Thread Tools





Similar help and support threads
Thread Forum
Internet Speed Fluctuations. Connection Drops when Playing Games
Hello, thank you for taking the time to help me out with this problem. A few days ago my internet started really acting up. Not the connection to the router, the speed would slow dramatically at random points and then come back up to normal speed. I could deal with this except for the fact...
Network & Sharing
connection speed drops after minutes connected
I can connect to the internet and browse but after anywhere from a minute to ten minutes my connection speed drops or i get disconnected all together. I only have this problem at school in my dorm. It works fine on my wifi at home and in other buildings on campus. I know nothing is wrong with my...
Network & Sharing
Internet sharing via Virtual Wifi miniport drops internet access
Hi All, I have established a Virtual Wifi Miniport and would like to share my laptops internet via the Miniport. Whenever I connect my android phone with this access point, it works perfectly for a few minutes and then all of a sudden there is no internet on the phone. The phone remains connected...
Network & Sharing
Upload speed drops to zero
The speed test on my 2 Windows7 machines (PC and netbook) have recently started to show a fine download speed but when measuring upload speed the dial moves up to 400 and then gradually sinks back to zero over the next couple of minutes. It doesn't register any final upload speed. I can upload...
Network & Sharing
HDD Speed Drops?
When ever I'm transferring something or if hdd is being use by another program. I can't do any else.. It drops the Speed bad. I have a Fresh copy of windows 7 Ultimate. I believe AHCI.. I Ideas would help.. My Hdd is a seagate 1tb 7200rpm
Hardware & Devices
Wireless speed drops to almost halt, Windows 7 64 bit
I just built a system with Windows 7 Home Premium 64 bit with a Gigabyte WP30N wireless card. When connecting to my router (a Netopia 3357), the network speed is initially OK (500kb/s), but then drops straight to a consistant slow (20kb/s). The time it takes for the speed to drop is anything...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App