Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to get signal downstairs

01 Jun 2010   #1

Windows 7 64bit
Unable to get signal downstairs


About a week ago i bought a Belkin N+ wireless router which ive installed upstairs and it worked fine. Ive used it with the built in realtek adapter in my laptop without any problems for the last week. The desktop connected to the router works fine and my laptop also works fine when im in the same room as the router. However today randomly i can no longer get signal downstairs at all. I used to get 3 or 4 bars but now i get a wide range of errors when i try to connect.

Some of these errors are:
  • Network appears on list of networks but when i connect it says "Unable to connect".
  • I can connect to network but it says "No internet access" and i cant use internet or access other computer upstairs.
  • I can connect with 5 bars of signal and no error appears but i still cant access the internet or network.
  • I can connect but it disconnects itself and then says "No networks available" even though there are 5 other networks that it normally finds"
  • I can connect and i get 5 bars of signal but it is incredibly slow - almost dial up speeds.
  • I can connect but it then says "Identifying..." for ages and then says "Unidentified network - no network access"
  • The network disapppears when i try to connect and the keeps reappearing and disappearing every few seconds.
  • It says "connecting to network..." indefinatley.
  • On very rare occasions i connect fine
I think its a signal issue but that doesnt explain why it used to work fine downstairs and now doesnt with no changes. Ive tried the following things to fix it with no luck:
  • Resetting adapter and router
  • Repositioning router
  • Changing angle of antenna
  • Performing a factory reset
  • Trying several different channels on both 20mhz and 40mhz mode
  • Changing to 802.11n only mode
  • Turning protected mode on and off
  • "Trusting" my laptops mac address
  • Updating router firmware
  • Updating realtek adapter driver
  • Uninstalling and reinstalling adapter which sometimes temporarily fixes it
  • Turning off power saving for adapter
  • Changing adapter to 802.11g which fixed it once
  • Turning off security
None of these things have permenantly fixed it. Windows 7 troubleshooter says "Investigate a router or access point issue" or it says it fixed "A problem with wireless adapter" but the problem is never fixed. Ive used network stumbler and when these problems occur downstairs the signal fluctuates significantly but it is still fairly high. For me it seems it could be signal, the router or the adapter as the problem is sometimes fixed by driver updates but it then stops working again. I have no other wireless devices which makes it harder to find out which part is the problem. Any help would be greatly appreciated.


My System SpecsSystem Spec
02 Jun 2010   #2

Windows 7 64bit

I have now tried every channel induvidualy and that hasnt solved the problem. It seems unlikely that its the router now
My System SpecsSystem Spec
02 Jun 2010   #3

Windows 7 Ult, Windows 8.1 Pro,

There is a very high probability that which ever A/V software you have installed is causing this problem. Happens all the time and it doesn't seem to matter which one because they all seem to cause similar problems such as you are describing. Also, those so called third party networking programs are also famous for creating problems like this.

It's usually required that you uninstall them completely in order to fix the problem.
My System SpecsSystem Spec


 Unable to get signal downstairs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
using old router up stairs along side new router downstairs?
hi again, i had a new router turn up from talk talk as the last one we had was a few years old but still works fine. i am wondering since i have new router downstairs can i use the old router upstairs so we have a good solid signal through all of house? if so what is the best method for this as the...
Network & Sharing
Wireless network adapter is unable to hold a signal
A couple days ago, I began having serious issues with my network adapter. It is unable to maintain a signal to the internet. When I say "maintain" I mean that it cuts in and out a lot. What it will do is, it will lose a internet signal, meaning, it is connected to the router but says "No internet...
Network & Sharing
Can Noise and movement vibration damage laptop from downstairs in this
If the laptop is upstairs(bedroom) sitting on a Desk but below the room is the kitchen and then you hear hard bashing noises + Could feel the vibrations(If someone was using a hammer and bashing on a chopping board(Stopped around maybe 20 times) from above the bedroom floor like echoing. It...
General Discussion
Problems in ad-hoc wifi network - signal strength weak, unable to ping
Hi, I need some help with Win7 wifi. I'm trying to create an ad-hoc wifi network between my Windows 7 laptop (Toshiba c650) and my samsung wave y handset. My wifi card is atheros-AR9285. When I connect to this network from my wifi, connectivity is established, but with some problems: It...
Network & Sharing
Wifi shows connected with full signal but unable to surf the internet
As shown here: I connected to HTC Aria Wifi Hotspot and on the task bar it shows full signal. On the network and sharing center, there was a 'RED CROSS' although it said Access Type : Internet. After I connected to the...
Network & Sharing
WMC and TV Tuner - No Signal / Too Weak a Signal
I have owned several TV Tuners in the past and this is the first OS that has given me problems. I have a Hauppauge WinTV-HVR-1950 (USB 2.0hs) and cannot get a picture from my Cox Cable Service in Orange County, Southern CA. Installed the 64bit driver from Hauppauge. According to Device...
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:19.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App