Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Ethernet not detected

05 Jun 2010   #1

Ethernet not detected

Hello all!
I know there have been some threads about this issue before, but I couldnt find a solution to my problem there:
Until today I had Windows XP running on my new system, which consists of:
  • Mainboard: Asus M4A87TD
  • Athlon X2
  • Ram and other hardware.
The network adapter is a onboard solution and is:
RTL8111E PCIe Gigabit Lan controller featuring AI NET 2 (by Realtek).
From there it is connected via cable to a router which itself is connected to a dsl-modem.
Running under Windows Xp I could connect to the internet and to the network without a problem.
Now I installed Windows 7 Home 64bit. After installing all drivers I still get the error message: No networkcable connected.
What I did so far to get a solution:
- Download and install the newest driver for the network adapter (7.018) from the realtek site
- Download and update BIOS (Version 0810) from asus site

After that the networkadapter showed in DM that it was working and running - what it obviously didnt.

- Installed Windows7 32bit - same problem
- Installed Ubuntu in 32bit and 64bit version - same problems as under Win7
- Cable and router work fine, have 3 other PCs on the router, 2 with Xp/Linux and one with vista
- I also tried to boot the pc without cable connected and plug it in later - no changes

Then I put Windows XP back on it and the connection worked again -_-

The next step I will do is to update the router software (ofc I did restart it like 5 times until now), but I doubt that it will help much.

Any thoughts on that problem?
Thanks in advance!


My System SpecsSystem Spec

05 Jun 2010   #2

Windows 7 Ultimate x64 SP1

Did you install the chipset drivers available from Asus?
My System SpecsSystem Spec
06 Jun 2010   #3


I did install the chipset drivers. I just checked again and they are all the latest versions.
My System SpecsSystem Spec

06 Jun 2010   #4


I solved it now somehow. Dont ask me how exactly but it is working now. My best guess is that the static IP I put into the advanced properties of the network adapter worked this time. It is not static anymore but maybe it triggered something who knows

At least it works now
My System SpecsSystem Spec

 Ethernet not detected

Thread Tools

Similar help and support threads
Thread Forum
Ethernet Lan Cable not detected
Ethernet Lan Cable not detected on my computer . last week it was working and now its not idk why . my friend told me to reset the bios setting so i removed the cmos and reseted the settings still not working and i also installed the latest driver for my 82579V Gigabit Network . Help pls i cant...
Network & Sharing
Thinkpad T60 ethernet connection not detected
Hello, recently I installed windows 7 on my Lenovo T60. First I thought the install went flawlessly because I was able to access the internet but later I realized that I was accessing the internet through wireless and my ethernet port was not detected. I installed the intel chipset driver but I...
Network & Sharing
Ethernet cable not detected!!
Hey everyone, Since I'm on a campus, I'd like to download shit with a real nice speed, but the only problem is, when I connect my ehternet cable, it won't connect or something. If I go to the adapter settings, it says that the wireless network connection is fine, but the local area connection...
Network & Sharing
Ethernet cable not detected
One of my Windows 7 computer has been getting an error for 24 hours that the ethernet cable is not detected and it can not connect to the internet. Other Windows 7 computers on the same router/internet connection work fine. I have already tried the following all of which were not successful....
Network & Sharing
HELP! ethernet cable not being detected
Hi, I am using windows 7. i have upgraded from vista recently. My internet connection has been cutting out infrequently over the past month, but now it has cut out completely. windows is detecting the problem as a either a faulty ethernet cable or as a cable not being connected. I have tried; ...
Network & Sharing
Ethernet cord not detected
Hey guys, I just installed Windows 7 on a new computer, and I can't get it to detect my ethernet cord. The light on the card that the cord plugs into lights up, and I could access the internet when running a Knoppix live CD, so I don't think it's a hardware problem. I'm fairly inexperienced...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:47.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App