Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Shares work over ethernet but not wirelessly

08 Jun 2010   #1

Windows 7
 
 
Shares work over ethernet but not wirelessly

I have a desktop PC and a laptop both connected to a Cisco WRT320N router and both running Windows 7 Home Premium. They are both in the same Homegroup and if they are both connected to the router by Ethernet cable then all the SHARES function correctly.
I get a problem if I connect the laptop wirelessly to the router, then I get the message "Windows cannot access \\computername\sharename". I have tried a different type of router but the result is the same. Is there some setting I need to alter to make the shares function through a wireless connection?

My System SpecsSystem Spec
.

08 Jun 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by sads45 View Post
I have a desktop PC and a laptop both connected to a Cisco WRT320N router and both running Windows 7 Home Premium. They are both in the same Homegroup and if they are both connected to the router by Ethernet cable then all the SHARES function correctly.
I get a problem if I connect the laptop wirelessly to the router, then I get the message "Windows cannot access \\computername\sharename". I have tried a different type of router but the result is the same. Is there some setting I need to alter to make the shares function through a wireless connection?
Are both the desktop and laptop win 7? You may want to try a new netwrok connection using workgroup instead of homegroup. Homegroup on sime systems has connectivity issues.
To test simply make a new network connection using workgroup instead. If it fixes the problem you can disable IPv6, and kill homegroup

Ken
My System SpecsSystem Spec
08 Jun 2010   #3

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

You can try either leaving the Homegroup while connected to the wired connection, then rejoin the same Homegroup using the wireless connection or, if the problem persists, there is most likely an A/V software or third party firewall causing the problem. Be sure and check the Homegroup sharing permissions after doing this.

You may also need to temporarily uninstall your A/V software until after you get Homegroups working again.

The link below is the Homegroup trouble shooting guide which shows common problems you might run into when setting up a Homegroup.
Ultimate Troubleshooting Guide for Windows 7 HomeGroup Connection Issues

Homegroup - Leave
Homegroup - Add Computer or Join
My System SpecsSystem Spec
.


09 Jun 2010   #4

Windows 7
 
 

I have almost fixed the problem. I changed some settings in the Firewall of "Kaspersky Internet Security" and I can now SHARE using WORKGROUP. Some of the libraries in HOMEGROUP are visible on the laptop but 2 of them show "no folders have been included in this library" even though that is untrue. I now have a usable system, thanks for your assistance. I will continue to attempt to resolve the HOMEGROUP issue.
My System SpecsSystem Spec
09 Jun 2010   #5

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

Kapersky,...that explains it LOL. If you want everything to work simply uninstall Kapersky. Usually if you reinstall it after you get everything working you will be ok. I really wish that people would tell us they are using an A/V when reporting about sharing problems because it would be first thing I'd go after.

Real time protection A/V's cause nothing but problems in my opinion. The entire point behind A/V's is to prevent problems not create them. In that regard they fail miserably.

Both Windows 7 and Homegroups work absolutely perfectly for me, there are zero reasons to abandon Homegroups for any reason. There are no "issues" with Homegroups, the fault lays completely on the A/V software being used. I've tested Homegroups out for over a year on 5 completely different machines and I can't find any problems at all.
My System SpecsSystem Spec
Reply

 Shares work over ethernet but not wirelessly





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:38 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33