Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 SLOW Wireless Internet Connection

11 Jun 2010   #1
technomann

Windows 7 64-bit
 
 
Windows 7 SLOW Wireless Internet Connection

Two PCs side-by-side connected to my home wireless network - my Vista Home Premium 64-bit laptop, and my brand new HP Windows 7 Home Premium 64-bit desktop. I start up both and connect to the internet. The Vista laptop connects fine and displays web pages in a resonably fast time. My new Windows 7 desktop, however, takes FOREVER to even load my Google home page. The graphics take FOREVER and even hang and refuse to load. Forget about downloading anything as pages will hang and refuse to load.

What's going on here? Can anyone provide me some clues on how to troubleshoot this?

Thanks for any and all advice!


My System SpecsSystem Spec
.
11 Jun 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by technomann View Post
Two PCs side-by-side connected to my home wireless network - my Vista Home Premium 64-bit laptop, and my brand new HP Windows 7 Home Premium 64-bit desktop. I start up both and connect to the internet. The Vista laptop connects fine and displays web pages in a resonably fast time. My new Windows 7 desktop, however, takes FOREVER to even load my Google home page. The graphics take FOREVER and even hang and refuse to load. Forget about downloading anything as pages will hang and refuse to load.

What's going on here? Can anyone provide me some clues on how to troubleshoot this?

Thanks for any and all advice!

You are probably running Homegroup which uses iPv6. Mixed OS network seem to work better using workgroup (IPv4) . You can test this by simply creating a new network connection using workgroup. If it works you can then disable IPv6 and kill homegroup


Ken
My System SpecsSystem Spec
12 Jun 2010   #3
technomann

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Quote   Quote: Originally Posted by technomann View Post
Two PCs side-by-side connected to my home wireless network - my Vista Home Premium 64-bit laptop, and my brand new HP Windows 7 Home Premium 64-bit desktop. I start up both and connect to the internet. The Vista laptop connects fine and displays web pages in a resonably fast time. My new Windows 7 desktop, however, takes FOREVER to even load my Google home page. The graphics take FOREVER and even hang and refuse to load. Forget about downloading anything as pages will hang and refuse to load.

What's going on here? Can anyone provide me some clues on how to troubleshoot this?

Thanks for any and all advice!

You are probably running Homegroup which uses iPv6. Mixed OS network seem to work better using workgroup (IPv4) . You can test this by simply creating a new network connection using workgroup. If it works you can then disable IPv6 and kill homegroup


Ken
I haven't set up a Homegroup or a workgroup. Each machine has it's own wireless adapter connected to the AT&T wireless router...
My System SpecsSystem Spec
.

Reply

 Windows 7 SLOW Wireless Internet Connection




Thread Tools





Similar help and support threads
Thread Forum
My laptop's Internet connection is slow when connected via Wireless.
Hi guys. It's been some time since my Dell XPS M1530 laptop has been having Internet issues when connected via Wireless. It currently sports an Intel 4965 AGN card with Windows 7/8 pre-installed drivers and is connecting wirelessly to a Thomson router. It connects smoothly, but its reception...
Network & Sharing
Wireless Internet Connection Dropping/Slow
Recently started having trouble with my Wireless internet. Im using Windows 7 X64, have been for ages. Recently, ive been having trouble connecting to the net using a wireless PCI Card WPN311. It connects, but basically doesn't show anything, the green bar for loading takes a lifetime. ...
Network & Sharing
Verrrrrry Slow Internet Connection - wireless
This is a new computer with Built-in wireless LAN (802.11b/g/n). Windows 7 Home Premium Edition 64-bit AMD Athlon™ II quad-core processor 645* 6GB PC3-10600 DDR3 SDRAM ATI Radeon HD 4200 integrated graphics Router is netgear wnr834bv2 with up-to-date firmware All windows updates...
Network & Sharing
Windows 7 SP1 causes slow internet connection
Hi, I formatted my 32bit Vista PC this weekend and loaded Windows 7 64bit on here. All fine, except my internet connection speed has now plummeted from around 15Mb to 8Kbps!! It's taken about 5 mins just to load this page :( I've Googled and there seems to be a lot of similar issues. I've...
Network & Sharing
Windows 7 Slow Wireless connection
This "slow" internet connection did not happen in Windows XP. (54.0 Mbps) Its only when I first bought a new computer with Windows 7 then this slow connection starts to happen. (1-2 out of 5 bars) Plugging directly to the router won't work since the distance between my router and my cpu's back...
Network & Sharing
Very, very slow internet connection on Windows 7
Hi, it's my 1st post on this forums. I've got huge problem with my internet connection on Windows 7. I have 6Mb/s internet connection (always downloads 750-800 kbps - it is not my bandwich issue, cause on my iMac wirelessly everything runs great). I have Kasypersky Internet Security installed. I...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App