Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 VM No installed network adapter

29 Jun 2010   #1
karrow

VMWare ESXi Server 3.5.0
 
 
Win7 VM No installed network adapter

Hello all,

I recently created a Win7 image in VM Workstation 6.5.3. On the host machine (running Windows XP) I was able to access the internet using a NAT connection. Unfortunately, when I migrated the image to my VMWare ESXi Server (3.5.0), it was unable to connect to the internet.

The error message I get is "Windows did not detect a properly installed Network Adapter...". I'm really not sure what could be causing this issue. The Hardware tab in the VM Settings says that Network Adapter 1 exists and is a VM Network. The Device Status Connected checkbox is checked, as is the Connect at power on checkbox. Adapter type is set to flexible.

Does anyone know if there is a hardware compatibility issue for network adapters for Win 7 images on VMWare ESXi or something?

Any help would be appreciated.


My System SpecsSystem Spec
.
07 Jan 2012   #2
crownstar

64bit Home Premium Windows 7
 
 

Over a year and a half and still not a reply ?

It sounds like I am currently ran up against this same issue but i know for a fact I have created a NEW CLEAN BLANK virtual hard drive with Virtual Box ver. 4.1.8 Newest last stable edition . ..

It have got it to work , boot up and all but NO NETWORK ADAPTER HARDWARE FOUND !!!

I have been spending days on this trouble and about to switch back over to vmware player or virtualpc or ....

I can not just seem to find any solution for this delima .

I even tried bridging my Ethernet hardware RealTek NIC card with my Belkin Router to no avail ..

So if anyone would care to shed some light on this i would be very appreciated !

Windows 7 64x Home PRemium - Host Windows 7 64x Home PRemium - guest
My System SpecsSystem Spec
07 Jan 2012   #3
Solidwave

Win7Ultimate x64 + x32, Win7Pro x64, XP x32, Win 2003, Ubuntu and OpenIndiana
 
 

Crownstar, you probably have a VirtualBox issue. Make sure you have a network adapter enabled in your VB settings for your Win7 VM and install the VirtualBox guest additions. If that doesn't help, try the VirtualBox support forum at forums.virtualbox.org.
My System SpecsSystem Spec
.

07 Jan 2012   #4
crownstar

64bit Home Premium Windows 7
 
 

< SOLVED > I found another image creation of my NAT network setting and copied the working settings and it works !

sometimes just talking it out helps

thanks for listenin ! ;p
My System SpecsSystem Spec
07 Jan 2012   #5
crownstar

64bit Home Premium Windows 7
 
 

Oh I forgot in case anyone else having this trouble / issue with network adapter not found / reconized in win7 VMachine.

Network (WORKING) config is

Adapter 1 set to NAT

Advanced TAB : Intel PRo /1000 MT Desktop (82540EM)

Promiscuous : DENY

Both Network Adapter and Cable connected boxes checked !

happy surfin !
My System SpecsSystem Spec
13 Feb 2012   #6
haroldh

Windows 7 Profesional 64 bit
 
 

Hello,
This reply is not an answer, but is a question about an issue I have that seems related to the above question. I just installed VirtualBox on my computer that is running Windows 7 Professional as the host. I created two vms, each running Windows Server 2003 R2. The two vms are configured to use a bridged network, so that they can communicate with each other and the host. At present, neither is able to connect to the host network, so they cannot communicate with each other, nor can either connect to the Internet. I am not surprised since IPConfig shows no IP address for either vm. I am new to VirtualBox, and I am not a network guy, so I am not sure what is causing the problem.
I checked the network card driver on each vm, and Windows Server reports this error message:
"This device cannot start. (Code 10)
Click Troubleshoot to start the troubleshooter for this device."
I reinstalled each driver, but get the same error.
The VirtualBox ethernet adapter on my host OS says "This device is working properly.", so I think I have missed some configuration settings.
Does anyone here have any thoughts on what is missing, or incorrect?
Any help is appreciated. Thanks
My System SpecsSystem Spec
06 Apr 2012   #7
huky

winxp (vbox); win7 ultimate (vbox)
 
 

Quote   Quote: Originally Posted by crownstar View Post
Oh I forgot in case anyone else having this trouble / issue with network adapter not found / reconized in win7 VMachine.

Network (WORKING) config is

Adapter 1 set to NAT

Advanced TAB : Intel PRo /1000 MT Desktop (82540EM)

Promiscuous : DENY

Both Network Adapter and Cable connected boxes checked !

happy surfin !
This works Thanks
My System SpecsSystem Spec
Reply

 Win7 VM No installed network adapter




Thread Tools




Similar help and support threads
Thread Forum
Windows did not detect a properly installed network adapter.
Hello. I have a custom build PC that i finally finished a couple of nights ago but it has been acting up. I have been to so many other forums and found no help what so ever! My specs are Motherboard-Gigabyte 990xa-UD3 CPU-AMD FX-6300 GPU-Radeon HD 7850-Sapphire edition Okay so im going to...
Network & Sharing
INTEL i3 Installed 7 from 8 and cannot find driver for Network Adapter
Hi. I recently downgraded my pc from 8 to 7 and now i cannot connect to internet due the absence of a network adapter drivers and other problems with drivers. Thank you for the help!
Drivers
Windows says did not detect properly installed network adapter. T.T
Good morning! My problem is : I just reinstalled windows 7 ultimate 32 bit (I have the disc) but I cant connct to internet for it says there is no properly installed network adapter. Hope you can help me out with this. info. Windows 7 Ultimate x32 Version 6.1.7600 build 6700 Intel...
Drivers
Windows Did Not Detect A Properly Installed Network Adapter.
I recently bought A new computer from ebay. Here is the link Vibox 4.2GHz I am not really good with computers, I spoke to a friend and they said to uninstall and install the network adapter but I really have no idea where to find the network adapter. If someone will help I will be really...
Network & Sharing
Installed Windows 7 and internet now says no network adapter.
I just installed Windows 7 onto a Dell Vostro 230. After installing, the internet has a red X on it and it says no network adapter. I have no idea what to do. Help please! Thank you!
Network & Sharing
network adapter not installed?
for some reason windows is not letting me connect to the internet and when i troubleshoot it sais that the network adapter is not installed. When i go to device manager it sais that the ethernet controller, network controller, and pci simple .communications controller are not installed. so i go...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App