Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7: DHCP works fine, but NO Static IP


30 Jun 2010   #1

W7
 
 
W7: DHCP works fine, but NO Static IP

I got a little problem getting the static ip configuration to work on one of the Windows 7 machine, DHCP works but i need to be static. Here is the layout of my network:

1. Modem conected to:

2. 4 port wireless router conected to:

3. 8 port SMC giga switch conected to:
3a. Windows 7 computer - static ip
3b. WinXP computer - static ip
3c. Network printer - static ip
3d. Network camera - static ip
3e. 5 port SMC giga switch

3e. The 5 port SMC giga switch conected to:
3ei: WinXP computer - static ip
3eii. Windows 7 computer - with two lan cards
Lan card 1: its a 10/100 card that works both in DHCP and static form. (its disabled right now)
Lan card 2: ITs a 10/100/1000 card that only seems to work in DHCP form. Once i set it up as static, the computer wont see the network (without connection).

Notes:
1. Both Windows 7 boxes are configured the same way except the ip number of course.
2. The ip range on the network is in the 192.168.1.xxx
3. Gateway and Primary DNS: 192.168.1.1
4. Subnet: 255.255.255.0
5. I have disabled IPv6 (read in forums that might help) still doesnt work.

I have ran out of ideas.. :s

My System SpecsSystem Spec
.

07 Jul 2010   #2

Windows 7 Ultimate X64 SP1
 
 

Welcome Kamaelon,

Have you tried "reserving" a static IP address from the DCHP pool? If you dont know how to do this, post back with your router model and I will make a rough guide for you
My System SpecsSystem Spec
07 Jul 2010   #3

Windows7 Ultimate 64bit
 
 

Have you test ping in static IP mode? Make sure you only have one IP address on that particular interface, no additional IP addresses bonded to it. Make sure there's no other active network connection other than that interface.

If you can, please post ping test results...

zzz2496
My System SpecsSystem Spec
.


07 Jul 2010   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by kamaleon View Post
I got a little problem getting the static ip configuration to work on one of the Windows 7 machine, DHCP works but i need to be static. Here is the layout of my network:

1. Modem conected to:

2. 4 port wireless router conected to:

3. 8 port SMC giga switch conected to:
3a. Windows 7 computer - static ip
3b. WinXP computer - static ip
3c. Network printer - static ip
3d. Network camera - static ip
3e. 5 port SMC giga switch

3e. The 5 port SMC giga switch conected to:
3ei: WinXP computer - static ip
3eii. Windows 7 computer - with two lan cards
Lan card 1: its a 10/100 card that works both in DHCP and static form. (its disabled right now)
Lan card 2: ITs a 10/100/1000 card that only seems to work in DHCP form. Once i set it up as static, the computer wont see the network (without connection).

Notes:
1. Both Windows 7 boxes are configured the same way except the ip number of course.
2. The ip range on the network is in the 192.168.1.xxx
3. Gateway and Primary DNS: 192.168.1.1< Default Gateway, > DNS server should look something like 8.8.8.4 which is Googles primary DNS server.
4. Subnet: 255.255.255.0
5. I have disabled IPv6 (read in forums that might help) still doesnt work.

I have ran out of ideas.. :s
The new LAN card may be looking for the actual DNS server that your router is using. When you do an ipconfig you only get the gateway to the DNS and not the actual DNS server that the router is using. You can get the actual DNS server from your routers set up page.
My System SpecsSystem Spec
08 Jul 2010   #5

W7
 
 

Thanks for your replies guys, here is more info:

Severedsolo: the router is a Draytek Vigor 2100G - everytime i reboted the computer (when in dhcp mode) the same ip would be assigned and right next to it said (preffered)

zzz2496: i was wrong about not being able to see the network, i can ping all computers in the network normally and do remote desktop connection (which was my main goal for this comp) but it had no connection to go online .. interesting ..

chev65: the DNS server i put in the nicīs config is the same as the routerīs gateway. i dont quite follow your idea.. do you mean the routers dns is different than the 192.168.1.1? if so how is it working in all the other computers but this one?

Right now, im using both nic cards at the same time, the 10/100 i use for browsing the net and the giga card for to connect to it via remote desktop (much faster). I would like to solve the initial problem get it to work with just one card
My System SpecsSystem Spec
08 Jul 2010   #6

Windows 7 Ultimate X64 SP1
 
 

Well thats useful your router doesn't allow reservation of IP addresses.

I think your problem is that you are assigning static IP's that are in the DCHP pool.

Basing these instructions on your routers manual, so apologies if they are wrong.

I am going to assume that nothing on your network has a static IP of 192.168.1.2 if ti does, then revise the number up to the next available address

First disconnect all network devices from the router (or switch them off) except for the machine you are setting this up with.

Open up the routers main page (normally http://192.168.1.1) and click LAN then "LAN TCP/IP and DCHP" settings

change the "start IP address" to anything above 192.168.1.2 (for instance, 192.168.1.3) then reboot the router.

assign the 2nd Lan card a static IP of 192.168.1.2 PortForward.com - Free Help Setting up Your Router or Firewall and set up DNS etc.

Reconnect all your devices
My System SpecsSystem Spec
Reply

 W7: DHCP works fine, but NO Static IP




Thread Tools



Similar help and support threads for2: W7: DHCP works fine, but NO Static IP
Thread Forum
DHCP and static ip simultaneously, one nic ? Network & Sharing
Assign DHCP & Static IP of other subnet to the same NIC ? Network & Sharing
Internet Only Works w/ Proxy Server (Works fine everywhere else though Network & Sharing
dual net config dhcp or static ip Network & Sharing
W7: DHCP works fine, but NO Static IP Network & Sharing
How to enable DHCP and Static IP adress on the same NIC ? Network & Sharing
Switch from DHCP to Static IP Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 04:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33